AutoCAD LT General

Reply
*Expert Elite*
drjohn
Posts: 1,690
Registered: ‎03-01-2006
Message 11 of 16 (230 Views)

Re: xref problem

12-11-2012 10:09 AM in reply to: TP000

As Charlie would say, SWAG ....

 

First check to see if anyone else has that dwg checked out for xref .... if not, try going to the dir they are stored in and if there are dwl files there, delete them.  Sometimes if a dwg crashes AutoCAD does not clean up after itself and it leaves the dwl files that are lock files.

 

Maybe ... just a shot in the dark.

 

Regards,

DJ

 

 [edit]

@Charles:  sometimes you don't know if you don't use it much.  :smileyhappy:

[/edit]

 

 

 

Active Member
TP000
Posts: 7
Registered: ‎12-11-2012
Message 12 of 16 (206 Views)

Re: xref problem

12-12-2012 04:05 AM in reply to: drjohn

Hi DJ,

 

Right yes thank you, I seem to be 'making' dwl files almost before Ive even done anything to a file. Is my computer powerful enough to cope with xrefs? I am deleting them as soon as I can when I see them, and am having more success with edit in place now. I have to wait for the computer to catch up with what I am doing.

 

Its still not perfect. Could the server be slow too? When I say delete image files from a folder it takes a while for the changes to be visible. So when someone else checks something back in it takes a few mins to become fully avail for edit???

 

All the best, Naomi

*Expert Elite*
pendean
Posts: 21,655
Registered: ‎11-06-2003
Message 13 of 16 (201 Views)

Re: xref problem

12-12-2012 05:08 AM in reply to: TP000

If after closing a file the associated DWL files remain, this old tip may help:

http://www.cadforum.cz/cadforum_en/qaID.asp?tip=3186

Dean Saadallah Blog | Facebook | Google+ | Twitter | PINS
*Expert Elite*
drjohn
Posts: 1,690
Registered: ‎03-01-2006
Message 14 of 16 (194 Views)

Re: xref problem

12-12-2012 07:20 AM in reply to: TP000

TP000 wrote:

Hi DJ,

 

Right yes thank you, I seem to be 'making' dwl files almost before Ive even done anything to a file. Is my computer powerful enough to cope with xrefs? I am deleting them as soon as I can when I see them, and am having more success with edit in place now. I have to wait for the computer to catch up with what I am doing.

 

Its still not perfect. Could the server be slow too? When I say delete image files from a folder it takes a while for the changes to be visible. So when someone else checks something back in it takes a few mins to become fully avail for edit???

 

All the best, Naomi


Well, don't go overboard on this. A DWL (and DWL2 depending on ACAD version) file is created as soon as you open the drawing file.  You don't want to delete DWL files that are there for a DWG that is open.  Especially in a multi-user environment.  They are intended to keep "Bill" from opening a file that you are working on cause the last person to save wins :smileymad: . Only delete the DWL files that are not protecting open drawings.

 

If they are becoming an issue or the IT department has set your server working dir so that you cannot delete from there then talk to them or follow the tip Dean posted. You may need to have full admin on your box to make those changes, though.

 

Regards,

DJ

 

[edit]

 

One other thing to try with the Edit In Place issue is to select the xref and rather than double clicking to edit it, select the EIP icon (a paper with a pencil and a paperclip) and see if that works.

 

There is a switch/option also for using double click to EIP but for the life of me I can't remember it .  Charlie?  Dean?

 

[/edit]

 

 

 

*Expert Elite*
Charles_Shade
Posts: 8,196
Registered: ‎04-10-2005
Message 15 of 16 (179 Views)

Re: xref problem

12-12-2012 12:05 PM in reply to: drjohn

Could it be XEDIT?

And to the OP: Is this set to 1 in your drawing? It is Drawing specific.

 

Open the Help file and type XEDIT. The second item should be Commands for Editing External References.

There are several there you should become familiar with (As I am now DJ :smileyfrustrated:)

 

Regards, Charles Shade            Win8 FAQ
CSHADEDESIGN|AUTOCAD LT|LT-KB|DYNAMIC BLOCKS

 
Please mark Accept as Solution if your question is answered. Kudos gladly accepted.
Active Member
TP000
Posts: 7
Registered: ‎12-11-2012
Message 16 of 16 (168 Views)

Re: xref problem

12-13-2012 03:42 AM in reply to: Charles_Shade

Hi Charles & DJ,

 

I think the combination of deleting stuck dwl's, opening files from the programme not explorer have helped me thank you. The OP was set to 1 already.

Ive looked at XEDIT now too.

Its not perfect - Ive only crashed out once today :smileywink:

So thanks again, Illl muddle on now.

 

Best wishes, N

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community