AutoCAD Electrical General Discussion

AutoCAD Electrical General Discussion

Posts: 21
Registered: ‎10-09-2012
Message 1 of 14 (876 Views)
Accepted Solution

Catalog error since SP1

876 Views, 13 Replies
10-09-2012 11:04 AM

Im not sure if this issue has been addressed already. I checked and didn't find anything on it.


I've been unable to use components "Lookup" function ever since I got the SP1.

I've been on ACADE 2013 for a couple of months now and the "Lookup" function has been working perfectly fine, until a few days ago. Now when I try to use the Lookup button on any project, ACADE freezes and I have to force close it. It actually locks up all my programs until I close ACADE.  


Im not absolutely positive its the SP1 that caused this, I could have changed a setting that caused it, but I can't figure out what it could have been. Im hoping its just a silly mistake on my part. I'll try to give as much info as possible.


-I believe I have the "default_cat.mdb" in the right folder (it matches the "Active catalog lookup" search path). However a locked file called "default_cat.ldb" is in the same folder as the .mdb, im not sure if that is suppose to be there.

-Here is info from the wd.env file:

* Catalog Parts Database Path
WD_CAT,%WD_DIR%/catalogs/,AE catalog file path
*WD_XCAT,x:/some path/wd_xcat.lsp,to override catalog look-up and call user's external routine

-I used an untampered default_cat.mdb file from a coworker that worked for his ACADE, (which doesn't have the SP1) but it didn't work for mine.


I've attached a picture of what the error looks like, its nothing special.


I would really appreciate some help with this.


James Bunch

Posts: 208
Registered: ‎06-29-2011
Message 2 of 14 (820 Views)

Re: Catalog error since SP1

10-14-2012 02:08 AM in reply to: jbunch55



We have installed the ACE2013 SP1 in the Win7 64 OS in our side, but we can still use the catalog lookup to open the lookup dialog successfully with no issue.


Would you please help to try to uninstall the SP1, then check if the issue still happen? If after you uninstall the SP1, the issue is still there, then it should not be the SP1 cause the problem.


If it is not the SP1 cause the issue, then should be some settings you change or some special problem in your machine, as you mentioned the same catalog data file default_cat.mdb works well in other machines. If this is the case, can you try to uninstall the ACE2013 and reinstall it again to check if the issue still there?



Robin Shou    

Quality Assurance    

AutoCAD Electrical    

Autodesk, Inc.

Posts: 21
Registered: ‎10-09-2012
Message 3 of 14 (770 Views)

Re: Catalog error since SP1

10-18-2012 12:36 PM in reply to: RobinShou-Autodesk

Hello Robin,


Yeah, I confirmed that isn't not the SP1, by uninstalling it.

I tried the Look up function with the SPI uninstalled and it didn't work.


I've also tried a couple of other things too with out success.

After talking with someone from solidCAD for a bit, we came to conclude that the error is most likely with the computers hardware. It seems like the next thing to do, other then getting a new computer, is to try to uninstall ACADE.

Im not looking forward to this task, since I have a lot of custom settings. I will have to back up a lot of files.


Thanks for the help though.

James Bunch


*Expert Elite*
Posts: 1,081
Registered: ‎03-09-2004
Message 4 of 14 (767 Views)

Re: Catalog error since SP1

10-18-2012 01:11 PM in reply to: jbunch55

One thing that will make this a little less painful is if you use AutoDesk 360. I signed up and let it copy my settings (CUI) to the cloud and when I installed and activated ACE at home, logged into AutoDesk 360, waited a few minutes and bamm, all my customized menus there. I did not check for .MNU files for ACE, but all my RCM menus where available. Very cool.

Bob Hanrahan
Ace User since 1998
*Expert Elite*
Posts: 910
Registered: ‎09-21-2007
Message 5 of 14 (678 Views)

Re: Catalog error since SP1

10-29-2012 10:25 AM in reply to: jbunch55

Are you sure the program is hanging? If you press ESC, does anything happen?

Could be that the lookup-dialog is placed off screen...

Please select "Accept As Solution" if this post answers your question. Kudos don't hurt either. ;-)
Product Support
Posts: 303
Registered: ‎11-01-2005
Message 6 of 14 (648 Views)

Re: Catalog error since SP1

10-30-2012 10:04 AM in reply to: rhesusminus

If AutoCAD Electrical freezes or locks up when performing a catalog lookup, it could have to do with some table fields being empty in the database default_cat.mdb. At the very least, fields 1, 2, 4, and 5 must be populated for all records. We've seen this lockup issue caused by table records which don't conform to this. Once the lockup occurs, even switching back to the default catalog database (MDB) file won't correct the freezing behavior.


If you've confirmed that another Windows user works fine on the same workstation, then try the following:


  1. In the AutoCAD Electrical folder on the Windows Start menu, run Migrate Custom Settings > Export AutoCAD Settings.  This will create a ZIP file with backup copies of your CUI, LIN, CTB/STB, fonts, and other support files.
  2. Open the Windows Registry Editor and browse to the following key:
    HKEY_CURRENT_USER\Software\Autodesk\AutoCAD\R1x.x\ACAD-x007:409 (where the x value will vary with the version of Electrical that you have installed)
  3. Use the Registry Editor's File pull-down menu to export the ACAD-x007:409 key (for backup purposes)
  4. Delete the ACAD-x007:409 key
  5. Replace the default_cat.mdb with the default version or one that is known to be working
  6. Launch AutoCAD Electrical

The deleted registry key will be rebuilt and catalog lookup functionality should return to normal.

Zac Travis
Posts: 21
Registered: ‎10-09-2012
Message 7 of 14 (640 Views)

Re: Catalog error since SP1

10-30-2012 11:24 AM in reply to: zalant

Thanks Zac,


I deleted the key and added a default_cat that i knew worked, and now my lookup function works.

I imagine reinstalling ACADE would have done the same thing, but this way i didn't have to back up so much.

I lost my cuix settings but that isn't too big of a deal. Hopefully there isn't anything else that I've lost.


Thanks again,


James Bunch

Product Support
Posts: 303
Registered: ‎11-01-2005
Message 8 of 14 (609 Views)

Re: Catalog error since SP1

10-31-2012 08:25 AM in reply to: jbunch55

Thanks for your reply James.  I'm glad to hear that your lookup is working again.  I just now edited the list and added another step in order to back up the AutoCAD support files, in case they need to be put back after the procedure.  Hopefully, you're back together on that front.

Zac Travis
Active Contributor
Posts: 36
Registered: ‎11-09-2012
Message 9 of 14 (477 Views)

Re: Catalog error since SP1

11-09-2012 10:23 AM in reply to: zalant



This issue of AE2013 locking up when performing a lookup search has just happened to me as well. I must then manually force AE to close. I have seen several posts on this so I suspect this is more of a global problem. In all cases it seems that we have all verified that we do have the appropriate data in columns 1,2,4,5. You mentioned that you updated the steps for clearing this out. Would you please send those latest steps to me? Also, does Autodesk have an explanation as to why this is occuring so we can avoid in future?


Thank you,


Jeff Denny
Sr. Engineering Manager
Harris Corporation
Melbourne, Florida
Posts: 21
Registered: ‎10-09-2012
Message 10 of 14 (472 Views)

Re: Catalog error since SP1

11-09-2012 12:01 PM in reply to: jdenny



The latest steps were added to his original post, you can see that he edited it. I think Zac just added step 1, backing up your files first. I've been working with my catalog for a few weeks and I haven't encountered that error again. Just before the error occurred for you did you try to add a large "Secondary catalog lookup" to a project? Because I think my error happened shortly after I tried that.


Also, while I'm on the forum, do you know if there is any way to momentarily turn off terminal snaps? Sometimes I want to place a wire close to a terminal but not snap to it. It would be great to be able to disable able the snap for that one time.



James Bunch.

Manufacturing Community
The Manufacturing Community provides additional access to tips, tutorials, blogs and networking with peers.
Need installation help?

Start with some of our most frequented solutions to get help installing your software.

New AutoCAD Electrical Category!

The AutoCAD Electrical forum has moved into it's very own category page, and can no longer be found within the Additional Product Forums.