AutoCAD Electrical General

Reply
*John Pullen
Message 1 of 6 (67 Views)

Catalog Database Replication

67 Views, 5 Replies
02-27-2004 12:59 PM
I thought I was going to be really cool and tricky and use Access Database Replication to try and sync several different users catalog changes. Unfortunately, once I created a child replica, trying to edit a record from within ACADE causes a lockup. Any thoughts? -- John Pullen Doerfer Engineering
*John Pullen
Message 2 of 6 (67 Views)

Re: Catalog Database Replication

03-01-2004 07:02 AM in reply to: *John Pullen
I suppose I should have been a bit more descriptive. I can share a catalog on a server just fine. However, we travel with our computers and I'd like to make the catalog available when not connected to our server. Hence the desire for replication. John Pullen ----- Original Message ----- From: "Jacques Benoit" To: Sent: Monday, March 01, 2004 7:26 AM Subject: Re: Catalog Database Replication > I have multiple machines sharing the database on the our file server. > "John Pullen" wrote in message news:403fafb0_3@newsprd01... > I thought I was going to be really cool and tricky and use Access Database > Replication to try and sync several different users catalog changes. > > Unfortunately, once I created a child replica, trying to edit a record from > within ACADE causes a lockup. > > Any thoughts? > > -- > > John Pullen > Doerfer Engineering > >
*Nate Holt \(Autodesk\)
Message 3 of 6 (67 Views)

Re: Catalog Database Replication

03-01-2004 09:31 AM in reply to: *John Pullen
John, I am totally unfamiliar with this concept. Is this child replica an "mdb" file also? If so, there must be something different or odd about it that AcadE is choking on. Can you zip and email a copy? Nate. "John Pullen" wrote in message news:403fafb0_3@newsprd01... > I thought I was going to be really cool and tricky and use Access Database > Replication to try and sync several different users catalog changes. > > Unfortunately, once I created a child replica, trying to edit a record from > within ACADE causes a lockup. > > Any thoughts? > > -- > > John Pullen > Doerfer Engineering > >
*John Pullen
Message 4 of 6 (67 Views)

Re: Catalog Database Replication

03-01-2004 12:25 PM in reply to: *John Pullen
I sure can. I'll send the file direct. This is a detailed article about replication: http://msdn.microsoft.com/library/default.asp?url=/library/en-us/dnacc2k/html/dbrepjet.asp John "Nate Holt (Autodesk)" wrote in message news:40437369$1_3@newsprd01... > John, > I am totally unfamiliar with this concept. Is this child replica an "mdb" > file also? If so, there must be something different or odd about it that > AcadE is choking on. Can you zip and email a copy? > Nate. > > "John Pullen" wrote in message > news:403fafb0_3@newsprd01... > > I thought I was going to be really cool and tricky and use Access Database > > Replication to try and sync several different users catalog changes. > > > > Unfortunately, once I created a child replica, trying to edit a record > from > > within ACADE causes a lockup. > > > > Any thoughts? > > > > -- > > > > John Pullen > > Doerfer Engineering > > > > > >
*Nate Holt \(Autodesk\)
Message 5 of 6 (67 Views)

Re: Catalog Database Replication

03-01-2004 10:09 PM in reply to: *John Pullen
John, I checked out your file and it seemed to come up okay in AcadE 2004 on my machine. I could do catalog lookup and such without a problem. But when I opened the file with MS Access 2002, it gave me this alert msg "...missing or broken reference to file dao2535.tlb v3.5". But the file came up and displayed okay. Not sure what might be amiss... but your file seems to work okay. This is outside of my area of experience/expertise. Nate.
*John Pullen
Message 6 of 6 (67 Views)

Re: Catalog Database Replication

03-02-2004 08:56 AM in reply to: *John Pullen
Nate, Catalog lookup works fine, it's when I choose Edit from the catalog lookup that there's an issue. And it seems to behave differently when I'm editing a component that already has a catalog item attached than when I'm adding a new component. For editing, I get this message: error: bad argument type: fixnump: "" When adding, it brings up a blank edit screen and just hangs. Don't know why the dao message... There isn't any VBA code in there at all. (Although I am currently running Access 2003 but the file format is supposed to be the same.) John "Nate Holt (Autodesk)" wrote in message news:4044250f_3@newsprd01... > John, > > I checked out your file and it seemed to come up okay in AcadE 2004 on my > machine. I could do catalog lookup and such without a problem. But when I > opened the file with MS Access 2002, it gave me this alert msg "...missing > or broken reference to file dao2535.tlb v3.5". But the file came up and > displayed okay. Not sure what might be amiss... but your file seems to work > okay. This is outside of my area of experience/expertise. > > Nate. > >

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Manufacturing Community
The Manufacturing Community provides additional access to tips, tutorials, blogs and networking with peers.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

New AutoCAD Electrical Category!

The AutoCAD Electrical forum has moved into it's very own category page, and can no longer be found within the Additional Product Forums.

Ask the Community