AutoCAD Civil 3D General Discussion

Valued Contributor
Posts: 73
Registered: ‎09-04-2008
Message 1 of 4 (882 Views)

Sub assembly links not showing up (Subassembly Composer)

882 Views, 3 Replies
03-09-2012 07:21 AM

I created a simple sub-assembly for a windfarm project but when I bring it into civils none of the links or points show up!








I probably missed a button somewhere. Any advice would be great.





*Expert Elite*
Posts: 241
Registered: ‎12-14-2010
Message 2 of 4 (879 Views)

Re: Sub assembly links not showing up (Subassembly Composer)

03-09-2012 08:18 AM in reply to: CRThorn

I was able to Import Subassembly with your attached pkt file into C3D2012 with no problems and it has codes listed as expected. 3-9-2012 11-15-25 AM.jpg

I would try deleting your subassembly from your Tool Palette. Restarting Civil 3D and importing it again? 

Kati Mercier, P.E.

Co-author of "Mastering AutoCAD Civil 3D 2013"
AutoCAD Civil 3D 2013 Certified Professional and AutoCAD 2013 Certified Professional
AU2012 Speaker::: CI3001: Reverse Engineering with Subassembly Composer for AutoCAD Civil 3D
AU2011 Speaker::: CI4252: Create Subassemblies That Think Outside the Box With Subassembly Composer for AutoCAD® Civil 3D®
Distinguished Contributor
Posts: 152
Registered: ‎11-13-2006
Message 3 of 4 (744 Views)

Re: Sub assembly links not showing up (Subassembly Composer)

09-21-2012 11:10 AM in reply to: CRThorn

This is the exact same problem I am having. I tried the .pkt attached to this thread and get the same results as the OP. No links.


I have tried this on two different machines, along with the sample .pkt's (from the SAC wiki), and also with the samples provided from AU last year. No luck with any of them.


Either something right in front of me I am missing, or are there issues with some machines?


Tried running 2012, on XP and Win 7.

Distinguished Contributor
Posts: 152
Registered: ‎11-13-2006
Message 4 of 4 (700 Views)

Re: Sub assembly links not showing up (Subassembly Composer)

10-02-2012 05:28 AM in reply to: tmullins

I was able to get this working (with some help from Autodesk Support).


I simply renamed the install folder (C:\Program Files\Autodesk\Subassembly Composer 2012) then reinstalled the .exe.


You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community

Civil 3D Exchange Apps

Created by the community for the community, Autodesk Exchange Apps for AutoCAD Civil 3D helps you achieve greater speed, accuracy, and automation from concept to manufacturing.

Connect with Civil 3D