AutoCAD Civil 3D General

Reply
Contributor
mgsell
Posts: 19
Registered: ‎08-14-2006
Message 1 of 6 (328 Views)
Accepted Solution

Part Family Validation Error

328 Views, 5 Replies
03-16-2011 07:45 AM

I am getting the following error when trying to validate my part.

ERROR: Sample Expanded Table Row not fully expanded (calc error)

My part works fine as far as I can tell. when I change dimintions it changes to what it is supposed to. I don't know where to start to isolate what is causing this error. Any help would be appreciated.

Product Support
SethHall
Posts: 723
Registered: ‎02-08-2010
Message 2 of 6 (321 Views)

Re: Part Family Validation Error

03-16-2011 08:12 AM in reply to: mgsell

Hi mgsell-

 

Although I have not seen this exact error before, I have seen the calculation errors before. These are typically due to a Calculation value set to zero. For example:

 

ColumnCalc desc="Structure Height" dataType="float" unit="inch" name="SBSH" id="CCA7" visible="1" context="StructHeight" index="0">0.0000</ColumnCalc> 

 

This needs to have a default value other than zero.

 

Good luck!



Seth Hall
Product Support
GCSO - CSS - FTS
Autodesk, Inc.


Being Civil
Being Civil Twitter
Being Civil Facebook







Contributor
mgsell
Posts: 19
Registered: ‎08-14-2006
Message 3 of 6 (317 Views)

Re: Part Family Validation Error

03-16-2011 08:26 AM in reply to: SethHall

Thank you Seth for your reply. All my Model parameters have a value greater than 0. the error still persists. Here is my xml file. 

 

Contributor
mgsell
Posts: 19
Registered: ‎08-14-2006
Message 4 of 6 (300 Views)

Re: Part Family Validation Error

03-16-2011 09:56 AM in reply to: mgsell

I found it. You were right it was one of the calcs. For somereason it did not like a parameter with an underscore. Riser_Height that I had, even tho it did the calculation correctly. When I changed it to RiserH it validated fine. Thanks for your direction.

Product Support
SethHall
Posts: 723
Registered: ‎02-08-2010
Message 5 of 6 (294 Views)

Re: Part Family Validation Error

03-16-2011 10:06 AM in reply to: mgsell

I took a look and I did not pick up on the "_". Good catch!!

 

Glad I was able to "nudge" you in the right direction :smileyhappy:



Seth Hall
Product Support
GCSO - CSS - FTS
Autodesk, Inc.


Being Civil
Being Civil Twitter
Being Civil Facebook







Contributor
corcad
Posts: 25
Registered: ‎05-18-2005
Message 6 of 6 (158 Views)

Re: Part Family Validation Error

03-08-2012 08:20 AM in reply to: mgsell

Same issue. I wasnt able to determine the source of the error. I also had a calculation which used an underscore. I removed the underscore and validation was successful. Kudos to you!

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community


Civil 3D Exchange Apps

Created by the community for the community, Autodesk Exchange Apps for AutoCAD Civil 3D helps you achieve greater speed, accuracy, and automation from concept to manufacturing.

Connect with Civil 3D

Twitter

Facebook

Blogs