AutoCAD Civil 3D General

Reply
*Expert Elite*
rkmcswain
Posts: 3,085
Registered: ‎11-13-2006
Message 1 of 22 (1,160 Views)

2014 Pipe network: pipe styles change with Sync

1160 Views, 21 Replies
12-30-2013 09:09 AM

Using 2014 SP1, we have “Parent” drawing and “Child” drawing, both were started from the same template. Parent contains a pipe network, with a data shortcut created for it.

 

We open “Child” drawing and d-ref in this pipe network, taking care to select the proper Parts List – and everything looks great.  But, the first time we sync the pipe network, the style assigned to the pipes changes (to something unwanted).

 

We have:

  • Deleted the pipe network from “Child” and re-referenced it in.
  • Ensured that both drawings are associated to the same project
  • Went back to “Parent” and deleted the d-ref from the list and created it again.

....and nothing works.

 

Then I open “Child” in 2013 SP2, delete the pipe network, create the d-ref to it again then sync. The styles DO NOT change, and everything is fine.

 

So what is the difference between 2014 SP1 and 2013 SP2?

Why are the styles changing in 2014 only?

 

TIA

 

(FWIW, I have researched a few threads here and at augi regarding the possibility that the two drawings do not share the same parts list, etc. - and have taken care to make sure that is not the cause in this case)

 

 

*Expert Elite*
jmayo
Posts: 2,696
Registered: ‎11-13-2006
Message 2 of 22 (1,146 Views)

Re: 2014 Pipe network: pipe styles change with Sync

12-30-2013 10:23 AM in reply to: rkmcswain

Not that I can answer the 'why' and not that this will help you solve the issue but when you create the DRef are your pipes and structures displaying the same styles they were created in (parent style)? Are the styles being switched to the style that they were created in, the template default, pipe network default or a random style perhaps the first name in the style list?

John Mayo, PE
IDSP 2014
Win 7 64, Xeon ES165@3.2Ghz,
64 GB RAM, Quadro K4000 (x2)
*Expert Elite*
rkmcswain
Posts: 3,085
Registered: ‎11-13-2006
Message 3 of 22 (1,143 Views)

Re: 2014 Pipe network: pipe styles change with Sync

12-30-2013 10:36 AM in reply to: jmayo

jfmayo wrote:

..... when you create the DRef are your pipes and structures displaying the same styles they were created in (parent style)? Are the styles being switched to the style that they were created in, the template default, pipe network default or a random style perhaps the first name in the style list?


(1) Yes, when the dref is created, the pipe (and structures) are exactly like they are in "Parent" drawing. And FWIW, this is how it has always worked for us, 98% of the time. The other 2% of the time can be attributed to when a user starts with the wrong (or no) template.

(2) I think it may be using the default style located here (Settings>Pipe Network>Commands>Create Network>Default Styles>Pipe Default Style) - but I'm not 100% on that. I was thinking it took its "Default" from (Settings>Pipe Network>NetworkName>Edit>Pipes Tab>Style column) and that setting is correct.

 

I did not mention this in the original post to keep the confusion to a minimum, but I have a second pipe network in both "Parent" and "Child" (which uses a different parts list), and it works fine. No problems syncing at all with this one in 2014.

 

Thanks for your help!

*Expert Elite*
TRogers
Posts: 1,206
Registered: ‎09-05-2007
Message 4 of 22 (1,138 Views)

Re: 2014 Pipe network: pipe styles change with Sync

12-30-2013 11:00 AM in reply to: rkmcswain

What about the default styles in the Command Settings?  Are they set to what you want them to be?

If the issue was resolved by this method, please click on "Accept As Solution"
*Civil 3DJ*
Todd Rogers

Visit my blog here.

     
Distinguished Contributor
n2itive
Posts: 104
Registered: ‎04-15-2003
Message 5 of 22 (1,133 Views)

Re: 2014 Pipe network: pipe styles change with Sync

12-30-2013 11:16 AM in reply to: rkmcswain

This sounds like a familiar topic so I did a quick search.

Maybe this thread can help: http://forums.autodesk.com/t5/AutoCAD-Civil-3D-General/Pipe-and-structure-styles-resetting-when-data...

Infrastructure Design Suite 2014
Civil 3D 2013 sp2
Windows 7 x 64, 16 GB
Intel Xeon @ 2.80 GHz
NVIDIA Quadro K2000
*Expert Elite*
rkmcswain
Posts: 3,085
Registered: ‎11-13-2006
Message 6 of 22 (1,120 Views)

Re: 2014 Pipe network: pipe styles change with Sync

12-30-2013 12:29 PM in reply to: TRogers

TRogers wrote:

What about the default styles in the Command Settings?  Are they set to what you want them to be?


Todd, it doesn't matter. We are using the same templates/drawings/setting in both 2013 and 2014.

The problem only happens in 2014.

 

See the thread in post 5 - that pretty much sums it up, the workaround being "do not sync".

 

My workaround is = quit using 2014 until this is fixed.

*Expert Elite*
rkmcswain
Posts: 3,085
Registered: ‎11-13-2006
Message 7 of 22 (1,119 Views)

Re: 2014 Pipe network: pipe styles change with Sync

12-30-2013 12:30 PM in reply to: n2itive

n2itive wrote:

This sounds like a familiar topic so I did a quick search.

Maybe this thread can help: http://forums.autodesk.com/t5/AutoCAD-Civil-3D-General/Pipe-and-structure-styles-resetting-when-data...


Thanks. This tells me the workaround is to not sync, so I will go with my own workaround of just not using 2014.

 

Thanks again.

*Expert Elite*
TRogers
Posts: 1,206
Registered: ‎09-05-2007
Message 8 of 22 (1,111 Views)

Re: 2014 Pipe network: pipe styles change with Sync

12-30-2013 01:09 PM in reply to: rkmcswain

I heard that is supposed to be fixed in 2015 Randy.:smileysad:

If the issue was resolved by this method, please click on "Accept As Solution"
*Civil 3DJ*
Todd Rogers

Visit my blog here.

     
*Expert Elite*
jmayo
Posts: 2,696
Registered: ‎11-13-2006
Message 9 of 22 (1,103 Views)

Re: 2014 Pipe network: pipe styles change with Sync

12-30-2013 01:28 PM in reply to: rkmcswain

Looks like it's an issue...

John Mayo, PE
IDSP 2014
Win 7 64, Xeon ES165@3.2Ghz,
64 GB RAM, Quadro K4000 (x2)
*Expert Elite*
rkmcswain
Posts: 3,085
Registered: ‎11-13-2006
Message 10 of 22 (1,098 Views)

Re: 2014 Pipe network: pipe styles change with Sync

12-30-2013 01:50 PM in reply to: TRogers

TRogers wrote:

I heard that is supposed to be fixed in 2015 Randy.:smileysad:


It was fixed in 2013 :-(

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community


Civil 3D Exchange Apps

Created by the community for the community, Autodesk Exchange Apps for AutoCAD Civil 3D helps you achieve greater speed, accuracy, and automation from concept to manufacturing.

Connect with Civil 3D

Twitter

Facebook

Blogs