AutoCAD Architecture Customization

Reply
Valued Contributor
Posts: 96
Registered: ‎03-19-2007
Message 1 of 1 (95 Views)

Need help with AnchorEntityToEntity location of anchored object

95 Views, 0 Replies
07-05-2012 08:28 AM

With VB.Net I'm trying to anchor an MVPart to a Railing.

I add the MVPart at a specific location first, and it is located correctly.

Then I attempt to anchor it with AnchorEntityToEntity and it anchors fine but the MVPart moves from where it was originally located.

I repeat this process a few times and all the anchored MVParts are displaced the same.

What am I missing in my code snippet below to get the MVPart to maintain its location?

 

Using acTrans As Transaction = mydb.TransactionManager.StartTransaction()
    MVPObj = acTrans.GetObject(MVPObjID, OpenMode.ForWrite) ' MultiViewPart
    BeamObj = acTrans.GetObject(BeamObjId, OpenMode.ForRead) 'Railing object
    Dim anc2 As New AecDBS.AnchorEntityToEntity
    anc2.SetToStandard(mydb)
    anc2.SubSetDatabaseDefaults(mydb)
    anc2.ReferencedEntityId = BeamObjId
    anc2.OwnerId = BeamObjId
    MVPObj.SetAnchor(anc2)
    acTrans.Commit()
End Using

 

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Welcome to the new Autodesk Community!
If this is your first visit, click here to get started and make the most of the Community. Let us know what you think of the new experience in the Community Feedback Forum.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community