AutoCAD 2013/2014/2015

Reply
Active Member
Posts: 7
Registered: ‎07-22-2012
Message 1 of 8 (350 Views)
Accepted Solution

xreferenced colour(s) displaying wrong

350 Views, 7 Replies
09-15-2012 03:15 AM

i am editing a drawing i have inherited from the previous drafter who is no longer working here. this drawing references 2 other drawings. one is the title block, the other is the engineering drawing. both of these drawings have white objects in them, namely, some text and some solid hatching.

 

instead ot those white objects appearing as white in this drawing, they are appearing as a grey colour. i have double and triple checked that these objects are coloured by layer and the layer is white in both of the xrefs. they appear white in the xrefs but not in the final drawing.

 

since we are using colour dependent line weights in our printing, i would like to get this colour problem sorted. ideas?

*Expert Elite*
Posts: 1,380
Registered: ‎08-16-2007
Message 2 of 8 (340 Views)

Re: xreferenced colour(s) displaying wrong

09-15-2012 05:34 AM in reply to: n0tepad

You might misunderstand some relatively new features.  See help on XDWGFADECTL.  If setting it to 0 changes the color, then that is what is affecting the display.

Active Member
Posts: 7
Registered: ‎07-22-2012
Message 3 of 8 (336 Views)

Re: xreferenced colour(s) displaying wrong

09-15-2012 06:58 AM in reply to: dbroad

thanks for your reply. ive changed that xref fading value from 50 to 0 but that didnt change the appearance of the colours. 

looking closer now i notice that all colours in the xrefs are affected. could there be a setting in this drawing causing the xrefs to fade/darken?

*Expert Elite*
vladimir.michl
Posts: 224
Registered: ‎09-17-2006
Message 4 of 8 (332 Views)

Re: xreferenced colour(s) displaying wrong

09-15-2012 07:36 AM in reply to: n0tepad

Check also the transparency of xref-layers. See:

http://www.cadforum.cz/cadforum_en/print-xref-entities-faded-tip7570

 

Vladimir Michl, www.cadstudio.cz

 


*Expert Elite*
Posts: 1,380
Registered: ‎08-16-2007
Message 5 of 8 (327 Views)

Re: xreferenced colour(s) displaying wrong

09-15-2012 10:15 AM in reply to: n0tepad

@n0tepad

 

"i notice that all colours in the xrefs are affected."

 

That is what XDWGFADECTL does.  It affects all colors.

 

The way things appear on-screen do not necessarily affect the plot.  If your plotstyles are color based and the color numbers aren't changed, they will plot the same way.  If you want more help, attach a zip file with a small sample pair of dwg and xref that demonstrate the problem.

 

If you are new to AutoCAD, I strongly suggest getting classroom training rather than via newsgroups.

*Expert Elite*
3wood
Posts: 908
Registered: ‎03-25-2009
Message 6 of 8 (317 Views)

Re: xreferenced colour(s) displaying wrong

09-15-2012 02:49 PM in reply to: n0tepad

The layer color in xref and the master drawing can be different.

Check the layer color in your master drawings.

Or check the VISRETAIN setting.

Active Member
Posts: 7
Registered: ‎07-22-2012
Message 7 of 8 (311 Views)

Re: xreferenced colour(s) displaying wrong

09-15-2012 05:27 PM in reply to: 3wood

thanks 3wood. i checked visretain was set to 1. i searched for more information on visretain and found a solution at

http://www.caddmanager.com/CMB/2005/01/dont-ya-just-love-visretain/

 

which essentially suggests to set visretain to 0, detach all xrefs, purge my drawing, then reattach my xrefs (losing all my layoff settings etc). it is important to set visretain back to 1 in order to keep layoff settings and (deliberate, wanted) layer colour changes.

 

note that a comment left at the abovementioned page suggests that you can simply reload your xrefs is not helpful. all that does is loses your layoff settings and doesnt resolve the colour display issue.

 

 

*Expert Elite*
Posts: 1,380
Registered: ‎08-16-2007
Message 8 of 8 (290 Views)

Re: xreferenced colour(s) displaying wrong

09-16-2012 04:13 PM in reply to: n0tepad

I really do love visretain.  Sorry I didn't think about that earlier.  You don't have to detach the drawing and reload it.  Just turn visretain off and then then reload and then turn visretain back on. Before you do, however, consider that there may have been a very good reason for the previous drafter to use the same base plan and to assign different colors to it in different trade drawings.  This would be if you use color to control lineweight. Always plot preview before adjusting.  Note also that visretain preserves the on/off and freeze/thaw status of the layers, not just its color.  Arbitrarily detaching and reattaching when following up a drafter's work can lose these carefully chosen layer settings.

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you interested in helping shape the Autodesk Community?
We’re looking at a few different ways to improve the “All Forums” landing page and need your feedback! If interested, please take a few minutes to fill out the following Usability Study. Thank you for your time!

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community




Connect with AutoCAD

Twitter

Facebook

Blogs

Pinterest

Youtube