AutoCAD 2013/2014/2015

Reply
New Member
swystephen
Posts: 2
Registered: ‎11-17-2012
Message 1 of 4 (752 Views)
Accepted Solution

model space and paper space - layoff

752 Views, 3 Replies
11-17-2012 12:36 AM

How can i set up the viewport in paper space when i use layoff turn off layers and once i move back in model space which the layer it's still on?

*Expert Elite*
tcorey
Posts: 2,476
Registered: ‎12-18-2002
Message 2 of 4 (639 Views)

Re: model space and paper space - layoff

11-19-2012 01:51 PM in reply to: swystephen

The LAYOFF command checks to see if you are working on the Model tab or a Layout tab. If you are working inside a viewport on a Layout tab, the command does not turn layers off, it Viewport-Freezes them.

 

Oddly, LAYFRZ works the same way.

 

A way around it would be to add your own command to use in addition to or instead of LAYOFF:

 

(defun c:layoffCustom()

(setq lay (cdr (assoc 8 (entget (car(entsel "\nSelect object on layer to turn off: "))))))

(command "-layer" "off" lay "")

(princ)

)

 

It's not fancy, but it will do the job. Add a loop if you want it to keep asking for more objects/layers.

 

 

 

Tim Corey, Owner
Delta Engineering Systems
Redding, CA
Autodesk Authorized Value-Added Reseller
*Expert Elite*
pendean
Posts: 21,848
Registered: ‎11-06-2003
Message 3 of 4 (615 Views)

Re: model space and paper space - layoff

11-20-2012 05:04 AM in reply to: tcorey

Both LAYOFF and LAYFRZ have a Settings option (watch that command line): you can turn off the "viewport" effect you describe in the core command, no lisp required. Tap that HELP file and explore more if you wish.

Dean Saadallah Blog | Facebook | Google+ | Twitter | PINS
New Member
swystephen
Posts: 2
Registered: ‎11-17-2012
Message 4 of 4 (570 Views)

Re: model space and paper space - layoff

11-22-2012 06:36 AM in reply to: pendean
Things are like this, I am using AutoCAD 2010 at home with no any settings such means when i use "layoff" in paper space that will just turned off the selected layers in model space. However, school is using AutoCAD 2008 til now 2013, when i use "layoff" in paper space that will just freeze the selected layer in paper space and it still kept on in model space. But they havent set up anything. So that must be something works in the settings. I just found its really useful with "layon" and "layoff" in paper space. i can just create a viewport and "layoff" those layers i dont need in this drawing. Please help...

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community




Connect with AutoCAD

Twitter

Facebook

Blogs

Pinterest

Youtube