AutoCAD 2013/2014/2015

Reply
Valued Mentor
TrevN
Posts: 548
Registered: ‎04-14-2008
Message 1 of 7 (407 Views)

Seems Nothing Changes....

407 Views, 6 Replies
05-22-2012 08:50 AM

So, here we are with 2013, and yet again Autosave switches off after I've used the publish command.

 

One day, maybe in a few decades, probably when I've retired, Autodesk will fix it. But then agian, probably not!

 

:smileyfrustrated:

*Expert Elite*
rkmcswain
Posts: 3,077
Registered: ‎11-13-2006
Message 2 of 7 (378 Views)

Re: Seems Nothing Changes....

05-22-2012 12:21 PM in reply to: TrevN

I know we shouldn't HAVE to.....but add it to one of your frequently used macros....

 

(defun C:E ()
 (setvar "savetime" 5)
 (command "._erase")
 (princ)
)

 

 

:smileywink:

 

*Expert Elite*
pendean
Posts: 21,596
Registered: ‎11-06-2003
Message 3 of 7 (317 Views)

Re: Seems Nothing Changes....

05-23-2012 07:18 PM in reply to: TrevN

Not sure it will change until the core Publish command: have not seen even a hint of that anywhere, maybe with R2016?

Dean Saadallah Blog | Facebook | Google+ | Twitter | PINS
Product Support
Silvia.Menon
Posts: 182
Registered: ‎06-11-2007
Message 4 of 7 (267 Views)

Re: Seems Nothing Changes....

05-29-2012 09:20 AM in reply to: TrevN

Hi,

 

I tried to reproduce this, but my SAVETIME variable actually stays at the previous value after I use PUBLISH (both when I acctually publish the file, and also when I just cancel out of the Publish dialog) ...

 

savetime_publish.png

 

 

Are you running Vanilla AutoCAD 2013 or another AutoCAD-based product?

 

Best regards,

Silvia



Silvia Menon
Support Specialist
Product Support
Autodesk, Inc.


http://www.autodesk.com/autocad-support

 

*Expert Elite*
dgorsman
Posts: 5,035
Registered: ‎10-12-2006
Message 5 of 7 (251 Views)

Re: Seems Nothing Changes....

05-29-2012 11:14 AM in reply to: Silvia.Menon

This isn't something that happens 100% of the time.  It's one of those annoying intermittent problems.  I *think* it's related to background vs. foreground publishing due to the fact an auto-save firing may interupt the publishing process so gets set to 0 but depending on how the command exits may not get reset to the original value.

----------------------------------
If you are going to fly by the seat of your pants, expect friction burns.
Adopt. Adapt. Overcome. Or be overcome.
A good question will be halfway to a good answer.


Contributor
jamieq
Posts: 13
Registered: ‎12-20-2005
Message 6 of 7 (184 Views)

Re: Seems Nothing Changes....

06-21-2012 07:36 AM in reply to: TrevN

I put the following code in my acaddoc lsp file several months ago.

 

;;; START AUTOSAVE CHECK

(defun C:ALERTME ()

  (vl-load-com)

  (setq VTFRXN (vlr-editor-reactor nil '((:VLR-sysVarChanged . VTF))))

  )

  

(defun VTF (CALL CALLBACK)

  (if (and

  (= (strcase (car CALLBACK)) (setq str "SAVETIME"))

  (not (eq (getvar str) 10))

  )

  (progn

  (princ (strcat "Warning: Someone or something has changed your Autosave settings.\n" str " has been changed back to 10 minutes"))

  (setvar "SAVETIME" 10)

  )

  )

  )

  (setvar "SAVETIME" 10)

  (c:alertme)

;;; END AUTOSAVE CHECK

 

Whenever I publish (which I do from the Sheet Set Manager almost exclusively to plot) I see the "Warning" message. This happens every time. And I have background publishing turned off. While this is a ridiculously annoying bug in AutoCAD that has plagued me for years, at least I was finally able to find this work around which has solved my issue. Of course, work arounds shouldn't be necessary with an issue so glaringly obvious as this one.

Valued Mentor
TrevN
Posts: 548
Registered: ‎04-14-2008
Message 7 of 7 (182 Views)

Re: Seems Nothing Changes....

06-21-2012 07:40 AM in reply to: jamieq

Yeah, I tried that lisp, or something very similar at Civils kept crashing!

 

Problem doesn't hgappen so often now, but still pops up every so often, aggggggh

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community




Connect with AutoCAD

Twitter

Facebook

Blogs

Pinterest

Youtube