AutoCAD 2013/2014/2015

Reply
Active Member
Vandeurzen
Posts: 8
Registered: ‎07-07-2009
Message 1 of 18 (1,832 Views)

Multileader not extending to text

1832 Views, 17 Replies
04-17-2012 07:40 AM

All of my multileaders (mleaders) worked great in 2012 with the added "extend leader to text" for leaders on the end of a text string, but in 2013, they now attach to the end of the box again.  

 

Some appear as though they are "trying" to extend, but the begining of the leader without the extension now starts at the end of the box on the FIRST line.  Does anyone else have this issue?

 

See the attached examples:

 

Top one - Mleader is on the end of a text box larger than the actual text (NOTE:  I have many drawings like this, opening them in 2013 is a nightmare)

 

Version #2 - Note what the leader does in this example, the "extend to end of text" is the correct length, but it starts at the edge of the box, not the end of the first line of text.  Again, this worked fine in 2012.

 

Version #3 - This is what should happen, only happens if you adjust the text box size.  I don't really want to spend my clients money updated dozens of multileaders on hundreds of drawings to force the mleader to work.

Product Support
luconceicao
Posts: 583
Registered: ‎11-07-2007
Message 2 of 18 (1,795 Views)

Re: Multileader not extending to text

04-20-2012 08:40 AM in reply to: Vandeurzen

Hi,

I tried to reproduce the issue but it is working fine here, see the file attached.

Could you please send one of your drawings showing the problem?

 

Cheers,

Luciane

 

Luciane Conceição
Product Support Specialist
Autodesk, Inc.

*Expert Elite*
GrantsPirate
Posts: 1,550
Registered: ‎08-15-2008
Message 3 of 18 (1,775 Views)

Re: Multileader not extending to text

04-23-2012 06:08 PM in reply to: Vandeurzen

I see the problem here on R2013, I will have to try it at work on 2012.

Active Member
Vandeurzen
Posts: 8
Registered: ‎07-07-2009
Message 4 of 18 (1,757 Views)

Re: Multileader not extending to text

04-24-2012 06:02 AM in reply to: luconceicao

Thank you for taking the time to work on this.  If you are working in Autocad 2012, you won't see the problem.  I only have the problem on 2013 (just clarifying, I'm not sure what version you used for this drawing).  Also, the drawing you attached the MText boxes have a defined width of "0".  The extend to text function works fine for that scenario.  It does not work  if you have a defined width of GREATER than the width of the text.  I will try to attach a drawing when I have more time.

 

Thanks again.

Product Support
luconceicao
Posts: 583
Registered: ‎11-07-2007
Message 5 of 18 (1,751 Views)

Re: Multileader not extending to text

04-24-2012 07:18 AM in reply to: Vandeurzen

I created it in 2012 and opened it in 2013, but did not save as 2013.

COJones, did you create it in 2013?

I was trying to reproduce it as Vandeurzen explained, that it happened with files that looked fine in 2012.

 

Please send a file that shows OK in 2012 and not OK in 2013, then we can see if we can find the difference.

 

Cheers,
Luciane

Active Member
Vandeurzen
Posts: 8
Registered: ‎07-07-2009
Message 6 of 18 (1,746 Views)

Re: Multileader not extending to text

04-24-2012 07:51 AM in reply to: luconceicao

The drawing does NOT have to be created in 2012, this is just what most of my files are.  This is a universal problem for all of 2013s leaders.

 

I have attached 3 files.  2 are .dwg files showing the leaders, 1 is a .jpg files so that you can see what I am seeing.

 

Please note:  when you open the 2012 file in 2013, everything looks fine, the leaders appear to be working.  When you edit the text, then they will revert to the strange rules again.

Product Support
luconceicao
Posts: 583
Registered: ‎11-07-2007
Message 7 of 18 (1,740 Views)

Re: Multileader not extending to text

04-24-2012 08:32 AM in reply to: Vandeurzen

Thank you for the files and explanation, I am able to reproduce it now.

I will report this issue to our developers.

Thanks for letting us know.

 

Cheers,

Luciane

Active Contributor
mt1083
Posts: 34
Registered: ‎07-28-2008
Message 8 of 18 (1,729 Views)

Re: Multileader not extending to text

04-24-2012 02:52 PM in reply to: Vandeurzen

I have the exact same problem, so hopefully there will be a patch release soon on this after your work in your post. Thanks for posting this info because I'm glad I'm not the only one.

Active Member
Vandeurzen
Posts: 8
Registered: ‎07-07-2009
Message 9 of 18 (1,725 Views)

Re: Multileader not extending to text

04-24-2012 03:01 PM in reply to: mt1083

Thanks for the reply mt1083, I was hoping another user would chime in with the problem in addition to product support.  I have found that you can work around it, but it does take time, and seems very unnecessary when it worked in the last release.

Active Contributor
mt1083
Posts: 34
Registered: ‎07-28-2008
Message 10 of 18 (1,700 Views)

Re: Multileader not extending to text

04-26-2012 07:25 PM in reply to: Vandeurzen

Out of curiosity, what operating system are you using currently? I am on Vista and just found out the Autodesk decided not to support Vista on this release (which I find really retarded since I am on a subscription and I'm sure there are thousands of customers using vista). I wonder if this may be at all related to the OS... probably not but I figure I'd ask what you are using.

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community




Connect with AutoCAD

Twitter

Facebook

Blogs

Pinterest

Youtube