AutoCAD 2010/2011/2012

Reply
Member
civilgirl2010
Posts: 4
Registered: ‎06-26-2010
Message 1 of 13 (69,777 Views)

Error Autocad 2011:Adui18res.dll not found. Reinstalled and problem persists!!

69777 Views, 12 Replies
07-03-2010 09:38 PM

Hi, I already uninstalled Autocad 2011, rebooted machine and installed again and no luck.

 

After installation of Autocad 2011, I click the icon on the desktop, launch it and I get:

 

"C:\Program Files\Autodesk\AutoCAD 2011\acad...

 

Adui18res.dll not found"

 

I googled this problem before and some peopled reported that was a bad install and suggested a reinstallation, which in my case did not help.

 

Notes:

The only error or warning I got during installation was that "serial number is invalid". I clicked OK and continued with installation. My observation is that I never had an opportunity to enter the serial number though.

 

I removed the original then installed the latest Visual C++ 2008 Redistributable package.

 

Platform:
Window 7, 32-bit.

Autocad 2011.

 

Valued Mentor
wengle
Posts: 658
Registered: ‎06-02-2010
Message 2 of 13 (69,762 Views)

Re: Error Autocad 2011:Adui18res.dll not found. Reinstalled and problem persists

07-04-2010 11:08 AM in reply to: civilgirl2010

I don't know what that dialog (adui18res.dll) is, but try a Repair via the Control Panel.

Member
civilgirl2010
Posts: 4
Registered: ‎06-26-2010
Message 3 of 13 (69,678 Views)

Re: Error Autocad 2011:Adui18res.dll not found. Reinstalled and problem persists

07-07-2010 10:37 PM in reply to: wengle

Problem persists. I tried the repair and it complained that "NET 3.5 Framework is not installed".

Then I read a similar post in which it was recommended to cleanup the NET 3.5 Framework. I ran the tool, cleaned up Net 3.5, rebooted the computer. Then I reinstalled NET 3.5 framework. Finally I was able to run the "repair" through the Control Panel.

 

Problem persists though.

I launch Autocad 2011 and I get the dreadful message "adui18res.dll not found".

 

This is so annoying. Based on the number of posts it seems Autocad 2011 on Windows 7 is plagued by several bugs.


Who can help me get this resolved? I do not know what else to do and I need to get this running ASAP.

 

Windows 7, 32-bit, Autocad 2011 32 bit.

Product Support
zalant
Posts: 297
Registered: ‎11-01-2005
Message 4 of 13 (68,858 Views)

Re: Error Autocad 2011:Adui18res.dll not found. Reinstalled and problem persists

08-18-2010 07:14 AM in reply to: civilgirl2010

Indeed, this error is a sign of a bad installation, as there are simply some needed files which are missing.  If you were to copy the adui18res.dll into its correct location, you'd then go down a path of other files which cannot be found.  Replacing them file-by-file would eventually lead to a situation where you'd just get an impassible error.  The only solution I have found is to go through the complete and thorough removal, using the following link:

 

http://usa.autodesk.com/getdoc/id=TS45252

 

The above comments about verifying the .NET Framework installation are quite valid, and it's certainly a good thing to check before proceeding with any problematic AutoCAD installation.

 

When I ran into this problem on my own system, the key seemed  to be removing the Autodesk Shared folder from C:\Program Files\Common Files.  As there are some DLL files in use there, it can be difficult to remove.  Start by setting Windows to show all file extensions.  Next, rename the DLL extensions for all DLL files to some other extension (like OLD, for example).  You'll need to do this for all DLL files in the root of the Autodesk Shared folder, plus any subfolders.  A simple batch file can accomplish this.  The syntax consists of one line, which is REN *.DLL *.OLD.  I've attached such a batch file to this post.  Please use it with caution and only within the confines of getting rid of the Autodesk Shared folder.

 

NOTE:  I had to give the file a .LOG file extension so that I could attach it here.  Remove the .LOG file extension so that it is a batch file, once you've saved it to your system.

 

Once the DLL files have all be renamed to *.OLD, reboot the system and you should be able to delete the Autodesk Shared folder (if not, try booting into Safe Mode to delete it).  Then, run the installation for the AutoCAD product in question again and it should copy all of the installation content successfully.



Zac Travis
New Member
wkbennion
Posts: 1
Registered: ‎11-30-2010
Message 5 of 13 (66,283 Views)

Re: Error Autocad 2011:Adui18res.dll not found. Reinstalled and problem persists

11-30-2010 02:58 PM in reply to: zalant

Having the same "adui18res.dll not found" problem...

 

I'm installing a trial version new install on a Windows 7 64bit OS with a download from autodesk.  I have tried repair, reinstall, reboot and now it looks like I need to research group policies, customized .msi, additional .mst files.  It's a whirling dervish of retorich for a simple attempt to just try out the software.  I'm thinking it is too complicated and that maybe I need to look at different software.

 

Can anyone tell me what the real solution is...  Software this sofisticated shoul install and run seamless, especially when it has had this problem in earlier versions and when they are trying to provide a good experience for someone evaluating it for purchase.

 

Stop the madness....

 

Karl

Product Support
zalant
Posts: 297
Registered: ‎11-01-2005
Message 6 of 13 (66,240 Views)

Re: Error Autocad 2011:Adui18res.dll not found. Reinstalled and problem persists

12-01-2010 11:46 AM in reply to: civilgirl2010

Indeed, the software should install seamlessly, and in most cases it does.  However, since you mentioned Group Policies, there are several technical support cases we have where the outlined process was not followed for Group Policies, and the result was the missing DLL messages upon running the program.  There is a section of the documentation (included with the software) that details considerations and processes when Group Policies are in use.

 

Another thing which has been shown to result in the missing DLL errors is the usage of hard drive encryption software, as well as software which redirects user-specific folders.  As there are many and varied softwares which perform those tasks, we do not test against such configurations.  For the most part, our software installation testing is done within the confines of the most common (standalone and network) Windows scenarios.  Since there are almost limitless amounts of combinations of Windows installation options and the various user/file/folder rights/permissions, it's not feasible to test within every conceivable scenario. 

 

When 3rd party security softwares and other factors are included, there is another complete subset of potential real-world scenarios against which Autodesk software installations were never tested prior to their release.  

 

To summarize, it's very rare that we find problems with installations of Autodesk software on machines which just have Windows (and MS Office) installed directly from disc and no other software loaded.  I realize that it's uncommon to find such a system in the real world, but past that the sky is the limit for possible configurations.  No software within any industry would ever get released to market if it were required that every possible combination of factors be tested against.



Zac Travis
New Member
michaelshe
Posts: 1
Registered: ‎12-22-2010
Message 7 of 13 (65,214 Views)

Re: Error Autocad 2011:Adui18res.dll not found. Reinstalled and problem persists

12-22-2010 09:42 AM in reply to: civilgirl2010

This issue is resolved by using the setup.exe file to install and NOT the acadlt.msi file.

 

 

New Member
varshne.tushar
Posts: 1
Registered: ‎04-08-2011
Message 8 of 13 (59,019 Views)

Re: Error Autocad 2011:Adui18res.dll not found. Reinstalled and problem persists

04-08-2011 11:12 AM in reply to: civilgirl2010

hi, 

i uniinstall autocad 2011 .and when i installed again ,it shows adui18res.dll file missing.please help me imidiately

New Member
Scarramouche
Posts: 1
Registered: ‎06-22-2011
Message 9 of 13 (52,831 Views)

Re: Error Autocad 2011:Adui18res.dll not found. Reinstalled and problem persists

06-22-2011 06:44 AM in reply to: civilgirl2010

Issue is to do with manually installing using a MSI deployment file system. There are certain switches required to install corporate created MSI deployments correctly

 

Issue with this missing DLL is down to the Language Pack not installing correctly.

Locate Language Pack MSI (Acadlp.msi) usually in the en-us subfolder for UK/US installations. Use relevant MST Transforms file with the MSI (eg for my company the Transform file is called "acad-ACAD2010.mst"

run this combination from install files location

i.e msiexec.exe /i "en-us\acadlp.msi" TRANSFORMS="acad-ACAD2010.mst" (add full paths to each file if necessary)

Once the Language Pack has installed, run a repair on the AutoCAD installation and all should be well.

 

New Member
vtoma
Posts: 2
Registered: ‎02-05-2008
Message 10 of 13 (49,732 Views)

Re: Error Autocad 2011:Adui18res.dll not found. Reinstalled and problem persists

09-20-2011 01:50 PM in reply to: wkbennion

I had the same issue with C3D 2012. On a similar platform...new machine run windows 7 64 bit. 

 

 I resolved the issue by rolling back my machine to a state before my install attempt and then installing ALL Windows 7 updates. Once I tried the install again, I made sure that all other programs were closed and bam!  Install is perfect!  I did however, install from a disk as I could not install from the web.  I hope this helps all frustrated users.

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community




Connect with AutoCAD

Twitter

Facebook

Blogs

Pinterest

Youtube