AutoCAD 2010/2011/2012

Reply
Valued Contributor
phil-mcam
Posts: 71
Registered: ‎01-19-2011
Message 1 of 26 (17,007 Views)

2012 and 2011 Performance Issues: Slow on common commands

17007 Views, 25 Replies
05-11-2011 11:58 AM

Bear with me.

 

I have customers using new installs of 2011 and 2012.

They report problems with common commands such as copy, dimensions, mirror.

The main complaint is slowness. A 9 second lag after completing the copy command for instance. Or a very long lag while making dimension picks.

 

They both have brand new machines: Windows 7, 12gig RAM, massive approved vid cards and drivers, massive processing speed.

 

Both transitioned from 32 bit, XP machines with old vid cards, smaller processors and 4 gigs of RAM. Both customers are stunned that their new hardware is not running AutoCAD better than their old outdated under equipped machines.

 

I've searched and only come up with "maybe" type solutions. 

Maybe it's the drivers

Maybe it's the [fill in the blank with any number of settings in AutoCAD]

 

So what is the deal?

 

Are the newer versions of AutoCAD somehow so much more complex that even when you throw all the best latest greatest hardware that money can buy at them it's still not enough?

 

Is there an issue with Windows 7?

 

Please do not: 

Suggest turning off all the Windows doo-dads. That is unacceptable to a person who just spent thousands on the latest, greatest, approved hardware. What this means is that the money they spend on subscription or upgrades is flushed down the toilet because older everything works better. They simply cannot create a version of AutoCAD after almost 30 years that works without turning off OS functionality. And why would Inventor, or any number of other video/processor heavy applications work flawlessly, reflective of the awesome power of these new machines, even with the silly settings turned on?

 

Also try to resist suggesting turning off the AutoCAD settings that are there for customers to use. Why would a user pay all that money for new hardware and software only to find out that the thing is built with 30 or more settings that are known to slow it down or cause serious problems? I understand this method for someone running an old anemic 32 bit machine with limited resources and processing. Make it run lean. I get it. 

 

It doesn't help that many people say they have zero problems. It doesn't help that there is no known issue or solution for this besides pretending you have an old underpowered machine. Did I just miss something in my searches? Any heads up here is what I'm after.

 

For instance: I have ZERO issues with AutoCAD 2005 on an old Dell Dimension 3000, XP, with onboard video and 512meg RAM. I am not joking this is my setup at home. 

 

Should I suggest this solution to my customers who desperately need to get something done today? 

 

 

 

 

 

 

*Expert Elite*
Patchy
Posts: 6,224
Registered: ‎09-16-2009
Message 2 of 26 (16,996 Views)

Re: 2012 and 2011 Performance Issues: Slow on common commands

05-11-2011 12:22 PM in reply to: phil-mcam

2012 autocad = Ford Excursion:smileyvery-happy:

I like that Dell 3000,  XP SP3,  2008 LDD it runs like a Corvette.

Active Member
johnjgray
Posts: 6
Registered: ‎03-07-2011
Message 3 of 26 (16,976 Views)

Re: 2012 and 2011 Performance Issues: Slow on common commands

05-11-2011 01:18 PM in reply to: phil-mcam
Contributor
compassray
Posts: 15
Registered: ‎04-26-2010
Message 4 of 26 (16,927 Views)

Re: 2012 and 2011 Performance Issues: Slow on common commands

05-12-2011 05:08 AM in reply to: phil-mcam

Have you tried turning hardware acceleration on or off.

*Expert Elite*
GrantsPirate
Posts: 1,581
Registered: ‎08-15-2008
Message 5 of 26 (16,907 Views)

Re: 2012 and 2011 Performance Issues: Slow on common commands

05-12-2011 07:18 AM in reply to: phil-mcam

We aren't there and so we have to guess at what you may or may not have tried.


I assume this happens in a blank drawing as well as large drawings, etc.?


Download and Use Process Monitor  to find where autocad is freezing or slowing down, go to this link for details=> http://technet.microsoft.com/en-us/sysinternals/bb896645.


Also,

This has reportedly made a big difference when running ANY version of AutoCAD on a Win7 64 machine.

 Go to:

 Control Panel

All Control Panel Items

Network and Sharing Center

Change Adapter Settings

Right-Click "Local Area Connection"

Select "Properties"

Click "Configure"

Select the "Advanced" tab

Select the "Speed & Duplex" Property and set the value to "Auto Negotiation"

 

If it's already set that way, change it to the highest network speed your network is capable of and see if that fixes your issue.  If it does, but the problem reccurs after a reboot, then change it back to "Auto Negotiation".

 

You should also change the "Power Management" by unchecking the "Allow the computer to turn off this device to save power" (Unless you're running on a laptop).  This is a problematic setting on many devices when running under Win7 and the devices seem to not awake and are sluggish after being turned off.


Turn off virus protection as a test as well.


There is no one size fits all fix to these slow downs so all you will get are maybe this or that.


It does help to know that many don't have a problem and in fact 2012 runs as fast or faster than 2011 on my setup.  This means that the program isn't fundamentally flawed and doesn't work for any one.



----------------------------------------------------------------------------
If something I wrote can be interpreted two ways, and one of the ways makes you sad or angry, I meant the other one.
Valued Contributor
phil-mcam
Posts: 71
Registered: ‎01-19-2011
Message 6 of 26 (16,884 Views)

Re: 2012 and 2011 Performance Issues: Slow on common commands

05-12-2011 08:29 AM in reply to: phil-mcam

Thank you very much for your clear and detailed advice.

 

I will forward this and report back.

 

Member
sbanister
Posts: 4
Registered: ‎05-16-2011
Message 7 of 26 (16,578 Views)

Re: 2012 and 2011 Performance Issues: Slow on common commands

06-13-2011 05:35 AM in reply to: phil-mcam

I currently have AutoCAD 2007 & AutoCAD 2012 running simultaneously.

In Windows Task Manager > Processes under 'Mem usage'

 

2007 is using 32,600 K of memory

2012 is using 167,700 K of memory

 

2012 runs slower simply because it's too resource hungry

 

New Member
christiebokor6533
Posts: 1
Registered: ‎06-30-2011
Message 8 of 26 (16,336 Views)

Re: 2012 and 2011 Performance Issues: Slow on common commands

06-30-2011 08:23 AM in reply to: johnjgray

Thanks!!! the hot fix worked for us - for reasons unknown the slow down issues only happend when working on drawings over our network, locally saved projects were much faster.  now they are all fast, what a relief!

Contributor
tombaumberger
Posts: 12
Registered: ‎08-15-2007
Message 9 of 26 (16,310 Views)

Re: 2012 and 2011 Performance Issues: Slow on common commands

06-30-2011 12:32 PM in reply to: phil-mcam

I'd bring that old XP machine from the house in and run 2005. That's the last decent version I've seen. I've been using Autodesk products since the very first version 2.17. I'm just happy that retirement is on the horizon. I'd hate to have another 30 years at this.

 

So after all that. I'm not buying that hotfix solution. I had the hotfix installed before I brought Autodesk into this. I've had a support request in about this issue with unsatisfactory results. They keep saying it's our network and blah, blah, blah. All I know is the identical file before I brought it into 2012 saved across our network in about a couple of minutes. It's a 25MB corridor with a 100MB existing surface data referenced into it. It's not any big project or anything just something typical in the industry. After I took it up to 2012 it now takes about 15 minutes to save it and the corridor builds like a snail.

 

I'm running a Windows 7 64bit quadcore Xeon with 12GB RAM and an nvidia card with 1GB RAM on it. Our network is all 1Gb.

 

I have the hotfix installed. I've created a duplicate file structure on my hard drive and saved the drawing locally. I gained a whopping 1 minute. I can save the drawing to my hard drive in 14 minutes. Wow.

 

Say what you want about nobody having problems but 2012 is a boat anchor. If it isn't prove me wrong and point me to the solution.

Valued Contributor
phil-mcam
Posts: 71
Registered: ‎01-19-2011
Message 10 of 26 (16,013 Views)

Re: 2012 and 2011 Performance Issues: Slow on common commands

07-27-2011 09:09 AM in reply to: phil-mcam

Just got another call:

 

Good video card

New Windows 7 Machine

AutoCAD LT running slowly, to put it nice

 

The original customer who asked about this has reported: Plugging into a different network jack on the wall did the most for her. Turning off the ribbon seemed to help, but not entirely. Mostly the problem seems to come and go, over periods of weeks.

 

I wish there were a single answer.

 

I just set up a brand new Dell laptop. Non-certified video. Windows 7. Runs like a champ. Fastest best machine I've ever had for Inventor, AutoCAD, Showcase, Publisher... So the variable is what? Windows, or AutoCAD? I'm running both OUT OF THE BOX, no settings changes whatsoever. It is a standalone version.... is that it, the network versions?

 

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community




Connect with AutoCAD

Twitter

Facebook

Blogs

Pinterest

Youtube