AutoCAD 2007/2008/2009

Reply
Distinguished Mentor
lpseifert
Posts: 889
Registered: ‎08-08-2006
Message 11 of 17 (2,052 Views)

Re: UCS, World, Viewport crosshair drawing rotation issue

07-23-2009 08:49 AM in reply to: will2605
I'm not quite sure what you're after, but try Ucs > View. This will align the UCS and crosshairs with the viewport.
~~~Civil 3D 2008~~~
*A+P
Message 12 of 17 (2,052 Views)

Re: UCS, World, Viewport crosshair drawing rotation issue

07-23-2009 08:49 AM in reply to: will2605
Snapang = 0

Paul

wrote in message news:6223664@discussion.autodesk.com...
still not fixed!
Active Member
will2605
Posts: 7
Registered: ‎07-23-2009
Message 13 of 17 (2,052 Views)

Re: UCS, World, Viewport crosshair drawing rotation issue

07-23-2009 09:01 AM in reply to: will2605
sorted it!

rotated the drawings in modelspace and used snapang to determine the degree of the rotated cross hair..just selected the end points of a horizontal line in the drawing to correct the crosshair..

thanks to everyone for their help along the way!

persistence pays....
Valued Mentor
Randy_Culp
Posts: 1,257
Registered: ‎08-17-2007
Message 14 of 17 (2,052 Views)

Re: UCS, World, Viewport crosshair drawing rotation issue

07-24-2009 05:12 AM in reply to: will2605
Rotated the modelspace components?? ummm ... what is the current UCS, SNAPANG, VIEWTWIST and VIEWDIR?
*Expert Elite*
drjohn
Posts: 1,700
Registered: ‎03-01-2006
Message 15 of 17 (2,052 Views)

Re: UCS, World, Viewport crosshair drawing rotation issue

07-24-2009 07:26 AM in reply to: will2605
>rotated the drawings in modelspace

Ummmm ... you did what?

/shivers


Regards,
DJ


Active Member
lamensterms
Posts: 8
Registered: ‎01-10-2010
Message 16 of 17 (2,052 Views)

Re: UCS, World, Viewport crosshair drawing rotation issue

01-10-2010 07:19 PM in reply to: will2605
i am having the same issue with autocad 2009 (i just googled my problem and found this thread). what happens is... set my UCS to world, viewing the model in an isometric view, and when i go to draw a polylin/rectangle/line/etc i can see the UCS rotates slightly (about 1 degree) about the X axis. so when i draw my line/shape... it is not sitting "flat"/"parallel" with the world UCS.

any help with this problem? wills solution does not work for me.

cheers.
Active Member
lamensterms
Posts: 8
Registered: ‎01-10-2010
Message 17 of 17 (2,052 Views)

Re: UCS, World, Viewport crosshair drawing rotation issue

01-10-2010 07:52 PM in reply to: will2605
after some more investigation... i think i have found that the reason the UCS was rotating itself is because of the auto align/align to face feature of the newer autocads. is there a way to disable this feature?

the feature im talking about is when i try to draw a polyline, the ucs will align itself with the face of a 3d solid i am hovering over.

any help would be greatly appreciated.

----SOLVED------

the problem was with the feature called "dynamic UCS". toggle this feature on/off with CTRL+D.

my dynamic UCS was aligning itself with a hidden item, so i was waving my cursor around my viewport watching the UCS change in all funky ways... aligning itself with faces of a 3D solid that was hidden... what a drag.

hope this could help a few folks out. Edited by: lamensterms on Jan 11, 2010 3:56 AM

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements

    Come hangout with Autodesk Support Specialist and AutoCAD guru Volker Cocco, to learn about Precision Drafting: Object Snaps and Object Tracking on July 31 @ 11:00 AM PST.

    Click here for registration information!

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community


Connect with AutoCAD

Twitter

Facebook

Blogs

Pinterest

Youtube