AutoCAD 2007/2008/2009

Reply
*Bill Gilliss
Message 11 of 16 (577 Views)

Re: Smooth 3D Solids

02-03-2009 05:13 PM in reply to: oopzie

MarianDLL wrote:
FACETDEV
is probably not an Acad 2008 command coz it says is't an unknown
command. However i've tried FACETRATIO command which says: FACETRATIO
Controls the aspect ratio of faceting for cylindrical and conic solids.
A setting of 1 increases the density of the mesh to improve the quality
of rendered and shaded models.
0 Creates an N by 1 mesh for cylindrical and conic solids 1 Creates an
N by M mesh for cylindrical and conic solids How can you set the "N"
and "M" values?
It didn't work either.





Sorry -- FACETDEV is a AEC option that apparently isn't available in
vanilla
AutoCAD. From ACA 2009 Help:





"Facet Deviation



 ...
name="WS1a9193826455f5ffc751fd10f4618e369-2a91">
The facet
deviation is available only on the command line by typing
class="strong">-AecFacetDev
.


name="WScedd0d2069f88934b1c260fa2565c2ce-7f39">


name="WS1a9193826455f5ffc751fd10f4618e369-2a90">
The number
you set as the facet deviation defines the maximum distance from the
chord to the arc, the chord being an edge that is created from faceting
the curve, to the true mathematical arc. The facet deviation has a
range of greater than zero (0) and no upper limit.



name="WS1a9193826455f5ffc751fd10f4618e369-2a8f">
The minimum
number of facets is 8. For example, when you create a cylinder mass
element with a 1' radius, and specify a FACETDEV value of 1', the
cylinder has 8 faces."


Now you know.






Contributor
MarianDLL
Posts: 13
Registered: ‎02-02-2009
Message 12 of 16 (577 Views)

Re: Smooth 3D Solids

02-03-2009 06:44 PM in reply to: oopzie
Yes I've tried "vsedges" but with no luck.
I always have facetres set to max value, except in case when I'm trying to figure out something...
Thanks anyway...

The problem is not about setting some parameters to their max values or something, because as you can see on the picture, some of the solids are rendered correctly in the scene while others in the same scene are not. So this is a point where ALL the arguments about setting something up are failing. Also you have to realize that sometimes it WAS rendered correctly after few attempts without changing any settings. (I was just cprobably changing the view I mean the angle, and I was orbiting and then suddenly It was somehow correct) So this is no matter of settings.
I have a feeling that the problem is in the way you create solids. Primitive solids, or swept solids are usually rendered correctly, while solids created by subtracting one from each other are usually not rendered correctly. I think It's like this: the settings we are mostly talking about applies mainly to solid primitives but not to complex solids you can create in very different ways. It's like the more complex object you create the more you loose the precision or something..... hmmm no no . Wait a second. That's not true. The guy who started this forum had problems with cylinders and they are solid primitives, Or does he used union command by any chance?? maybe. I don't know. Someone should ask programmers about that. keep trying. :-)
Contributor
MarianDLL
Posts: 13
Registered: ‎02-02-2009
Message 13 of 16 (577 Views)

Re: Smooth 3D Solids

02-03-2009 06:47 PM in reply to: oopzie
Thanks for info! Good to know.
I should uninstall that 2008 crap! OMG. What will I do then? Go on a holiday? hahahahahahahahaaaaaa aaaarggggghhhhh I'm tired....
Active Member
gede
Posts: 6
Registered: ‎05-15-2007
Message 14 of 16 (577 Views)

Re: Smooth 3D Solids

02-25-2009 08:16 PM in reply to: oopzie
My heart goes out to you for all the trouble you have had and your determination to solve it.

I am looking at this site because I was having exactly the same difficulty and was trying to find an answer.

I knew something had changed, because I was comparing a .tiff file I had done six months ago which was as smooth as a baby's bum with a rendering I was obtaining now which had approx 16 facets on the same model in the same drawing which I had not changed in any way

Like you, I tried tweeking all the settings in 2008 without seeing any changes in the displayed rendering and was about to revert to 2004. So I saved the drawings (three separate drawings of almost the same model). Something made me try again, so I opened the drawings and rendered again - voila! good as gold I tried again on the other two and they were also good.

My gut feeling is althhough we are making changes to the settings, the rendering engine is not seeing them and may not until the drawing is saved and reopened.
Distinguished Contributor
oopzie
Posts: 152
Registered: ‎08-21-2006
Message 15 of 16 (577 Views)

Re: Smooth 3D Solids

02-25-2009 08:23 PM in reply to: oopzie
All i used was the simple cylinder command.
New Member
snappycad
Posts: 1
Registered: ‎02-07-2013
Message 16 of 16 (380 Views)

Re: Smooth 3D Solids

02-07-2013 04:14 PM in reply to: oopzie

Try ISOLINES - this works great for me!!  I'm using 3D Solids and isolines affects everything - even objects that have been subtracted or joined.

 

But be careful!  going very high will seriously slow you down!

 

Try slow and go up.  To see the effect, change ISOLINES to 1 then command REGEN then change ISOLINES to 2 and then command REGEN to see the result.

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community




Connect with AutoCAD

Twitter

Facebook

Blogs

Pinterest

Youtube