AutoCAD 2007/2008/2009

Reply
Contributor
adamdivine
Posts: 17
Registered: ‎03-27-2006
Message 1 of 8 (660 Views)

Hatch patterns don't appear properly

660 Views, 7 Replies
03-20-2008 11:58 AM
My hatch patterns appear properly in the pattern dialog box but when I preview them or insert them into the drawing, they don't display properly. For example, the concrete hatch appears as lines instead of circles and triangles. Any ideas?
*Pat
Message 2 of 8 (660 Views)

Re: Hatch patterns don't appear properly

03-20-2008 12:09 PM in reply to: adamdivine
I've had a problem with concrete hatches when the scale was set too small.
The triangles would explode apart.


wrote in message news:5881622@discussion.autodesk.com...
My hatch patterns appear properly in the pattern dialog box but when I
preview them or insert them into the drawing, they don't display properly.
For example, the concrete hatch appears as lines instead of circles and
triangles. Any ideas?
Distinguished Contributor
sadkuh
Posts: 175
Registered: ‎03-04-2008
Message 3 of 8 (660 Views)

Re: Hatch patterns don't appear properly

03-20-2008 12:17 PM in reply to: adamdivine
If you are trying to hatch an object that is far away from the coordinates 0,0, you may want to try these 2 things.
1) Copy the object you want to hatch to 0,0 and hatch it then move the hatch back to the original object.
or
2) type "snapbase" and click near the object you want to hatch. Now try hatching it and that should work also.
Contributor
adamdivine
Posts: 17
Registered: ‎03-27-2006
Message 4 of 8 (660 Views)

Re: Hatch patterns don't appear properly

03-20-2008 02:27 PM in reply to: adamdivine
I tried snapbase and it is still messed up. I tried hatching close to the origin and it diplayed properly. Is there any other workaround other than drawing near the origin and then moving the hatch? I work with things that are spatially located according to NJ state plane coordinates so I am always very far from the origin. This seems like a silly limitation to me.
*George Drayton
Message 5 of 8 (660 Views)

Re: Hatch patterns don't appear properly

03-20-2008 03:30 PM in reply to: adamdivine
The problem of some things not working a long way away from 0,0 as I
understand it is the mathematics of the resolution of the display system
calculated in 16 (?) integer (?) bit resolution/maths. Some hatch
patterns also have trouble working with very small geometry if for
example and area is created in meters rather than millimetres. some more
complex hatch patterns wont work correctly at small scale factors - I
believe for the same reason.

George Drayton CD-CAD Ltd Christchurch New Zealand
*Dave F.
Message 6 of 8 (660 Views)

Re: Hatch patterns don't appear properly

03-21-2008 02:20 AM in reply to: adamdivine
adamdivine wrote:
> I tried snapbase and it is still messed up. I tried hatching close to the origin and it diplayed properly. Is there any other workaround other than drawing near the origin and then moving the hatch? I work with things that are spatially located according to NJ state plane coordinates so I am always very far from the origin. This seems like a silly limitation to me.

Try setting the UCS origin to where you want to hatch.

Dave F.
Valued Contributor
tddbuck
Posts: 65
Registered: ‎11-27-2007
Message 7 of 8 (660 Views)

Re: Hatch patterns don't appear properly

03-21-2008 07:16 AM in reply to: adamdivine
"I tried snapbase and it is still messed up. I tried hatching close to the origin and it diplayed properly. Is there any other workaround other than drawing near the origin and then moving the hatch? I work with things that are spatially located according to NJ state plane coordinates so I am always very far from the origin. This seems like a silly limitation to me. "

I have ran across this problem as well, first if you're trying to hatch an object (say a rectangle) and the lines of it are at different elevations, it will skew the hatch. Another way to try is in the hatch dialog toward the bottom click the "specified origin" button and click near where your hatch is and it should correct it. Hope this helps.
Todd
*Hugh Adamson
Message 8 of 8 (660 Views)

Re: Hatch patterns don't appear properly

03-26-2008 03:54 AM in reply to: adamdivine
As tddbuck says, the AC2008 hatch dialog has a button to allow setting the
hatch origin close to the hatch area. This replaces earlier workarounds such
as moving SNAPBASE or the UCS in some earlier versions.

The problem arises in some concrete and gravel hatches due to limited
precision employed in their specification.. It is possible to repecify such
patterns to a much higher precision within the 80 character definition file
line length limit, greatly increasing the patterns' useful range about the
hatch pattern origin.

http://cadro.com.au/hatchkit/faq1.html


--
Hugh Adamson
Cadro Pty Ltd
www.cadro.com.au

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community




Connect with AutoCAD

Twitter

Facebook

Blogs

Pinterest

Youtube