Area :: Header
Meet the Experts Webinar
Learn how Black Forest Games rebooted the classic C64 platform game “Giana Sisters” from 1987 using Autodesk 3ds Max®.
Discussion Groups

3ds Max CAT

Reply
Contributor
i3ds
Posts: 18
Registered: ‎11-13-2008

Rig resizing headaches

1380 Views, 18 Replies
07-05-2010 08:12 PM
I'm having a heck of a time trying to scale the default "marine" rig using CAT to match the scale of my objects. Basically, I need this guy to be roughly 3x larger than he is (mesh, bones etc.). I tried the scale tool... the screws things up. I tried editing the CAT ratios, it screws things up. I even tried the Animation - CAT rig resizing which just ends-up spitting a bunch of errors. I got around this earlier by just scalling down the entire environment the model was in but I can't do this in this case.

I'm not sure why this is so difficult, I'm using 3ds Max 2011... you would think this is a very common situation but I can't seem to find a way of accomplishing this very easy task.

How do I resize a CAT model so everything stays proportionally the same in order to match the scale of the rest of my environment?

Thanks,
Jon
Please use plain text.
Contributor
i3ds
Posts: 18
Registered: ‎11-13-2008

Re: Rig resizing headaches

07-06-2010 04:24 AM in reply to: i3ds
This problem seems to be isolated with the Marine CAT, the others scale up/down by dragging the mouse while still having the button clicked down.

Jon
Please use plain text.
Active Contributor
Posts: 32
Registered: ‎10-07-2006

Re: Rig resizing headaches

07-06-2010 06:06 AM in reply to: i3ds
have you used the CAT resizing tool?

from: http://download.autodesk.com/esd/3dsmax/cat-help-2010/index.html

To use Rig Resizer:
1. Add a rig.
2. From the CAT menu, choose Rig Resizer. This opens the Rig Resizer dialog.
3. Click the Add button to open a Pick dialog.
4. Highlight the items to resize and then click the Frame button.
All highlighted items appear in the Objects list, along with the type of object (for
example, Skin Mesh, CATBone). Each listed item has an associated check box; to disable
resizing for an item, turn off its check box.
5. Set the Scale Factor value.
6. Click Resize.

All listed and enabled objects are scaled by the specified scale factor.

hope that helps
Please use plain text.
Contributor
i3ds
Posts: 18
Registered: ‎11-13-2008

Re: Rig resizing headaches

07-06-2010 06:44 PM in reply to: i3ds
I have tried that but it generates a lot of errors in a pop-up.

Jon
Please use plain text.
Valued Contributor
StephenT_1
Posts: 68
Registered: ‎09-11-2008

Re: Rig resizing headaches

07-08-2010 10:06 AM in reply to: i3ds
The Rig resizer appears to have a few issues, and its definitely on my list of "To Fix".

In the mean-time, the reason this script exists is because its pretty difficult to correctly scale a fully rigged & skinned character (as you have seen). This Marine rig is fully set-up and ready to animate, unlike the other CAT rigs which are just bones (no skin).

This situation is not as common as you might think - usually the skin is moddelled in relation to its target scenery, and the rig is simply fitted to the mesh. No need to resize the final, skinned mesh.

You can create the marine sans skinning, by using the Marine_NoBones_NoSkin preset, in which case resizing is simply a case of changing the CATUnits scale.
If it aint broke, hit it with a hammer and then we'll see...
Please use plain text.
Contributor
i3ds
Posts: 18
Registered: ‎11-13-2008

Re: Rig resizing headaches

07-09-2010 11:04 PM in reply to: i3ds
I look forward to a solution being figured-out. I think the CAT system is very powerful and hope to use it more extensively in the future.

Jon
Please use plain text.
Distinguished Contributor
Graeck
Posts: 154
Registered: ‎10-01-2007

Re: Rig resizing headaches

07-21-2010 01:57 AM in reply to: i3ds
In the meantime, in order to fix the pop-up errors when using the RigResizer script with a skinned mesh, open the RigResizer.ms script file and remove the following lines:

fn BakeMesh obj =
(
local skinmod = FindSkinMod obj;
select obj;
setCommandPanelTaskMode #modify
modPanel.setCurrentObject skinmod ui:true

skinmod.always_deform = false
skinOps.SelectVertices skinmod #{1..obj.mesh.numverts}
skinOps.bakeSelectedVerts skinmod
)


local skinmod = FindSkinMod obj;
select obj;

-- add an XForm modifier
xformmod = XForm()
modPanel.setCurrentObject obj ui:true
modPanel.addModToSelection xformmod

--xformmod.center = (Inverse (getModContextTM obj xformmod)).pos
--xformmod.center.controller.value
xformmod.gizmo.scale.controller.value =
subObjectLevel = 0


After that, scale your skinned mesh in sub-object mode and turn Always Deform in the Skin Modifier off and on again.
My CAT demoreel:
http://www.youtube.com/watch?v=Gfq-4VoeAPU
Please use plain text.
Distinguished Contributor
Posts: 121
Registered: ‎11-27-2006

Re: Rig resizing headaches

09-06-2010 09:22 AM in reply to: i3ds
To have to jump through all these hoops is simply inexcusable.
You can make all the excuses you want, but there should be a straight forward way to change the size of a character.
Why should we attempt to adopt CAT rigs when we have these types of issues?
I may be off base here, but this just seems to be a very poor method of execution.
It seems we will need to stay with biped for a while longer till this issue is resolved or I will need to pay someone to rescale the characters I need (pathetic)..
Please use plain text.
Distinguished Contributor
Graeck
Posts: 154
Registered: ‎10-01-2007

Re: Rig resizing headaches

09-06-2010 11:32 PM in reply to: i3ds
Calm down. I have resized dozens of characters with CAT. The Rig Resizer tool is great and works very well (if the error is fixed). Rig Resizer not only scales the rig (which can be done with the default CAT tools in Setup Mode without any animation layer applied anyway), but also scales the animation correctly. As I said I have done this so many times, you can be sure it works.

Use the following Rig Resizer script. It was really easy to fix. I have changed a few lines in there so it also works with skinned meshes.

Make sure to unhide all objects that belong to your rig, including skinned mesh, helper objects, custom objects and whatever. Open up the Rig Resizer tool and add all objects. Type in your desired scale value and process.

Note if you have a skinned mesh applied, the rescaling of the mesh will not be finished due to the error that has been fixed in my version of the script. You need to rescale the mesh manually afterwards. To do this, don't simply scale your mesh at object level. Scale it in sub-object mode (by selecting all polygons) with the world pivot. Also you need to uncheck and recheck the option "Always Deform" in the Advanced Parameters of the Skin Modifier.

Hope this helps.

On a sidenote, resizing rigs is not easy to do at all. I think we can be happy we have such a resizing tool at all.

Here's the script...

www.graeck.de/showroom/Rig%20Resizer.ms
My CAT demoreel:
http://www.youtube.com/watch?v=Gfq-4VoeAPU
Please use plain text.
Distinguished Contributor
Posts: 800
Registered: ‎09-12-2007

Re: Rig resizing headaches

09-07-2010 02:42 PM in reply to: i3ds
to dustin you might want to hold off on your critiques about cat until you have actually used it. you really cant compare biped to cat. its really like comparing a typewriter to a computer. they operate at levels that are not equal.

you have to either use the script or you could always resize the rig the old way. scale the bones in setup mode and reskin the mesh
Please use plain text.