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3.2 What You See 

 

Figure 3 - Autodesk Vault Interface 

The Autodesk Vault client application has an interface consisting of 6 basic elements: the folder 
tree, the file viewing pane, the file information pane, the shortcuts pane, the help pane, and the 
Query Builder.  Each of these elements can be resized to fit the user’s needs.  Each is described 
below. 

 
–  The Folder Tree 
 

The folder tree displays a list of all of the folders found within the current database.  
Notice that the root folder is called Vault Explorer and is represented by the $ symbol.  
Notice the different types of folder icons found under the root folder.  These are described 
in section 3.3.  Clicking on any folder will populate the file viewing pane. 
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–  The File Viewing Pane 
 

The file viewing pane lists every file that is contained within the selected folder.  It does 
not list subfolders as these are displayed in the folder tree.  Each listed file has several 
columns of information.  These columns can be customized to fit the user’s needs, but the 
basic ones include the file status (represented by the white circle in the column header), 
the file type (represented by the white sheet of paper), the file name, the current version 
number, the user who created the current version, the check-in date, and any comments 
included when the current version was created.  Selecting any file will populate the file 
information pane. 

 
–  The File Information Pane 
 

The file information pane displays 4 types of information about the selected file.  Each of 
these types is displayed in its own tab and these are History, Uses, Where Used, and 
Preview. 

The History tab displays a version history for the selected file.  Each version is displayed 
with a thumbnail image, file name, version, etc.  The file history can be useful in tracking 
the evolution of a design or for rolling back to a previous stage in the design.  Adding 
comments when checking in a file can greatly help with tracking file history. 

The Uses tab displays a structured view of all of the children of the selected file.  In other 
words, this tab displays every file that the selected file uses.  This is very useful for 
viewing the inter-file relationships of a design. 

The Where Used tab displays a structured view of all of the parents of the selected file.  
In other words, this tab displays every file where the selected file is being used.  This is 
also very helpful for viewing the inter-file relationships of a design. 

The Preview tab displays a DWF version of the selected file.  This preview is able to be 
zoomed and rotated (if applicable) with the tools provided in the viewing window.  If the 
window displays the message “Unable to view the file selected”, then a visualization file 
is not available.  If this is the case, the file can still be previewed through an external 
DWF viewer by selecting the Open button on the Preview tab.  
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–  The Shortcuts Pane 
 

The shortcuts pane lists any shortcuts that the user has created to help navigate the vault. 

 
–  The Help Pane 
 

The help pane displays the help documentation for the vault client application.  This pane 
can be undocked and moved around the screen as a separate window if desired.  It can 
also be closed to free up screen space for the other panes.  If closed, the help pane will be 
restored later whenever the help menu is accessed. 

 
–  The Query Builder 
 

The query builder is the vault client’s integrated search function.  By clicking on the 
Expand button circled in Figure 3, the query builder is expanded to give more search 
options.  A detailed treatment of the search functionality is given in section 3.6. 
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3.3 Folder Structure 

The folders displayed in the folder tree are of two main types: 

 – Normal Folder 

 – Library Folder 
 
Normal folders contain the bulk of the data that is added to the vault.  These are the normal 
folders that are created as a design is being built. 

Library folders are special folders that are meant specifically for standardized files that do not 
often change.  These can be reference parts, vendor-supplied components, standard fittings, etc.  
These folders restrict access to their files by typically allowing read-only permission.  Standard 
content center parts are stored in this type of folder. 

The creation and use of library folders follow the same rules as library folders created when 
setting up an Inventor project (IPJ) file. 

A working folder is specified in the vault client, and this working folder corresponds to a folder 
on the user’s local hard drive.  This working folder specifies to which local folder files will be 
downloaded when they are checked out.  Within this working folder, the folder hierarchy will be 
exactly the same as the hierarchy in the vault. 

 

Figure 4 - Matching Folder Structures 
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In Figure 4, the working folder has been set to “D:\Vault Training” which results in the root vault 
folder ($) mapping to that local folder. 

NOTE:  The vault creates local folders only when files contained in the corresponding vault 
folder are downloaded, so all of the folders found in the vault may not exist on the local hard 
drive. 

3.4 Behind the Scenes 

Several operations in the vault client application create or modify files.  With each of these 
operations, the master files stored in the vault database are never directly modified.  Instead, each 
file is checked out to the user and downloaded to a temporary folder on the local disk.  All 
operations are performed on the local copy of the file, and then it is checked in and uploaded to 
the database where the new file (or the new version of an existing file) is stored. 

3.5 Adding Files to the Vault 

Files can be added to the vault through either the vault client application or their native 
application’s vault add-in. 

IMPORTANT!  Files from a CAD application such as Inventor or AutoCAD may contain 
inter-file relationships.  To maintain these relationships, these files must be added through 
the vault add-in from their native CAD program. 

An error message will be displayed if a user attempts to add one of these files through the vault 
client.  Adding a CAD file through its native application is described in section 4.6. 

To add non-CAD files to the vault, follow these steps: 
1. In the folder tree, right-click the folder to which you wish to add files.  From the context 

menu, select Add Files. 
2. The Add Files dialog opens.  This displays the contents of the local folder that 

corresponds to the folder you selected.  Browse to the files that you wish to add, select 
them, and then click Open. 

3. The Add Files dialog will change to show the files that were selected.  It will also show 
you where these files will be placed (the vault folder you selected).  You can select any of 
the options available.  You can also add a comment to the file which will be displayed for 
that file in the Comments column of the file information pane. 

4. Click OK.  The files are uploaded to the vault. 
5. Non-CAD files may also be added through their native application’s vault add-in if it 

exists. 
6. Non-CAD files may also be added by dragging and dropping them from Windows 

Explorer to a folder in the vault client application’s folder tree. 
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3.6 Searches: Using the Query Builder 

Quick searches can be performed by typing keywords into the search field (item 6 in Figure 3 on 
page 3-3) and pressing enter.  Any files that have any property that includes the keywords will be 
displayed in the file viewing pane.  The scope of this quick search is the selected folder and all 
subfolders. 

The search can be refined by accessing the query builder.  The query builder can be accessed in 
several ways: 

A. Clicking the Expand button (circled in Figure 3), 
B. On the menu bar, clicking Tools > Find, or 
C. Pressing Ctrl+F. 

Option A – The Query Bar 

Option A expands the query bar shown in Figure 5. 

 

Figure 5 - Searching with the Query Bar 

The current scope of the search is listed in the top of the bar, noted by item 1.  The scope is the 
current folder and any subfolders.  In the figure, the scope is the entire vault.  To change the 
scope, simply select a different folder in the folder tree. 

The search criteria are specified in the area noted by item 2.  If a search of all properties is 
required, type the search term into the Multiple Properties field.  If some keywords need to be 
searched in specific properties, select Add Criteria and select a property.  Criteria can be changed 
by selecting the drop-down arrow next to the property name and selecting a new property.  Once 
the search terms and criteria are prepared, click the Search button. 
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The findings of the search will be displayed in the file viewing pane noted by item 3. 

To save a search, click Options > Save Search. 

Options B & C – The Find Dialog 

Options B & C open a separate Find dialog box that looks slightly different than the expanded 
query bar of option A, but the functionality is identical. 

The Find dialog offers options for a basic search or a more advanced search, similar to the query 
bar described above.  The scope of the search can be changed by clicking Browse and selecting a 
new folder. 

In the Advanced tab, criteria are specified by selecting a property from the drop-down list, 
selecting a condition, and typing keywords into the Value field.  Clicking Add will add this 
criterion to the list below.  Additional criteria may then be added.  Clicking Find Now will 
execute the search.  If there is not at least one criterion in the list, clicking Find Now will list 
every file in the scope of the search.  You must click the Add button even if there is only one 
search criterion. 

To save a search, click File > Save search.  To load a previously saved search, click File > Open 
Search. 

Saved Searches 

Searches can be saved under any name desired.  If the search is saved as a folder, it will be 
displayed under the My Search Folders node in the folder tree. 

Saving a search does not save the results, just the criteria so that the search can be performed 
again later. 

To execute a saved search, select the search from under the My Search Folders.  If the search is 
saved, but not as a folder, then it can only be opened from the Find dialog discussed above. 

Saved searches are not stored on the vault server.  They are stored only on the user’s local 
computer and can only be accessed by that user. 
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3.7 Vault File Status 

Icons indicate the status of files in the vault.  The icons indicate whether a local copy exists, if 
the local copy is up-to-date, if the local copy is the current version, and so on.  The following 
table contains a legend for the icons. 

Icon Description and Required Action 

 
If no icon is displayed, the file is in the vault, but you do not have a local 
copy of the file on your computer. You can quickly identify which files are 
new to the vault. Use Get / Checkout to retrieve a copy of the file. 

File is in the vault and available to be checked out. The version in your 
working folder is the same as in the vault. Also referred to as the Latest 
Version. 

File is in the vault and available to be checked out, but the local version is 
newer than the latest version in the vault. This typically means that your local 
file was changed without checking it out. 

File is in the vault and available to be checked out, but the local copy is out 
of date. Get the latest version from the vault. 

File is checked out to you, but you do not have a local copy of the file on 
your computer. This can occur if you have not set a working folder, if you 
previously checked out the file without getting a local copy, or you checked 
out the file to a location other than your working folder. Use Get / Checkout 
to retrieve a copy of the file. 

File is checked out to you and the local version is the same as in the vault. 
Also referred to as the Latest Version. 

File is checked out to you and the local copy is newer than the latest version 
in the vault. This typically means that you made changes to the file since it 
was checked out but have not checked it back in. 

File is checked out to you and the local copy is older than the latest version 
in the vault. This typically means that you started with a version from the 
vault that was older than the latest version, and then checked it out to 
promote it to the latest. 
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Icon Description and Required Action 

 
File is checked out by another user, but you do not have a local copy of the 
file on your computer. Use Get / Checkout to retrieve a copy of the file. 

File is checked out by someone else, and the local copy is the same as in the 
vault.  This typically happens if the other user did not check changes back 
into the vault. 

File is checked out to someone else, but the local copy is newer than the 
latest version in the vault. 

File is checked out to someone else, but the local copy is older than the latest 
version in the vault.  This typically happens if the other user checked changes 
into the vault, but kept the file checked out. 

File has attachments. Check the Uses tab in the file information pane to see 
what files are attached. 

The appearance of the font for each file name also indicates whether the file is not checked out, 
is checked out to you, or is checked out to another user.  A normal black file name indicates that 
the file is not checked out.  A bold blue file name signifies that the file is checked out to you.  A 
bold gray file name denotes that the file is checked out to another user.  See Figure 6. 

 

Figure 6 - File Name Font Appearance 

For the case of a file checked out to another user, the Created By column indicates which user 
has checked out that file. 

The status of a file may not automatically refresh.  This is especially true if the user checks files 
in or out or otherwise makes changes to any file from outside the vault client application.  For 
example, if the user opens a file through Inventor, checks the file out, and then makes changes to 
the file, a quick look at the file status in the vault client application may not indicate any of this.  
The view may need to be refreshed before the file status icons will reflect these conditions. 
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3.8 Working with Files in the Vault 

Right-clicking a file in the vault client application brings up a context menu as seen in Figure 7. 

 

Figure 7 – The Vault File Context Menu 

The following table gives a description of each function in the file context menu. 

Function 

 
Open 
 
 
 
View in Window… 
 

Description 

 
Clicking Open will open the file in its native application.  If 
that application is not currently running, the vault client will 
attempt to launch it. 
 
This command opens the file in a viewing application 
designed for that file type.  AutoCAD files are opened in the 
Autodesk DWG Viewer.  Inventor files are opened in the 
Autodesk Inventor View application.  All other files are 
displayed in the viewer associated with that file type.  For 
each file type, the appropriate viewing application must be 
installed.  Files viewed in this way are downloaded to the 
local TEMP directory and do not replace the files in the 
working directory.

IMPORTANT! 
Be cautious when 
working in the vault.  
All changes made in 

the vault client 

application cannot be 

undone. 


