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Floating Away: Connecting AutoCAD® Civil 3D® with
HEC-RAS for Floodplain Mapping

Andy Carter, PE — Halff Associates, Inc.

Cl4043 Intended for intermediate to advanced AutoCAD Civil 3D users, this class is designed to show
land development professionals techniques and nuances for extracting detailed hydraulic floodplain
models from a LiDAR terrain. Leveraging the "Export to DEM" method for surface export, this class will
explore performing quick and accurate floodplain delineations on detailed Civil 3D surfaces by
interacting with the newly released and publicly available RAS Mapper in Hydrologic Engineering
Centers River Analysis System (HEC-RAS) version 4.1.0 from the U.S. Army Corps of Engineers.

Utilizing only Civil 3D and open-source programs, this class will demonstrate creating detailed hydraulic
workmaps from Civil 3D surface, then to HEC-RAS model, then to floodplain delineation imported to Civil
3D. This class will further explore the use of grading objects for developing quick and iterative floodplain
analysis to determine the comparative impacts of proposed grading in the floodplain.

Learning Objectives
At the end of this class, you will be able to:

e Develop an existing and proposed HEC-RAS hydraulic model from a LIiDAR surface
e Use Civil 3D® surfaces with HEC-RAS Mapper to create accurate floodplain delineations
e Connect HEC-RAS and Civil 3D® as a full floodplain mapping solution

e Use grading objects to create quick and accurate floodplain reclamation analysis

About the Speaker
Mr. Carter—a project manager in the Halff Associates, Inc., Austin, Texas Water
Resources Department— has more than 14 years of experience in the design of
drainage, stream reclamation, and restoration projects. He was awarded "Young
Engineer of the Year" by the Dallas Mid-Cities Chapter of TSPE in 2007. His
experience includes hydrologic and hydraulic analysis, and the design of
drainage facilities within FEMA floodplains. Mr. Carter's experience has
concentrated on evaluating and designing drainage facilities necessary to
protect infrastructure from flooding and erosion.

acarter@halff.com & civileng127@hotmail.com
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Floating Away: Connecting AutoCAD® Civil 3D®
with HEC-RAS for Floodplain Mapping

NOTE:
This class handout provides a sequence of the workflow (pics and clicks) presented at the AU2011 class. It is

intended to serve as desktop reference for replicating these procedures on your own future projects.

Step 1: Building an Existing Ground Terrain Model from LiDAR

To get the most accurate floodplain model and delineation, it is necessary to produce the most
accurate surface model possible. For this tutorial, we will create an existing ground surface
from a LIDAR terrain model.

1. Open a new drawing in AutoCAD Civil 3D and define the zone in the "Units and Zone" tab of

the "Drawing Settings" as TX83-CF (NAD83 Texas State Planes, Central Zone, US Foot).
=10ix|

Units and Zone |Transformati0n IObject Layers IAbbreviations IAmbient Settings I

Drrawing units: Imperial ko Metric conversion: Scale:
IFeet j IUS Survey Footi39,37 Inches per Meter) j |1" =al j
Angular units: I Scale objects inserted from other drawings Custom scale:
lm ™ Set AuLaCAD variables to makch IGD—
Zone
Cakeqories: Ush, Texas j

Available coordinate systems:

a5 State Planes, Central Zone, LS Fook j

Selected coordinate system code: —I T#83-CF

2. From the toolspace prospector, create an { Toolspace
EG point cloud from the LAS file. 4 LN ENE
Master View j

Prospector

S| Open Drawings
ED Drawingl
@ Poinks

[‘3’] Poink Groups

I "
3. Name the cloud "Point Cloud EG" and —
P Information

Set th e Styl e as " L I DAR PO | nt Enter the name, description and style far the new paint cloud object.
e - Source Data
Classification" and select Next

Information

SUnmarY. Mame:
[Point Cloud - fsMNext CounterdCPY:) El
Description:

Point Cloud Style:

Point Clowd Layer:

[rSmEScen gl
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4. Add the tutorial source data LAS point cloud file "BUDA-SWC4.las" downloaded for this

tutorial and click finish. Make sure that you select an appropriate directory for the point
cloud database.

¥4 Create Point Cloud

Information Specity the file format and file names of the paint cloud source data,

P Source Data

Source Data

i o Processing will be performed in
+ Cieate a new point cloud database: .
Select a point cloud fle format the background and will take
[Las 2 .
Files to be imparted into the new point cloud database: between 3 and 8 mInUtes’
depending on the speed of your
machine.

Summary

File | File Farmat | Coordinat. .. |
[3C:D. JBUDA-SW T las LAS <Monez [

[ |&

™ Use an existing point cloud database.

Mew point cloud database
Specify new point cloud database:
C:\Documents and Settingshah22634My DocumentsiPoint Cloud EG.isd

Point cloud database coordinate spstem:
<Mone>

= 1

Current drawing’s coordinate spsten:
<Mone>

Back | NMext | Finish I Cancel | Help: |

Once the LIDAR processing is complete, perform a
"Zoom extents" to see the LiDAR data.

On the classification tab of the Point Cloud ol
" " . . Information | oints  Classfication |D\;p\sy | Surmmary |
Style, Select only the "2 Ground" Classification.
5| G B G
LIDAR Classification | color [
Se I eCt ap p Iy and O K [ 0 Created, never dassified O zss Z A
[ 1 Unclassified NES =
Bl
[ 3 Low Vegetation Oez P=4
[] 4 Medium Vegetation O y-SITE-SCAN £
\.‘:’}J Funit Groups ~ (15 High Yegetation sz V-SITE-SCAN =2
E| Faint Clouds " - [ 6 Building [ 3 [E%] v-stTE-sCAN =
=3 [[]7 Low point{roise) B3 V-SITE-SCAN =
Point Cloud EG = [] & Madel key-poirtimass poirt) " ES V-SITE-5CAN =
Paint Cloud Properties. .. l (]9 water M o [ v-sire-scan =
- P [ 10 Reserved mES] y-SITE-SCAN £
—F slignments Edit Point Cloud Sty - [] 11 Reserved Oz V-SITE-SCAN =
@ sit s . -+ [] 12 Overlap Foints L [E%] v-stTE-sCAN =
: es At Teints, [ 13 Reserved I 253 [5¥] v-sITE-SCAN = |
(g/ To apply these propetties, select the Points tah and sek the “Assign colar by” property to “Classification”

oK Cancel Apply Help

Create a surface from the LIDAR ground data by Dp.t Couds a
. . W c
selecting "Add points to Surface ..." () suacss Foint: Cloud Fropertiss...

Edit Point Cloud Style, ..

Alignments
- By sites Add Pairts. .
[]"Bﬂ Fipe Metworks Add Points ta Surface. ..
Corridors

- Assemblies
EJ Subassemblies Delete. ..

P .
:b Inkersections

Remove Civil 3D Properties.. .
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8. In the "Add Points to Surface Window", name the surface EG and select Next.

9. Select the "Window" option and click the "Define Region in Drawing.." button. Draw a
rectangle at 3081892, 9975587 to 3084430, 9977755 and select finish. You should see a
surface similar to the one shown below.

I Add Points to Surface

Surfare Options
Specity the point cloud source region for the extraction of visible points.
P Reqion Options

1. Specify a region option
SUMMEry:

£ Paint cloud extents
& Window

" Window polygan
" Dbject

Mid-ordinate distance:

7,000 ﬂ

2. Define the region

Define Region in Draving

Step 2: Export a HEC-RAS Model

With a detailed existing ground surface created from LiDAR, now we will export a detailed HEC-
RAS model from Civil 3D® by defining an alignment and cross sections.

10. From downstream to upstream,

draft a polyline along the center of the
creek.




11. Define stream centerline as a Civil3D alignment.
Name it "RiverCL" and make sure the "Add
curves between tangents"” is unchecked.

12.
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i"1| Create Alignment from Objects ﬂ
ame:
[RivercL '—E—‘l
Twpe
I"::} Centerling j
Descripkion:
El
El
Starting skation: I 0+00.00'
T e o rriteria |
] - — .
[ Conversion opkions
I [T add curves hetween tangents I
Default radius:
| 200,000
W Erase existing entities
QK I Cancel I Help I
A

with HEC-RAS for Floodplain Mapping

Select "Sample Lines" button from the Home tab of the ribbon. Click on the RiverCL

alignment. Name the sample line group RiverXS. Click OK.

V'™ Create Sample Line Group x|
Vault  Bxpress Tools o -
MName: Sample line style:
ns = i\ﬁ Profile View - / - £ [ Rivers rLr_|| [ Fozd Sanvle Line = ™ v| B
Fr ! N o o Description: Sample line label style:
— /
- -5 Sample Lines fu v | R, | |5 section Name = = '| Lol
ik - /I_‘* Section Views - J - & | sample ne layer:
- Alignment: I RO gl
Profile & Section Views Draw :
RiverCL
T | BuLayer j Select data sources to sample!
-—_ Type | Data Source | Sample: I Style Section layer Update Mode "
@ EG Finished Ground C-ROAD-SCTH [yniamic
oK I Cancel Help
|

13. Draw your desired cross sections with
the polyline tool. Make sure that
a. The cross sections cross the
RiverCL alignment once and

only once.

b. No cross section crosses any
other cross sections
c. The entire cross section is

contained within the "EG"
surface.
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14. In the "Sample Line Tool" menu bar, select the "Select Existing Polylines" option. Pick all of

the drawn section polylines.

Sample Line Tools

I <[Sample Line Station Yalue]> LT}‘ ":E;

[-] Riverxs

T|*

o Bl & 5B

|Current method; By stations |.ﬁ.|ignment name;: RiverCL

,pﬁ( B range of stations. ..

Jo ¥ AL a Station
_ﬂ From corridor stations

'[;F Pick. points on screen

u—-n[% Select existing polylines

15. In the output tab of the ribbon, select the "Export to HEC RAS" button

[WToTidl Manage Raster Tools Vault  Express Tools [ - I

E&] Page Setup Manager ﬁ M (O'_ﬁ
EEK :_ﬂ'

<2 Export Points

DH, Transfer Points

FS Export Civil Objects to 2

@ Export to Storm Sewers

&7, View Details
“ il Publish to  share with | Export &

E'EI Plotter Manager Google Earth  Seck LandXML

[ Export to HEC RAS |

it - | Publish |

Export

16. Select the appropriate surface, alignment and sample line group. In the "River name" field
type in "CartersBranch". Click the export button.

Export to HEC RAS _ Ol x|
—Select Surface and Alignment —Select Sections ta ERport

Surface: Sample line groups:

[EG =l E[§,| |Riverss =l

Site: River name:

I <Mone> j IEartersErancH

Reach alignment; River Banks

IHiVB'CL j EL%;' [ Check this to uge river banks

= Left I~ Right
Export | QK. | Help |
A

17. Save the file as "CartersBranch.geo"

TIP:

The routines inside Civil3D assume that the sections are for a roadway. Roadway designers assume that
roadways sections are from right to left looking in the direction of decreasing station. Hydraulic engineers
assume that a cross section in a hydraulic model is looking left to right looking downstream. Hydraulic
engineers also assume that the stationing decreases as you look downstream.

This causes Civil 3D® to export a hydraulic model that is "flipped" according to the standard hydraulic

modeling nomenclature.
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18. To correct and "flip" the exported HEC-RAS file, run the Halff Associates’ Civil3D RAS
Flipper. Select the “GEQO” file and process. The amended file will have a*_mod.geo file
name saved in the same directory.

F-Halff Associates - Civil3D HEC-RAS Flipper x|

File  Help

—Step 1 - Load "Geo" File

(RN - Dl 30 T utorials B S E xporttCarterBranch. geo

Browse. . |

— Step 2 - Create Revised GEO File

Create Revized File

Step 3: Creating a Hydraulic Model in HEC-RAS

With the exported and reversed channel geometry file, the geo file will be imported into HEC-
RAS 4.1.0, so that a floodplain can be computed. Download HEC-RAS at
http://www.hec.usace.army.mil/software/hec-ras/

19. Open HEC-RAS and select File and then New Project. Save the project as "CartersBranch"

BN HEC-RAS 4.1.0 o x|

File Edit Run Yiew Options GIS Tools Help
(o o e 0 S e N [ (s e 1
I

Praject: |_ g

20. From the main HEC-RAS window, select the Geometry button.

File Edit Buo. View Options GISTools Help

ER|EER Bl B2

Proiect | = =
’ﬁﬁjit Options  Wiew Tables Tools GIS Tools  Help
21. In the Geometric Data window, Select File 2> fon Seomey e
Import Geometry Data - GIS Format... Sz GTE i

Save Geomekry Data As ...
Reename Geometry Title
Delete Geometry Data

Copy to Clipboard

GI5 Format ...

USACE Survey Daka Format L.,
HEC-RAS Farmat ...

— HEC-Z Format ...

Strctle UMET Geometry Formak ...

Exit Geometry Data Editar

HEC Stream Alignment ...
Stnorage Mike 11 Cross Sections ...
rea
CSY (Comma Seperated Yalue) Format ...
- [ B B 7
GML Format ...

Storage
frea Conn

=
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22. Select the CarterBranch_mod.geo and select OK. Select the "Finished-Import Data" button
on the Import Geometry Data window

Import #GIS Format data file

Title File Mame Selected Folder Default Project Folder ty Docurnents
IEarters Branch IEarterBranch_mod.geo EACIB0 T utorialhRAS_E sport
Carters Branch CarterBranch.geo R
:Larters Branch Carterbranch mod.geo 3 Civl3D Tutorial
ok Cancel Help Create Folder ... | = j

|Select GIS Format file to import

Import Geometry Data

Intro | Riiver Reach Stream Lines | Crass Sections and 1B Nodes | Storane &reas and Connections |

Previousl {HewE Finished - Import Data I Cancel |

Geometric Data
Flle Edt Options View Tables Tools GIS Taols Help
o

23. Confirm that the stream
centerline is downstream and
the cross sections are "looking
downstream, left to right".

=[] Flot ws extents for Frofe =

2071.42

326961 1845.99

24. Set the Manning's 'n' values for all the cross sections. In the Geometric Data window select
Tables - Manning's n of k values (horizontally varied)...

Geometric Data
File Edit ©Options Wiew | Tables Tools GIS Tools Help

ﬁaﬁéaage Manning's n or k values (Horizonkally waried) ...
] Reach Lengths ...

CantractionlExpansion Coefficients (Steady Flow) ...
CantractionlExpansion Coefficients (Unsteady Flow) ...

RAim oy | mmmmm
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25. The Highlight all of the "n rows" an select the "Set Values" button.

Bl IEarters Branch j il E [V Edit Interpolated #5's Ehannel! nh}falues have
a light green

Reach: IHiverCL j IAII Regions j backaround
"Selected Area Edit Optiohs ‘

Add Constant .. | Multiply Factor ... II Set Values .. |I Replace ... I Reduceto L ChA .. |

Riiver Station Fretn k) | n i1 | n 2 | n #3
326961
2999.29
288458
2751.06
2539.69
2497 51
2377.58
223197
5| 2071.42
10[1845.99
11[1709.45
12113316
13[865.3
14| 74572

o= || e e ra ) =

153629
16| 288.66
17(111.82

I 3|33/ 3333 33 3333

QK | Cancel | Help |

Enter a amount

26. In the "Enter a amount to set entries in the selected range" form, type
in the value of 0.040 and select OK. Select the OK button on the "Edit
Manning's n or k values" form.

ok | Cancel |
27. In the geometric data window, select the '?Zeid:emf::r;at:‘ew LU,
File > Save Geometry Data As... S iy D &
Save the geometry data as "ExCartersBranch" ekl s

Save Geometry Data As ...

Rename Geometry Title

© O Tmarmebeu Mok

28. In the geometric data window, select the
File > Save Geometry Data As... Title
Save the geometry data as "ExCartersBranch" |F:CattersBranch

Create a Flow file

HEC-RAS 4.1.0
Eile Edit Run View Options GIS Tools Help

29. Select the "Edit /enter steady flow data" button on the

main HEC-RAS window. @ |

R P
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30. In the steady flow window, select
File > Save Flow Data AS...
Save the flow as "ExistingConditions".

Title

IE wiztingCaonditions

31. In the steady flow window, select
Options > Edit Profile Names
Rename the first profile from "PF 1" to "100Yr" and
select the OK button.

HEC-RAS

Edit Profile Marr

[16 Characters kdax]

Frofile # Frofile Mame

100

with HEC-RAS for Floodplain Mapping

Steady Flow Data
File ©pkions Help

Mes Flaows Data
Open Flow Data ...
Save Flow Data

Save Flow Data A5 ...

Renare Flow Title ...

Steady Flow Data - ExistingConditions
File | Options Help

Wndo Edits

Erte
- Copy Table ko Clipboad {with Headers)
- Delete Row From Table
™€ Delete All Rows From Table ..
Fea  Delete Column (Profile) From Table

Ratio Selected Flows ...
Edit Profile Mames ...

Set Changes in W3 and EG ...

I
b e Al

Steady Flow Data - ExistingConditions

32. In the steady flow window, set the 100yr flow
value to 1,500

File
Enter/Edit Mumber of Profiles [25000 max): |1

Options  Help

Reach Boundary [

Locations of Flow Data Changes

River: ICarters Branch j
Reach: |RiverCL =] River Sta:[3269.51 e
Flow Chanhge Location _
River Reach RS 100
Carters Branch RiverCL 3J269.61 1500

33. In the steady flow window, select the "Reach Boundary Conditions.." button. In the "Steady
Flow Boundary Conditions" form select the "Normal Depth" button and enter a value of
0.005 in the field. Select OK and OK to return to the Steady Flow Data form.

Steady Flow Data - ExistingConditions

File Options Help

Enter/Edit Mumber of Prafiles (25000 rmax): |1 Feach Boundary Conditions ..

| Aep

Locations of Flow Data Changes

Steady Flow Boundary Conditions

™ Set baundary for ane profile at a time

& Set baundary for all prafiles

Ko .5, |

Ciitical Depth |

Selected Boundary Condition Loc:

ondtion Tupes

Mormal Depth

HEC-RAS

ID. 005

Cancel |

Rating Curve I

rz and Types

| River [ Reach [ Prafils [

Upstream

L ownztream

Carters Branch RiverCL all

10



34. In the steady flow window, select
File >EXxit Flow data editor

Creating and Executing a Plan

35. Select the "Perform a Steady Flow Simulation”

from the main HEC-RAS window.

36. In the steady flow analysis window, select

File > Save Plan As..
Save the plan as ExPlan

For the short plan identifier enter "ExPlan"

HEC-RAS

IE:-:F'Ian

ok |

Cancel

37. Select the "Compute" button on the
Steady Flow Analysis form.
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’ﬁ Options  Help
e Flows Data [
Open Flow Data ...
Save Flow Data
Save Flow Data A5 ..,
Rename Flow Title ...

Lielete Flaw Data ... 2,
Set Location For 0SS Conneckions ... '

|
D55 Import ... ?

Impart Flows From Existing Qutput Prafile ...

Exit Flow Data Editar

HEC-RAS 4.1.0
File Edit Run View

- T

|CartersBranch

Qptions  GI5 Tools  Help

Froject:

Save Plan Data As

Title
IEHF'Iar]

Steady Flow Analysis
File Cphions Help

Mew Plan

Open Flan ...

Save Plan IE
Save Plan As ... I-E

Rename Plan Title ...
Delete Plan ...

ECT

Exit

d LI =1

Steady Flow Analysis I ] |
File Options Help
Plan: [ExPlan Short D [EsFlan
Geometry File : IEHEartersBlanch

Steady Flow Fila :

Flow Regime——
& Subcritical
 Syupercritical

7 Mived

Lef 4]

I E xigtingConditionz

Plan Dezcription :

El

[Erter to compute water surface profiles

11
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Step 4: Export surface from Civil3D and convert to FLT for use with HEC-RAS
Mapper to delineate the floodplain.

With the flood profile computed with HEC-RAS, we now need to get the existing ground surface
from Civil3D to the HEC-RAS Mapper to perform the floodplain delineation. To do this, we will
export the existing ground from Civil3D as a GeoTIFF and convert the GeoTIFF to the HEC-
RAS native ESRI FLT format. This conversion will require SAGA GIS. Once converted, the

surface DEM will be used to perform floodplain delineations.
EI@ Surfaces _
38. In the Civil3D toolspace, right click on the EG surface and A e r———

eLking:

H- 23 alignments

select Export to DEM Bl sies Edi Surface Styke.
[]--ﬁ'ﬁ Pipe MNebworks Rebuild
[ Corvidars Rebuild - Automatic
E"_-. Assemblies

Create Snapshaot
E Subassemblie:

Femave Snapshot
* Intersections

Febuild Snapshot

[]"ﬁ Survey

[Ig] Wigw Frame G Add Label...
3 Projects
ﬁ Dat]a Shiortcuts [] Select

Zoam to

ﬁj\@ Surfaces Panto
-+ -g Alignments
ﬁ% Pipe Metworks Lock.
[’E‘E] Yiew Frame Group Unlock

S Drawing Templates

x
39. Export the DEM with a grid spacing o 3

of 1.0. Under the "Dem file name" F—— e

select the file icon and save the file A R 557
Name

as EG.tif (make sure the GeoTIFF Description

. . Drawing coordinate zone NADE3 Texas State Planes, Central Zone, US Foot

option is selected.) =6 Export
Dem file name
Export coordinate zone NADES Texas State Planes, Central Zone, US Foolt !
Grid spacing 1,000
Determine elevations by Sample Surface at grid point =l
Use custom null elevation Mo ;I
Hull elevation 1000000000000000000000000.000

,TI Cancel } Help

File: narne: IEG-“f j &l

Files of type; | GEOTIFF f*1if] x| Cancel |

40. Select OK to begin the exporting of the surface.

12



Floating Away: Connecting AutoCAD® Civil 3D®
with HEC-RAS for Floodplain Mapping

Convert the Civil3D GeoTiff to a HEC-RAS native ESRI FLT.

TIP:

To convert the GeoTIFF to an ESRI FLT, conversion through a GIS package will be necessary. It is
important to note that HEC-RAS is particular with the input format of the header (hdr) file that is paired with
the converted FLT. HEC-RAS assumes that the FLT was generated from ESRI's ARC-GIS which writes
these files in a very particular way. Manual revision of the hdr file will be necessary.

Download the SAGA software for grid conversion at:

http://sourceforge.net/projects/saga-gis/files/

L g SR e e
@ Impark/Export - DXF
) ] i % Import/Export - ESRI EOD
41. Open SAGA GIS and import the GeoTIFF by selecting & @ mmpart/export - cbaLjocr
Import/Export — GDAL/OGR - GDAL: Import Raster e GDAL: Export Raster
'% GOAL: Export Rasker ko GeoTIFF
- GOAL: Import Raster
'% OiGR: Export Yeckor Data
L. Mg OGP Import Veckor Daka
@ Irnpart/Expart - GRIE Files

42. Navigate to the exported "EG.tif" and select Okay.

x|
B oOptions
Okay
EEE c:\Documents and Settings',ah2263)Desktop\LIDAR-Kyle\EG.AF" ] —I
Cancel I

LUl wgme LN LAY Lot L

43. Export the GeoTIF to a ESRI FLT by selecting :g iﬂ.‘iﬂiﬁiiiﬁiﬁii??&ﬁff

Import/Export - Grids - Export ESRI Arc/Info Grids =@ ImportiExport - Grids
: Export ESRI ArcfInfo Grid
© Mg Export Grid bo KYZ
: Mg Export Surfer Grid
Mg Fynort Troe Colar Ritman

44. Select the Grid system and under the "Grid" select 01.EG. Select binary as the format.

B Data Objects

E Grids
E Grid system 1; 2252% 2335y; 3081987.250000x 9975728.020000y
= Grid 01. EG
E Options

File J
Format

Geo-Reference COFnEr
ASCIT Precision 4
ASCIT Decimal Separator poink .}

13
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45. Under the file option, save as "EG" and select the file type of "ESRI Arc/Info Binary Grids
(*.fIt).

Export ESRI Arc/Info Grid

B Data Objects
B Grids
El Grid system 1; 2252% 2335y; 3081987.280000x 9975728.020000y
> Grid 01.EG
B Options
File
Format binary

1 EG j Save I

3 type: ESRI Arcdlnfo Binary Grids [*.ft] j Cancel |

ESRI Arc/lnto Grids FA
ESRI Arc/info ASCI Grids [*.asc]
‘ESEI Arc/lnfo Binary Gds [7 ]

Select Save and Okay to execute the conversion.
46. Close and Exit SAGA GIS.

Convert to a VERY SPECIFIC hdr file.

47. Open the EG.hdr file paired with the EG.flt file in a text editor (notepad). The acceptable
HDR format for HEC-RAS Mapper is:

ncols XXXXKXXX Nine (9) spaces proceeding

nrows XXKXXXXX Nine (9) spaces proceeding

xllcorner | XXXXKXXX . XX Five (5) spaces proceeding

yllcorner XXXXKXXX . XX Five (5) spaces proceeding

cellsize XX Six (6) spaces proceeding

NODATA value = -9999 Two (2) spaces proceeding

byteorder LBSFIRST Five (5) spaces proceeding

Edit the hdr file from this.... ...to this (case and spaces DO matter!)
MCOLS 2252 ncols 2252
MROWS 2335 M Ows 23345
XLLCORNER 3081986, 7800000003 x]lcorner  3081980.78
YLLCORMER 9973727, 5199599904 ?:(eTIsize 1.0 ’
CELLSIZE 1.000000 MODATA walue -09900
MODATA_VALUE 340282346638528800000000000000000000000, 0000 byteorder LESFIRST

Save the hdr file as EG.hdr

14



Floating Away: Connecting AutoCAD® Civil 3D®
with HEC-RAS for Floodplain Mapping

Step 5: Delineating a Floodplain in RAS Mapper
48. With HEC-RAS 4.1.0, ensure that the

. . File Edit Run WYew Options | GIS Tools Help
CartersBranch project is open an select from .

the main RAS menu,

GIS Tools - RAS Mapper... Praierk: |CartersBranch

RAS Mapper ...

49. In the RAS Mapper window, select Tools = Floodplain Mapping.

RAS Mapper
File | Tools | Help

Define Projection ...

A &

Floodplain Mapping ... | S

- [ CarterBranch_rv.geo
[El- [#] ExCartersBranch

i [2] River

; [ v B

‘[ Results

50. In the Floodplain Mapping window, select the "New Terrain ... " button. Select the EG flt file.
Name the terrain layer "EG"

Floodplain Mapping il
HEC-RAS Plan: IE:-:F'Ian j ﬁl CartersBranch.pl2

—HEC-RAS Geometry/Interpolation Surface

[ Usze Existing Transition Lines:

River Layer: IGeometr_l,l'\E sCartersBranchiRiver j
%5 Laver: IEieumetr_l,l'\EHEaltersBranch\XS j
S Layer: I j
Leves Layer: I j
[

|

Compute Interpalation Surface

—Ground Surface
Teran Laver | NN - V= Tenain ... |l Add Files ... |

|—La_l,lers to Generate L |

e
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Floating Away: Connecting AutoCAD® Civil 3D®
with HEC-RAS for Floodplain Mapping

51. In the Floodplain Mapping window, under the Layers to generate section, check the 100Yr
profile and the Water Surface Elevation check boxes. Note the output directory. Select
the Generate Layers button.

Floodplain Mapping x|

HEC-RAS Flan: IEHF'Ian j ﬁl CartersBranch.p02

— — |

—Ground Surface

Terain Layer: EG j News Terrair . &dd Files ...
—Layers to Generate
— Profiles —Wariables
[ Al [~ al

[ Welocity
[] Shear Stress
[] Stream Power

Output Directary:  |C:ADocuments and Settingz\ah2263hD eskiophLIDAR Fple\ExPlan Lj |

Generate Layers | Cloze |

52. Review the floodplain results in the RAS Mapper window. Save the HEC-RAS project and
close HEC-RAS

]
QBrasvamoer . EIE ]

S Fle Tools Help

R ®E A . o e i 309382996, 9977212.64 1 pixel = 3.36)

- [ Geometry
[ CanterBranch_rv.geo
(=1 [F] ExCartersBranch
~ [ River
Exs
- O Transiton Lines
= [F Results
- [ ExPlan
1001 Floadplain
- O1100v: Depths
Oes

Creating color ramp: Terain 0.5 sec
Creating color ramp: EG 0.4 sec

Crealing tansiion lines...[Done 0.3 sec]
Crealing interpolation surface...[Done 0.1 sec)
Frocessing WS Profle: 1007t

Deplh Giid and Bocndary .. (Done 14 sec]
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Floating Away: Connecting AutoCAD® Civil 3D®
with HEC-RAS for Floodplain Mapping

Step 6: Import the floodplain to Civil 3D®

Utilizing the MAP tools in Civil 3D®, we will import the floodplain limits delineated by RAS

Mapper.

53. In the command line of Civil 3D®, type in "mapimport" to bring up the shapefile import

routine.

l Conmtnand: mapimport

54. Insuring that the file type is "ESRI Shapefile (*.shp), navigate to the Output Directory utilized

in RAS Mapper. Select the 100YR folder - select the floodmap.shp. Select OK.

Laak jr: I [ 10

j & B F O P Vews v Tods -

2l x|

Marne =

Size | Type

| Date Modifis

x

floodmap. shp

546 KB AutoCAD Shape So...

File name: |f|l:|l:|C|IT|a|3.Sh|:l

Files af ype: IESFII Shapefile [*.shp)

gi6iz011 10

j ok |
j Cancel |

55. In the shapefile import window, check the "Import polygons as closed polylines" options and

select OK.
Sl Import - C:4..\floodmap.shp ﬂ
r— Current drawing coordinate systemm — Spatial filker
& | T+83-CF % Mone

MNADEI Texas State Planes, Central Zone, US Foot
" Cunent display

r— Driver options
[river [ ptions.... |

|mport properties for each laver imported:

Changing these options map affect the lapout of the ! Define window

g’\
import properties table,

it}

Input Layer
[ floodmagp

Drawing Layer
floodmap

Ohject Class
=Mang=

Input Coordinat
=Mane=

Data
=Mane=

Points
2ACA0_POINT-

— Saved profiles

Load..

Save... | ¥ Import polygons as closed palylines

Current profile:
i ¥ Use class defaults for out of range walles

]

Cancel Help
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Floating Away: Connecting AutoCAD® Civil 3D®
with HEC-RAS for Floodplain Mapping

56. Observe the delineated floodplain line,
that cleanly matches the Civil3D surface.

Step 7: Creating a Floodplain Surface

Building a Civil 3D surface that represents the existing floodplain is import to (1) show the water
surface on the cross sections and profiles, (2) calculate valley storage volumes, (3) develop
optimized feature lines for grading objects, and (4) creating base flood elevation lines (BFES).

57.In HEC-RAS, Select File - Export Geometry and Results. F] HEC-RAS 4.0
Check the “Water Surface Elevation” and the desired flood Et_Run_View Options GIS Tools Help
profile. Note a GML and XML file is exported. e

Open Project ...
Save Project

Save Project As ...

7 . : -
Ex o MaDoet Select Profiles Rename Project Title ...
. Delete Project ...
ot ] A B el Project Summary .

I Stream Fowar Export GIS Data ...

-~ 1(100yr)
¥ ater Surface Elevation Import HEC-2 Data ...
I Valociy ~ Import HEC-RAS Data ...
I Sheer Stress Generate Report ...
—

Select Al Clear Al \

- = Exvport o HIEC_ )
0K Cancel 0K Cancel I I

| Export Geometry and Results (RAS Mapper) ...
i
’ Restore Backup Data

58. Ensuring VBA is installed for Civil 3D®, load the RASgeoToCAD2011.dvb routine with the
vbaload command. Type in vbarun in the command line. Pick the dvb and click “run”.

Macro name:
\WBA\RASgeoToCAD2011.dvbiModule1HecRAS_To_CAD Run
C\VBA\RASgeoToCAD2011.dvbiModule1 HecRAS _To_CAD
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59. Load the GML and XML files
exported from HEC-RAS.

This routine will draw polylines for
the cross section at an elevation
equal to the selected flood profile.
These polylines will be used as
breaklines to produce a “Water
Surface”

Floating Away: Connecting AutoCAD® Civil 3D®
with HEC-RAS for Floodplain Mapping

Step 1: Select HEC-RAS XML & GML Output Data
HEC-RAS GML Fie: ‘ C:\Users\Andy\Desktop\CivI3DTutorial\HEC-RAS) Bonre |

HEC-RAS Qutput XML: ‘C:\Users\Andy\Desk‘top\Civ\I3DTut0ria[\HEC—RAS\ Browse... |

Step 2: Select a Flood Profile

List Available Profiles |

Avaiable Profiles:

Step 3: Import Model

Import Cross Sections @ Food Elevations

60. From the prospector, create a new surface. Add the imported and elevated polylines to the
surface as “standard breaklines” If desired, apply the floodplain limits as the outer boundary.

~[#] Point Groups
~@ Point Clouds

=
L &° | CreateSurface.. |
Create Surface From DEM...
. > Alignn Create Surface from TIN...
B Sites

=2 @ Definition “
=
@ Boundaries = E
Wi sreakines WK
fE_‘-l Contours m
(B DEM Files Refresh
P e — ——m
= @ Definition ‘ ng I
Nedcourcares  pa— 1

l % Breaklines

: - Contours Refresh

The image to the left shows the constructed
AutoCAD® Civil 3D® “Water Surface” of the
100-Yr flood event from the HEC-RAS analysis.
For clarity, this image shows base flood
elevation lines (water surface contours) at a 0.1
foot interval. Typical floodplain workmaps would
show a water surface a 1 foot interval.
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Floating Away: Connecting AutoCAD® Civil 3D®
with HEC-RAS for Floodplain Mapping

Step 8: Developing a proposed grading plan for a Post-Project HEC-RAS model
Using the constructed “Water Surface”, we will use feature lines and grading objects to develop
a proposed floodplain reclamation grading plan. Pasting the proposed surface to the existing

ground, a Post-Project hydraulic model can be exported and evaluated relative to the existing
conditions.

61. Within the limits of the “Water surface”, draw a polyline along the limits of the proposed
reclamation. From the Home tab of the Ribbon, select Feature Line - Create Feature Line

from Objects. Create a new site titled “ProposedGrade” and add the feature line. Assign
elevations from the “Water Surface”.

&, Create Feature L\ne__L
o= Options
B ProposedGrade -
() Elevation: 0.000"
[[Iname
From gradings
Feature <[Next Counter(CF)]
Q) From surface
5 L [ iierSutace -
.4 Basic Feature Line ~| B
[] Insert intermediate grade break points
Layer
© CToRO-FEAT [ ox [ cme |[ wep
(©) use eurrent layer
(©) Use selected entity layer
o Y- P Conversion options
@ Parcel ~ ~% Alignment - :F,‘ Intersec
- ) N ) [] Erase existing entities
J Feature Line ~| ™ Profile ~ &3 Asse{
Y L Assign elevations
W B €
j Create Feature Line [lieed poinid
|
= G\j Create Feature Lines from Objects ‘i [ oK ][ Cancel H Help I I

62. To provide freeboard, the feature line needs to be elevated two feet above the existing water
surface. Select the feature line. In the Ribbon, select “Edit Elevations” and pick the
“Raise/Lower” button. Raise the feature line by two (2.0’) feet.

UELISEEN I Feature Line

[ Add to Surface as Breakline T % f 2P AW S
1 +O +0 T N
L Apply Feature Line N e
: Edit GElA s Elevation Insert Elevation Delete Elevation i "J @ >
:tif [Elevations Apply Feature Line Styles Editor Point Point i{,
Modify | Edit Elevations

Specify elevation difference <1.000>: 2.0
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Floating Away: Connecting AutoCAD® Civil 3D®
with HEC-RAS for Floodplain Mapping

63. Move the last vertex on both ends of the feature line to a points that are approximately three
(3.0’) vertical above and outside of the floodplain limits.

64. Open the elevation editor Panorama. Pick the “Elevation from Surface” button and set the
elevation of the first and last point of the feature line equal to the existing ground “EG”.

x
113
q B0 QX @4 s@oo |[H3fBls B ®

Elevation Station Elevation Length Grade Ahi _Tj Elevations from Surface
Editor

2 p+00.00 661.450' 19.738'
0+10.74 661.355 114.002"
[& ] 1+3374 | 661288 | 75600 | -1.01% | 1.01% |

65. From the Home Tab of the Ribbon, select “Create Grading Group”. Name grading group
“ProposedFill” and check the “automatic surface creation” box. Grade the feature line
towards the centerline of the creek, with EG as the target at 4:1.

foi - =
& Parcel ~ =% Alignme \_‘ﬂ Parcel ~ ~: Alignmg

2J Feature Line ~ M Profile ~ eature Line ~ f Profile

(i Grading -] [ corridor [  Proposedtil (1] < Grading '] B corridol e %
NG j Deggription: \—‘—‘—/
3 (¥ Grading Creation Tools [t ot . - - - - - i}
= D 9 L b Grading Creation Tools [ h [ E B o
|
Val Lock
2 Create Grading Infill o 2Le o
i ? Create Grading Infill
_Faed . . Surface
N [ ﬁ) Create Grading Group [¥[Automatic surface creatiort i Cut/Fill Slope
[+7] use the Group Name [ ) >J Create ng Group Cut first &
Surface style: [
B Y - Format Slope &
& Contours 1' and 5' (Design) ~ |[%
Slope 4001 ]
Tessellation spacing: B Fill Slope Pr (down)
10.000" Format Slope 5]
Slope 2001 &
jlics=ltonianale: & Conflict Resolution
3.0000 (d) Interior Corner Overlap Use Average Slope a
["|volume base surface
Cut Slope Style: Fill Slope Style:
O G M & Cut Slope Display - EE Fill Slope Display - @ e
Group: ProposedFill Surface: EG
[ oK l [ Cancel ] [ Help ]




Floating Away: Connecting AutoCAD® Civil 3D®
with HEC-RAS for Floodplain Mapping

66. Draw a polyline connecting the ends of the slope fill grade. Add this as a feature line to the
“ProposedGrade” site with elevations assigned from the existing ground “EG”. Create a
“grading infill” between the newly created feature line and 4:1 slope grade.

(}’S Parcel - jgf Alignm:
J Feature Line ~ f Profile
Cf'} Grading ~ E Corrido
2O |_
| 5 Grading Creation Tool

1 ? Create Grading Infill
=
[ .c]) Create Grading Group

67. Paste the “Proposed Fill” surface into the existing ground “EG” to create a composite
surface that represents the proposed floodplain modifications. In the Prospector, find the
RiverCL alignment and drill down to the “Sections” of the RiverXS sample group. Make sure
the new composite surface is sampled / resampled.

6{} =723 Alignments
[ 4 =123 Centerline Alignments E|
Edit Surface || Water Drop B RiverCL
T M Profiles
: e o ile Vi
A_@ i line ¥l Profile Views
® Superelevation Views
4/ SMUuM SunEce =[] sample Line Groups
=3 Riverxs
I & Paste Surface @-'['3'] Sample Lines
=% Sectio
o (R EG
l] sectiof Refresh
LoD Mmee Ul inae

68. Export the “Post-Project” HEC-RAS model using the Civil 3D®. Repeat steps 16 thru 56 to
create a hydraulic model for the Post-Project HEC-RAS model.

= o

% Transfer Point =) E
E}(thr__'_ b ransrer Foints @ X
LandXMLY 7 Export to HEC RAS |

I Export
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668

Legend

666 WS 100yr - ProposedRecut
- .
WS 100yr - ExistRecut

i —
664 Ground - ProposedRecut

*
662 __..-‘ Bank Sta - ProposedRecut

Ground - ExistRecut

*
660 Bank Sta - ExistRecut

658

Elevation (ft)

656

654

652

650

Station (ft)

The goal: HEC-RAS comparison of Pre- vs. Post-project model reflecting our work in
AutoCAD® Civil 3D®

SUMMARY:

Running this tutorial to conclusion, you will have produced a Pre- and Post-project HEC-RAS hydraulic
model from LIDAR terrain data.

Surfaces for the (1) existing ground, (2) existing water surface, (3) composite surface with proposed grading
and (4) post-project water surface will allow you to leverage Civil 3D®’s tools to create profiles and cross
sections showing the impact the proposed grading has. Additionally, from these four surfaces you will be
able to calculate the proposed earthwork numbers and flood valley storage reduction.

Surfaces, alignments and sample line can be stylized to quickly produce FEMA compliant floodplain
workmaps.

Leveraging grading objects and/or cotridors allows for the quick iterations of proposed grading scenarios
allows the designer to find the optimum solution that minimizes costs and adverse flooding impacts.

**Visit the Autodesk University web site for class CI14043 to find the supporting files, custom programs and
VBA'’s utilized in this tutorial. Additional resources can be located at
http://sites.google.com/site/hecrasflipper
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