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Get Your Head Out of the Point Cloud:
Using AutoCAD® Civil 3D® for Large Surface

Datasets
Dana Breig Probert, Autodesk, Inc.

CV218-1L These days, we seem to be buried in data -- but how much data is too much? It's
often difficult enough to open our data files, let alone build a meaningful TIN surface from them.
We know we need to use high-tech field-collection information, such as LIDAR, Aerial
Topography, and GPS points, so let's figure out a way to use it with the software and computer
systems we currently have in our office.

About the Speaker:

Dana received her Bachelor of Science in Civil Engineering from Georgia Tech in 1998. Since then she has
worked on a variety of civil projects in the U.S. and Canada, using Land Desktop, Civil Design, Raster Design,
Map 3D and Civil 3D. In addition, Dana has helped many firms with their Civil 3D pilot projects and
implementation plans. Dana has been an instructor at Autodesk University for the past three years, worked
on Autodesk courseware projects, and is coauthor of the books, “Mastering AutoCAD Civil 3D 2008",
“Mastering AutoCAD Civil 3D 2009", and “Introducing Civil 3D 2009”. Dana maintains the Civil 3D Rocks blog
at www.civil3drocks.com.
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Get Your Head Out Of the (Point) Cloud!

We've all struggled with massive surfaces... You spend all day trying to import the data without
locking your machine. Once you finally succeed in getting the points into the drawing, you find
yourself crashing when you build the surface, or dealing with painfully slow regeneration times.

The goal of this class is to provide you with some plain and simple techniques for filtering
through the chaff and digging into the wheat to build a great surface. These ideas and
techniques may not be terribly flashy or high tech, but | find that they work for most large
surface applications such as large point files, LIDAR data and aerial topographic data. Many
techniques in this class can also be applied to other Civil 3D objects and applications.

Building Surfaces from Typical Large Datasets
Three extremely common large surface datasets are point files, LIDAR contours and aerial
topographic information.

Large point files might come from a state agency, internet site or perhaps from privately
contracted LIDAR work. These files are typically text files in the format of .txt or similar. The
points used in this presentation come from North Carolina Flood Mapping. There are lots of
publically available LIDAR point files. Try Google to search, or your state’s geospatial data
clearinghouse.

LIDAR contours are typically the export of some sort of LIDAR post processing software.
Instead of sharing the large point files, someone has converted the data into a terrain model and
exported the contours as polylines in an AutoCAD drawing. There are lots of publically available
LIDAR contour files. Try Google to search, or your state’s geospatial data clearinghouse.

Aerial Topographic Data is typically privately contracted. The aerial topography company will
often provide two drawings. The first drawing will contain contours, features and labeling. The
second drawing will contain points and breaklines. These companies can often provide you with
other formats upon request.
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Best Practices?

What is best practice for me could be completely wrong for you. Conventional wisdom on the
use of Civil 3D is constantly evolving. For me, I like to share information because it starts a
dialog and encourages others to share their approach. The techniques in this presentation are
intended to assist you in opening the Civil 3D bag of tricks and launch you on your own journey
to discovering your own Best Practices.

Much of work that is ongoing is documented on blogs and the Autodesk discussion groups, so
become a regular reader, and when you feel ready, a contributor.

The Truth About Hardware

If you are working with large surface datasets, it may seem like buying the most expensive
computer out there with the most muscle would be all you need for success.

The truth is that a lot of the limitations on large surface datasets are not hardware related, but
limitations from Civil 3D itself. There are, however, some hardware elements that can help.

A lot of people ask me for advice when spec’ing a new system. I'm not a hardware geek, so |
can't tell you what is best for you. But | can tell you what has worked for me and what | have
learned through asking questions and observing hundreds of workstations where Civil 3D is

installed.

Minimum Specifications

Yes. You need AT least the following (from the Autodesk website
http://usa.autodesk.com/adsk/serviet/index?sitelD=123112&id=8915326 ):

AutoCAD® Civil and AutoCAD® Civil 3D® 2009 Recommended System
Requirements

o Recommended configuration (excluding server components used with project
management capabilities):

o Intel® Pentium® 4 (3 GHz or higher); AMD Athlon™; multiple processors supported,
dual-core supported

e 32-bit only: Microsoft® Windows Vista® Ultimate/Business/Enterprise, Microsoft®
Windows XP (SP2)

¢ Note: Windows XP 64 and Windows Vista 64 are supported in 32-bit compatibility mode
only.

e 3GBRAM

o 5 GB free disk space for installation

e 1,280 x 1,024 display with true color, 1,600 x 1,200 or greater recommended (OpenGL®
accelerator with full OGL ICD support not required)

o Microsoft® Internet Explorer® 6.0 (SP1 or later)

e DVD drive
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J Note: All of the following refer to work with systems running Windows XP.

Because someone will ask...
My specifications on my office desktop machine:

HP xw4600 Workstation

Intel Core 2 DuoE6850

3.00 GHz

2.98 GB of RAM

NVIDIA Quadro FX 1700 (512 MB)

My specifications on the laptop used to give this presentation:

IBM lenovo T61p

Intel Core 2 Duo T7700

2.40 GHz

2.98 GB of RAM

NVIDIA Quadro FX 570M (512 MV)

Dual/Quad Core Processors

Civil 3D 2009 doesn't take full advantage of multicore processors. Multicore processors will help
with multitasking, such as keeping your stormwater software running while using Civil 3D.

Civil 3D is built on AutoCAD, and some AutoCAD functions, such as rendering, will take
advantage of the multiple cores. Also, you may see some improvement in regeneration,
zooming, and a few other operations if you adjust your WHIPTHREAD variable. Search Help for
more information on WHIPTHREAD.

Verdict: Yes on new machines, but don’t rush out to get one right now.

Video Cards

| noticed a real improvement when | upgraded to my current video cards, and | have heard the
same from many other users. Anecdotally, we all notice better real time panning and zooming,
more stability in 3D views and just fewer visual hiccups. Check out the Autodesk website for a
list of certified cards and read the Help file and online resources for proper tuning and
configuration (SDCONFIG).

J Before you upgrade you card, experiment with tuning your current card. Sometimes that is enough to
make a difference.

Verdict: Properly tuned, workstation class video cards make a difference. It is worth
replacing yours and buying the best you can afford on new machines.
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Ram

| personally noticed a difference in processing time when | added more ram to my desktop
machine. Be sure to read the article called “The 3 GB Switch and Civil 3D” which can be
obtained here: http://usa.autodesk.com/getdoc/id=TS1071001. The future of all software seems
to point towards more ram, so don’t skimp on new machines.

Verdict: Ram is cheap. Add more to your current system and be sure to leave lots of
room for expansion on new systems.

Civil 3D Limitations for Large Surfaces
Civil 3D 2009 has a much greater surface handling capacity than its predecessors, however |
still stand by this statement....

“Try to keep it under a million points per surface, and make sure they are a
meaningful million.”

-Dana Breig Probert, no warranty implied.



Get Your Head Out of the Point Cloud

Building Surfaces from Point Based Data

What are TIN points?

TIN points are data points or vertices used to build the surface. Every bit of data added to the
surface contributes points. For example, the location of a COGO point would be a TIN point, or
the vertices of a breakline. You can get a feel for TIN points by turning on points in your Surface
style display tab.

The “+” shapes represent TIN points at triangle vertices.

How do I know how many I have?

Right click on your surface (either in the drawing or in Prospector) and choose Surface
Properties. Expand under General and note Number of Points.

=i surface Properties - Surface2

Infarmation | Definition | Analysis | Statistics

Statistics Yalug

= General

= T gL i sl
Minirurm ¥ coordinate 235050,000"
Maximum ¥ coordinate 2596352,063'
Maximum ¥ coordinate 241241.130'
Minimurn elevation 311,895
Maximum elevation 426,365
Mean elevation 378.645"

Extended
TIN

What are quality TIN points?

Quality TIN points come from data that is only as detailed as necessary. Quality data is not
excessive, overly precise, overly accurate nor redundant. Read on...
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I Paid Good Money For These Points and I'm Gonna Use Every Stinkin’ One
of Them!

In Civil 3D, the surface game isn’'t so much “How do | use all of this data in Civil 3D?” as “What
is the minimum amount of data | can live with?” That can be hard to swallow if you've been sold
the promise of super duper precision.

Ask yourself:

What is the intended purpose of this plan?

What is the desired accuracy for vertical information?

What is the terrain like? Hilly? Flat?

If | had sent a crew out in the field, what kind of accuracy would | expect? How much
precision? Does this project require more or less?

PwnNpeE

Spend some time with your surveyor, your legal counsel, with industry guidebooks such as
those found in the References section at the end of this paper. Figure out exactly what you need
versus what would be nice.

Building Surfaces from Large Point Files

The example point file is a North Carolina Flood Mapping LIDAR .txt

e Bl Fomek U=m G download. The file is in NEZ format and is over 8 meg.
1962673.7900 847 460. 7000 555.3300
1962854 6400 347 471.5400 583.1200

1982797.2000,847504.0400577.2300  \When dealing with a file this large, DO NOT import the points as Civil
1962777 8700 847515.1800 579.2200

1eB2r58.4300847526 34005815000 3D cogo points. Importing this data as cogo points would make the
1962719.4700 ,847548.7700 ,585.3600 . . . . .
1ee2ron.0700 847559 22005208600 drawing size larger than necessary while not adding any additional
1962641.7300,547593.3300 595.5200 . . . . .

1962622 2300 847604 000 597 2100 quiality to the drawing. It is not likely that you will need to study any one
1962653.5500 ,847626.6000 ,593.6200 . . . .. .

1962564 1300 847637 7000 598 4300 POINE, you simply want to build a surface from this information.

AARIRAA 200 RATEAR Q20N BN 23NN

Experiment No. 1: Building a Surface from Large Point Files

Step Action Result

1 e Choose File>New. A new drawing is created from the

drawing template.
e Choose the wing P

__AutoCAD Civil 3D (Imperial) NCS
extended.dwt

e Press Open
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Step Action Result
2. Choose Surfaces > Create Surface A new, empty surface is created in
In the create Surface dialog: Prospector.
e Name the surface Existing
Ground Exercise 1
e Select the _No Display style
e Press OK
3. In Prospector: The Add Point File dialog will appear.
e Expand the surface definition
e Right-click in Point Files
e Choose Add...
4. Use the Format pull-down to choose The Northing-Easting-Elevation comma

NEZ (comma delimited).

= Add Point File

Farmat:

MEZ {camma delimited)

Autodesk Uploadable File

EMZ {comma delimited)

EMZ {space delimited)

External Project Point Database
MEZ {comma delimited)
MEZ {space delimited)
PEMNZ (camma delimited)
PEMNZ (space delimited)
PEMZD {comma delimited)

delimited format is selected. This matches
up with the format of the large point file
we will be choosing in the next step.
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Step Action Result
5. Press the blue “+” sign next to Source The Select Source File dialog will appear.
File(s):
6. In the Select Source File dialog, navigate | The Add Point File dialog will return.
to the Exercise 1 folder. T
e Change the Files of Type :
Selection to All files (*.%*)
X
e Select the NC LIDAR POINTS. txt =
file.
e Press Open.
[Epanini—
I™ Do coordinate transformation if possible
I™ Do coordinate data expansion if possible
[ o | came | Help
7. In the Add Point File dialog, uncheck all of | The points will be added to the surface
the advanced options. definition.
Advanced options The surface will bUIId, but since the _NO
B 5 clesmten aejustnen:(F posstsle Display style is current, you will not see it.
™ Do coordinate transformation if possible
™| b conrdinate data expansion if possile
Press OK.
8. Right-click on the surface name in The Surface Properties dialog will appear.

Prospector.

Choose Surface Properties.

10
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Step Action Result
9. Switch to the Statistics Tab of the Surface | Information regarding the number of
Properties dialog. points, triangles, and more are displayed
h .
e Expand all of the Options for on the screen
General, Extended and TIN. Make a note of how many points are part
of the TIN.
Make a note of how many triangles are
part of the TIN.
10. Switch to the Information Tab of the The surface will appear as contours and
Surface Properties dialog. triangles.
e Use the Surface Style drop-down
to choose Contours and
Triangles.
e Press OK.
e Zoom extents.
11. Choose File > Save As. The drawing will be saved.
e Name your drawing Experiment
1.dwg.
e Press Save.
12. Choose File > Drawing Properties Properties dialog will appear.

11
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Step Action Result
T
General |Summary| Statisticsl Eustoml
i
) . o
Da Exercize 1 Finizhed. dwg
Tupe: AutaCAD Drawing
Location: C:ADocuments and Settings\proberd\DesktophCy21
Size: 13.70MB (14,364,932 bytes)
M5-D0S name:  EXERCI™1.0WG
Created: Saturday, Movember 29, 2008 10:04:58 PM
Modified Saturday, Movember 29, 2008 10:14:33 PM
Acceszed: Saturday, Movember 29, 2008 10:14:33 PM
Aftributes: I™| Read anly I~ | Hidden
| &rchive I~ System
0K Cancel Help
13. Note the size of this drawing for future
comparison.

Experiment No. 2: Simply visualize your large surface with 3D DWF

Navigate to the Exercise 1
folder.

Press Save.

Press Yes in the View 3D DWF
dialog.

Step Action Result
1. Type 3DDWFPUBLISH in the command The Export 3D DWF dialog will appear.
line.
2. In the Export 3D DWF dialog: Autodesk Design Review will open.

Your surface will be visible in the Design
Review Window.

12
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Step

Action

Result

Use the 3D navigation tools, pan and
zoom to get familiar with the surface.

Experiment No. 3: Simplify Surface

Prospector.

Expand the Definition tree and choose
Simplify Surface.

Step Action Result
1. Continue working in Exercise 1 This drawing contains a surface that has
Finished.dwg been built from the NC LIDAR POINTS.TXT
shown as contours and triangles.
2. Select the Existing Ground Surface in The Simplify Surface dialog will appear.

13
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Step Action Result

3. In the Simplify Surface dialog, select Point | You’ve selected point removal as the
Removal then press Next. surface simplification method.

4. In the Region Options, choose Use The method will use the existing limits of
Existing Surface Border. Press Next. the surface, alternatively, you could
specify a different area, such as a smaller

H ’
et bt area that didn’t need to have as much
‘ ’Re — Specify the regions within the surface to apply the simplification. data .
Riegion Options
Reduction Options @ Lse existing surtace border
" Specify Window/Palygon:
Pick i Drawing... |
5. In the Reduction Options, use the slider 50% of the points will be removed from
to choose 50%. Press Apply. the surface.
Feduction Options
Total points gelected in region: 237841
¥ Peicentage of points to remove:
)' [
6. Save the drawing as Experiment 3.dwg.

Note the number of triangles, number of
points and drawing size in the laboratory
worksheet.

14
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Experiment 4: Creating a custom point format to weed large point files

Step

Action

Result

1.

e Choose File>New.
e Choose the

__AutoCAD Civil 3D (Imperial) NCS
extended.dwt

e Press Open

A new drawing is created from the
drawing template.

Choose Surfaces > Create Surface
In the create Surface dialog:

e Name the surface Existing
Ground

e Select the _No Display style
e Press OK

A new, empty surface is created in
Prospector.

In Prospector:
e Expand the surface definition
e Right-click in Point Files

e Choose Add...

The Add Point File dialog will appear.

15
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Step Action Result
4, In the Add Point File dialog, press the The Point File Formats dialog will appear.
Point File Format button.
5. In the Point File Formats dialog, make The Point File Format dialog will appear.
sure you have NEZ (comma delimited)
selected. Press Copy.
6. Name the new point file format WEEDED | The Point File Formats dialog returns.

NEZ (comma delimited)

Farmat name:
I WEEDED MNEZ {comma delimited)

Default file extension.: Comment Tag:

| bt =l

Then set the format to Sample every 5
Points.

I 1] pioinks
I -1 pioinks

™ Read no mare than

W Sample every

Press OK.

16
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Step Action Result
7. Press Close. The Add Point File dialog returns.
8. Use the Format pull-down to choose The newly created point file format will be
WEEDED NEZ (comma delimited). used for |m'p(.)r't|ng a point file into the
surface definition.
9. Press the blue “+” sign next to Source The Select Source File dialog will appear.
File(s):
10. In the Select Source File dialog, navigate | The Add Point File dialog will return.
to the Exercise 2 folder. =
e Change the Files of Type : -] @]
Se|ECtion to Allfiles (*- *) = S e e e \CY218- 1L Lab FilesiExercise 1\NC LIDAR POINTS, bt il
x|
e Select the NC LIDAR POINTS. txt ’
file.
e Press Open.
S
™| Do cocrdingte data expansion if possible
[T | carcel Help
2
11. In the Add Point File dialog, uncheck all of | The points will be added to the surface

the advanced options.

Advanced options

" Do elevation adjustment if possible
[™ Do coordinate transfarmation if possible

™| Do coordinate data expansion if possible

Press OK.

definition.

The surface will build, but since the _No
Display style is current, you will not see it.

17




Get Your Head Out of the Point Cloud

Step Action Result
12. Right-click on the surface name in The Surface Properties dialog will appear.
Prospector.
Choose Surface Properties.
13. Switch to the Statistics Tab of the Surface | Information regarding the number of
Properties dialog. points, triangles, and more are displayed
e Expand all of the Options for on the screen.
General, Extended and TIN. Make a note of how many points are part
of the TIN.
Make a note of how many triangles are
part of the TIN.
14. Switch to the Information Tab of the The surface will appear as contours and

Surface Properties dialog.

e Use the Surface Style drop-down
to choose Contours and
Triangles.

e Press OK.

e Zoom extents.

triangles.

18
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Step Action Result
15. Choose File > Save As. The drawing will be saved.
e Navigate to the class folder.
e Name your drawing Experiment
4. Finished.dwg.
e Press Save.
16. Choose File > Drawing Properties Properties dialog will appear.
x
General ISummalyl Statistics' Customl
i
Exercize 2 Finished.dwg
DWG
T yppe: AutoCAD Drawing
Location: C:ADocuments and SettingsiproberdsD esktophCy21
Size: 2 27MB [3,430,080 bytez)
MS-D0S5 name:  EXERCI2.DWG
Created: Saturday, Movember 29, 2008 10:43:37 P
Modified Saturday, Movember 29, 2008 10:44:10 Phd
Accessed: Saturday, Movember 29, 2008 10:44:10 Prd
Attributes: = Read orly = Hidden
¥ | frchive I™ System
QK. I Cancel Help
17. Note the size of this drawing for future
comparison.
.1

J  Points cannot be weeded by location using this method. For another approach to importing LIDAR
point files, check out this article by Chris Gountanis of ImaginIT. Note that | have not confirmed if
this method works in the 2009 version.
http://imaginit.rand.com/files/Workin%20with%20Lidar%20Data-White_Paper.pdf

19




Experiment 5: Using a Dataclip Boundary

Get Your Head Out of the Point Cloud

Step Action Result
1. Open Experiment 5.dwg The drawing contains a rectangle
highlighting an area of interest.
2. Create a new surface called Existing A new, blank surface is built.
Ground.
3. Expand the surface definition in The Add Boundaries dialog appears.
Prospector. x
Right Click on Boundaries and choose rfm
Add... Type:
IOutEr j
¥ Mon-destructive breakline
Mid-ordinate distance:
| 1000 ﬂl
OF I Cancel I Help J
¥
4, Name the boundary Area of Interest. The rectangle is defined as a dataclip
Choose the type Data Clip. El:)l:gg:ry for any new data added to the

20
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Step Action Result
7
Name:
| Area of Interest
Type:
[ata cip |
I~ fon-destructive breakine
Mid-ordinate distance:
[ 1.ooor ﬁl
[l I Cancel | Help |
W
Press OK.
Select the rectangle, then press enter.

5. Follow the steps from Experiment 1 to The surface builds, but only inside the
add the NC LIDAR point file to the dataclip boundary.
surface.

6. Save the drawing, and note the size.

J Adata clip boundary must be added to the surface definition first because it clips incoming data. If

you decide to add a data clip boundary later, go into the Surface Properties and move the boundary
operation to the top of the build order.

21




Get Your Head Out of the Point Cloud

Try Pasting Surfaces of Different Detail

There are times when you will need the most detailed data possible around a certain portion of
you surface, but the balance of the area might not be as critical.

For example, let's say we were doing a road rehabilitation project on the road located on the
eastern limit of the terrain model, as shown circled in red below.

While we need topographic information for the rest of the surrounding area, our interest is
mostly on a large scale- such as determining watershed trends.

One way you could consider approaching this would be to create two different surfaces, then
paste them together to form a composite. When pasting two surfaces, the triangles from the first
surface remain intact. It is critical that your more detailed surface is the first surface in the
pasting “stack”.

1. Build a surface with the densest data in your area of concern. Use a data clip
boundary.

2. Build another surface for the entire site from a weeded point format (or some
other reduction technique)

3. Make a new, empty surface. Call this surface Composite Existing Ground.

4. Paste the detailed surface into the new surface. Allow the surface to build.

5. Paste the overview surface into the new surface.

Depending on the size and scope of the surfaces you are working with, it might be best to

make one or both of the surfaces in their own drawing, creating data shortcuts to get the
composite into your design drawings.

22
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Building Surfaces from LIDAR or other Aerial Contours
LIDAR contours are often publically available.

An example of LIDAR contours.

Contours are probably the least desirable type of data for surface creation. By definition,
contours are the end product of a terrain model, not the raw materials. However, there are some
times where the only data you have is contour data. When contours are your only option, follow
the procedure below to create a surface.

Experiment 6: Using a Map Query to pull in a portion of the contour data

Select the Contour.

Step Action Result
1 e Choose File>Open. A drawing is opened that contains
. . contours from aerial LiDAR.
e Navigate to the Experiment 6
Contours.dwg The contours are polylines drawn at 5ft
intervals.
e Press Open
2. Zoom in on one of the “contours”. The vertices for the contour will light up.

Notice how close they are.

23
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Step Action Result
3. Right-click on the contour and choose Note that these “contours” are really 2D
Properties. polylines with an elevation assigned.
po| e =
. 18 v mk
Layer C-TOPO-MINR
Linetype Bylayer —
Linetype scale 1,0000
Plot style By Color E
Lineweight BylLayer é
Hyperlink %
Thickness 0,0000 °
30 izati = -
| Material ByLayer
| Geometry & [
Vertex 1 &
Verkex % 846204.0290 e
Verkex ¥ 1969999,2514
Start seqment width 0.0000 (ol
End segment width 0.0000
Global width 0.0000 o
Elevation 545.0000 z
Area 10610335.6173 2
Length 30381.9830
|Misc & —
| Closed Mo 8
| Lnetype generatian Enabled 8
4, Choose File> Drawing Properties. The Properties dialog appears. Note the
size of the drawing that contains only the
polylines at elevation.
5. Close the drawing It would be difficult to work with a surface
created from a source data of this size.
6. Open the Experiment 6 Query.dwg. A drawing opens containing a rectangle.

This rectangle represents an area of
interest for surface building.

24
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Step Action Result
7. Type mapwspace in the command line. The Map Task Pane will appear.
Press enter to select <On>
8. Switch to the Map Explorer tab of the
Map Task Pane.
9. Right-click on Drawings. The Select Drawings to Attach dialog will

Select Attach...

appear.

25
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Step Action Result
10. Navigate to the folder that contains the The Experiment 6 Contour.dwg will appear
Experiment 6 Contour. dwg. under drawings as attached.
Select the Exercise 3 Contour.dwg
Press Add.
Press OK.
11. = @) Current Drawing [Draving2. dwg] The Define Query of Attached Drawing(s)
=[5 Drawings dialog will appear.
P CDOCUMENTS AMD SETTINGS|PROBER)
EIE Query Library
@ CuUrrent ety
EIE Object Classe
¢ +[2] Undefines  Execute as Preview
E Data Sources  Execute as Defined
|3 Topologies Clear
“-[3 Link Template
Help
12. Press Location. The Location Condition dialog will appear.
13. Select Polyline. The Define Query dialog will return with

Press Define.

Select the rectangle in the drawing.

Press OK.

the location information.

Define Query of Attached Drawing{s)

— Current Query
Location: CROSSING POLYLINE POLYGOM

A 3|

- Query Type Guery Mode Options———————
& And Locatian,.. | ’76’ Preview ’7|_

Alter Prog

26
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Step Action Result

Contours appear in the drawing, but only
the ones that cross the rectangle area of

interest.

14. Select Draw.

Press Execute Query.

...from attached drawing... will be treated

-
15. = Q Current Drawing [DrawingZ2, dwg] EL
=R Drawings (=]
B{Q C\DOCUMENTS AMD SFTTIMNGSIPRORFRIANFSKTOR (42 as newly created.
D ey R
@ Current Query Activate
[=! E Obiject Classes Deactivate

2] Undefined Classes

=B Data Sources Qe v

Zoaorm Exkents
Track Drawing's Coordinates

Help

[ ) S

16. Save drawing. Note size.

J Map queries are a great way to bring forward only the “good stuff” and leave behind the junk. For
example, if you only wanted the polylines from a drawing. This is especially important with large files

that may not be easy to open and are often impossible to “block in”.

27
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Experiment 7: Creating surface from polyline contours

Step

Action

Result

1.

e Choose File>Open.

e Choose the Experiment 7
Contours.dwg

e Press Open

Or continue working in the drawing from
the previous exercise.

A drawing is opened that contains
contours from aerial LiDAR.

The contours are polylines drawn at 5ft
intervals.

Freeze the C-TINN-BNDY layer so that you
don’t confuse it with a contour later on in
the exercise.

Choose Surfaces > Create Surface
In the create Surface dialog:

e Name the surface Existing
Ground

e Select the Contours 5’ and 25’
(Design) style

e Press OK

A new, empty surface is created in
Prospector.

Expand the surface definition and locate
the Contours entry.

Right-click on Contours and Choose Add...

The Add Contour Data dialog will appear.

28
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Step Action Result
T
Description:
|
—Weeding Factors
Distance: Angle:
| 15,000 ﬁl | 40000 (d) EI
—Supplementing Factors
Diskance: Mid-ordinate distance:
| 100,000 ﬁl | 1.000 ﬂl
—Minimize flat areas by
¥ Filing gaps in conkaur data
[~ Swapping edges
IV adding points to flat triangle edges
v adding points to flat edges
(a4 I Cancel | Help |
5. In the Description field, type LiDAR A description is added that will help you
contours. remember which batch of contours you
added. You may also like to include a date,
or other identifier.
6. In the Add Contour Data dialog, uncheck | The dialog will close and the command line
all of the Minimize flat areas by options, will prompt you to Select Contours.
so that we can see what happens before
we use these options.
—Minimize flat areas by:
[ Filling gaps in conkour data
[~ Swapping edges
[™ adding points ko Flat triangle edges
™ adding points ko Flat edges
Press OK.
7. At the Select Contours prompt, make a The surface will build. This may take a few

crossing window to choose all of the
contours.

Press enter.

moments.

The surface should appear as orange and
green contours over the original grey
source data.
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Step

Action

Result

You may also get crossing breakline errors
in Panorama.

Zoom in on the surface and note that
surface contours don’t match the source

data very well.
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Step

Action

Result

Thaw the C-TINN-BDNY layer to get back

the rectangle around the area of interest.

10.

Expand the surface definition.

Right-click on Boundaries and choose
Add...

Add the rectangle as an outer boundary.
S|

Mame:

I Area of Inkerest

Type:
IOutar j

[+ Mon-destructive breakline

Mid-ordinate distance:

[ 1.000 ﬂl
0K I Cancel | Help |

v

The rectangle is added as an outer
boundary to the surface.

11.

Freeze C-TOPO-MAIJR and C-TOPO-MNR

The source data is frozen so that you can

focus on the surface at hand.
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Step Action Result
12. Change the surface to look like TIN to get
a feel for triangle density.
13. Use the surface properties to examine Make a note of this information in the

the number of points and triangles.

table.
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Step

Action

Result

14.

Save the drawing. Make a note of the
drawing size.

15.

Expand the Surface Defintion.

Right-click on Edits...

Choose Minimize Flat Areas.

Check all of the boxes, press OK.

x

Minimize Flat areas by:

¥ Filing gaps in conkowr data
W Swapping edges
¥ adding points to Flat triangle edges

¥ Adding points to flat edges

Ok I Cancel | Help I

The surface will do a routine to
supplement extra points to minimize flat
areas.

16.

Zoom in on the surface and notice that
the contours are a much better fit.

17.

Change the surface style to contours and
triangles to get a feel for the triangle
density.
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Step

Action

Result

18.

Save the drawing, make a note of the
points, triangles and drawing size.

Depending on your project needs, you may be able to greatly reduce the size of your surface
and your drawing without sacrificing accuracy. LIDAR contours are often present as polylines
with many closely spaced vertices. These closely spaced vertices often do not provide any
additional meaningful data and can be weeded resulting in a more manageable surface.
Investigate Map Cleanup tools to simplify polyline contours before using them for surface

creation.
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Building Surfaces from Aerial Topographic Data

Many firms will have a site “flown” by an aerial topography company in lieu of sending a crew
out in the field. Typically, the aerial company will provide you with two .dwgs. The first contains
features and the second contains DTM data.

When hiring an aerial topography company, be sure to ask what formats are available for the
final data. Many firms are capable of providing data formats such as LandXML, DEM or a .TIN
file that might be more useful to you than the traditional .dwg information.

The Features or Topography Drawing

The features drawing usually contains contours at elevation, blocks representing trees, linework
for roads, houses, tree lines and other notable features which are also often at elevation. This
drawing is typically VERY large. Many engineering firms use this drawing to create their surface.

If you have a choice- DO NOT USE THIS DRAWING TO CREATE YOUR SURFACE.

N

A close look at an example features drawing
Entire drawing covers 2400 acres, drawing file size 130 megabytes.
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The DTM (Digital Terrain Model) Drawing

The DTM drawing typically contains AutoCAD points at elevation, and polylines (either 3D or
2D) at elevation. This drawing will have a file size that is 50-75% smaller than the features
drawing. Many engineering offices overlook this data for surface creation.

J Chances are good that you receive this drawing from your aerial topo company whether you realize it
or not. Many firms have sworn up and down that they don’t get a DTM drawing. When | make them
dig out the original CD from the aerial company, we find the drawing on the CD. Usually, someone
opened a DTM drawing once and didn’t know what to do with it. From that point forward, the topo
drawing was dumped on the network and the DTM drawing forgotten. If you check the CD and you
aren’t getting the DTM drawing from your aerial topo company, give them a call and ask for it.

If you have a choice- DO USE THIS DRAWING TO CREATE YOUR SURFACE.

A close look at the DTM drawing for the same project.
Entire drawing covers 2400 acres, drawing file size 28.8 megabytes.

Jif you cannot see your AutoCAD points, change PDMODE to 2 and adjust PDSIZE.

Procedure: Creating a Surface from Aerial Breaklines and Mass Points

1.
2.
3.

Create a new drawing from your Civil 3D template.

Surfaces>Create New Surface

In the Create Surface dialog, give your surface a name and select an initial style
(probably a “no visibility” style for reasons discussed earlier in this paper.)

In Prospector, expand your surface definition and right-click on Breaklines. Choose
Add...

In the Add Breaklines dialog, provide a description for your breaklines. Choose Type:
Standard. Press OK.
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6. The Command Line will ask you to Select Objects. Go into the drawing and make a large
crossing window that includes all of your polylines, then right click to exit the command.

J Itis OK if this crossing window includes those AutoCAD point objects. Civil 3D will filter those out
since it is seeking polylines in this case. However, be sure that you do not have any other polylines
visible in the drawing (such as the topographic linework) because zero elevation polylines will add a
zero elevation to your surface data.

7. Your surface will build. Depending on the size of your drawing and your individual
machine specifications, this could take several minutes.

8. In Prospector, expand your surface definition and right-click on Drawing Objects.
Choose Add...

9. Choose Object Type: Points. Provide a meaningful description. Press OK.

10. The Command Line will ask you to Select Objects. Go into the drawing and make a large
crossing window that includes all of your points, then right click to exit the command.

J  Itis OK if the window includes those polylines or even the Surface you may already see. Civil 3D will
filter those out since it is seeking points.

11. Your surface will build. Depending on the size of your drawing and your individual
machine specifications, this could take several minutes.

Should | Erase the Linework That Created the Surface?

By default, surfaces are dependent upon the objects that created them. For example, if a
surface was created from polyline objects and those polylines were erased, the surface would
disappear upon rebuild.
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You can change this setting using the following procedure:

Procedure: Change the Copy Dependant Objects Setting
1. Select your surface in Prospector, right click and choose Properties.
2. Inthe Surface Properties dialog, switch to the definition tab.
3. On the Definition tab, note under Build that the Copy Deleted Dependant Objects field
says YES. This setting makes a “copy” of the linework and absorbs it into the surface

definition itself.

Information | Definition | Analysis | Statistics

Definition Options Yalue
= Build

Copy deleted dependent objects
Exclude elevations less than
Elewvation <

Exclude elevations greater than Mo
Elewation =

Use maxirnum triangle length o
TMaximum triangle length

e ek rmsienibes b alelimns b ok d e

Since the DTM drawing can be very large before a surface is even built, it is tempting to erase
those breaklines and mass points in an attempt to reduce file size.

I haven’t found much drawing performance improvement in erasing this linework, but it might be
worth experimenting.

J A Surface Snapshot can also be used to “freeze” the surface definition.

What About the Features?

Legally speaking, you probably have to show the aerial topography company’s contours exactly.
The only way to ensure this is to use that features drawing as an underlay through some kind of
XREF. Since the features drawing can be quite large, you will need to find some other way to
show this information. Here are two ideas:

1. Thoroughly weed, clean, flatten, purge and audit the features drawing, then attach to
sheet drawings as an overlay XREF. If the drawing is simply too large to handle, use Map
Queries to break it into logical chunks before XREFing.

2. Convert features drawing into DWF and attach through the XREF manager.
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Ideas for Drawing and Data Organization
Your drawings should be organized to take advantage of the strengths of the software.

Only keep surfaces you need in a drawing.

Keep individual surfaces to less than a million points where possible.

Label only where necessary.

Stylize only where necessary.

Avoid XREFing drawings containing surfaces, especially styled or labeled surfaces.
Use data references and style application instead of XREF and layer control to share
surface information between drawings.

ouhkwnNneE

J Civil 3D labels are regenerated every time you change views or switch layout tabs. This includes
when the labels are XREF'ed into another drawing. The higgest performance problems | have
encountered in Civil 3D 2008 are related to label regeneration.

Keeping the previous three items in mind, you might consider having three types of drawings:
Warehouse Drawings, Surface Only Drawings and Design Drawings.

Warehouse Drawings

The Warehouse drawing will keep the original data or linework for the entire site, such as the
data from the LIDAR contours or aerial topography drawing. Keep this data in a safe place, and
consider making it read only. Later in the paper we will talk about weeding data. You might want
to make a “weeded” warehouse drawing at some point.

Drawing template: Make a plain template with no styles.

In your warehouse drawing, you might decide where logical breaks would be for smaller surface
creation, perhaps marking with rectangles.

J Investigate the Map Books tool in AutoCAD Map and/or the Plan Production tool in Civil 3D to
possibly assist in semi-automatic sheet creation based on your phases.

Surface Only Drawings

Surface Only drawings will house individual “tile” surfaces. Using Map Tools, raw data is queried
for the appropriate location. After checking your TIN, apply a no-visibility style to your surface
and avoid labeling. You can leave the attachment for future queries or break the connection.
Experiment with erasing the AutoCAD entities, snapshots and build operations to find a drawing
size that works best. Consider querying small chunks for use in detailed phase design, and
larger chunks that are then weeded for a bigger surface that is a lower resolution.

Drawing template: Make a simple template that includes no object styles except a no-visibility
surface style and a triangle only style.
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Design Drawings

Data Reference (through data shortcuts or Vault) only the surfaces that are necessary in that
drawing for design, daylighting, profile work, etc. Label only as necessary. Maintain as few
layouts with as few viewports as possible and use data references and styles to control visibility
rather than xrefs and layer control. Avoid xrefing drawings with surfaces, or any other civil 3d
objects that are heavily labeled.

Drawing template: Use your company standard design template.

Planning Your Large Surface Strategy

Before you start creating drawings and importing data willy-nilly, sit down and make a plan.
Take pencil to paper and sketch out a drawing and data organization plan that gives you what
you need. Maybe print out an overall plan of your site and make some notes while you work
through these questions:

1. Will the project be done in phases?

2. Arethere phases of the project that require more detail?

3. Are there areas of the project that are being shown for “trend” or “background”
information only that may not be critical to the design?

4. Would higher resolution surfaces be required for fine design, such as parking lots, where
lower resolution surfaces suffice for other tasks, such as preliminary watershed studies?

5. How many surface drawings will | need, and what will | build in each one?

Road Design area needs more detail

Open space and

s
A W adjacent lands need

less detail.

Phase |

Phase Il
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A Large Drawing Is NOT a Badge Of Honor

Before you even consider building a surface in your drawing, take a look around and make sure
your drawing is big for good reason.

Common Culprits:

1. Unpurged 3D blocks or “blocked in” drawings
2. Unpurged *UXX blocks from exploding Civil 3D objects

3. Remnants such as land desktop polyface meshes, linework at elevation, things that
don’t have to be in this drawing
4. Excessive layouts or viewports
5. Drawing errors
Don’t get me wrong... I've had 2 meg drawings that behaved like dogs and 20 meg drawings
with large corridors and surfaces that behaved really well.

What is a big drawing? While every drawing must be examined individually, | use the following
sizes as my “red flag” for further investigation:

Civil 3D drawing template: 1 Meg

Simple drawing containing only 2D linework: 1 Meg

Drawing for approximately 100 lot site containing alignments, parcels, corridor, and

surfaces: 12-15 Meg

Large Surface Drawing: 15-20 Meg
If you start from a clean drawing but notice your drawing size getting large or performance
beginning to lag, try cleaning it out first, then apply data organization techniques discussed
below.
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Techniques To Practice For Large Surface Data Preparation

Don’t Use..

linstead Learn...

Import Points

Adding Points directly to surface; applying weeding to point
files

Object Viewer

View>3D Views; 3DDWFPUBISH

Converting AutoCAD Points to Civil 3D
Points

Add AutoCAD Points directly to surface

QSELECT, Select Similar, other selection
tools

IMap Query for location and property

Insert another drawing as a block, or
copyclip

[Map Query

IMap Trim, EXTRIM

Map Query for location

Flatten, or properties change

IMap Query with Alter Properties

IAdding every bit of data just because it is
there

Choosing the important and meaningful data
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Resources

Books
American Society of Civil Engineers. Topographic Surveying. 2000.

Robert C. Steele. Modern Topographic Drawing. 1980.

Online Materials

Best Practices for Working with Large Data Sets White Paper from Autodesk
http://images.autodesk.com/adsk/files/large data best practice.pdf

Working with LIDAR data in Civil 3D from Chris Gountanis of Imaginit

http://imaginit.rand.com/files/Workin%20with%20Lidar%20Data-White Paper.pdf

Manage Surfaces by Mike Choquette of Imaginit

http://aec.cadalyst.com/aec/Column:+CAD+Clinic/Manage-Surfaces-Part-1-CAD-Clinic-Civil-3D-
Tutoria/ArticleStandard/Article/detail/470059

Blog Resources for Using Map Tools and Dealing with Large Surfaces:
www.civil3d.com

Map 3D and Murph’s Law at http://map3d.wordpress.com/

Take the Edge off Civil 3D at http://edgeofwedge.com/civil.php
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Lab Worksheet

Use the tables below to keep track of our progress in class today.

Point Based Data

Exp. 1- External

Exp. 3- Simplfiy

Exp. 4- Weeded

Exp. 5.-DataClip

Contour Based Data

Experiment 6 -1: Size of Raw Contour File

Experiment 6-2: Size of Queried Contour File

Exp. 7-1

Exp. 7-2
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Check Your Head
Multiple Choice:

Which TIN was most likely made with point based data?

True/False:

Civil 3D object display (such as surface contours) and Civil 3D labels (such as spot elevations)
regenerate and recalculate when changing drawing views.

Short Answer:

If you were given an 8 meg text file of points and needed a surface, what would you do?

What is your biggest issue with surface data today?

Answer after class only- what is your new strategy for tackling that issue?

Your Name

O | promise to go fill out a class evaluation and give honest feedback.
Pinky promise!
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