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 IDEAS FOR SPEEDING UP AUTOCAD (collected from various NG’s, personal experience, 

etc.)  cojonez 5-18-10 

 First things first, if you start having trouble, close AutoCAD, reboot your 

computer, restart AutoCAD and then see if that made a difference. 

 DRAWINGS: 

1 Is the slowdown in all files or just one?  Start a new drawing by typing .new and see if the resulting 

file is ok or not.  If ok then the existing file is the problem. Run Recover on that file to see if that 

helps, see other tips further down. 

2 Once a slow drawing is up check to see what fonts are being used or called.  If you don't have one 

on your system substitute in STYLE for an AutoCAD shx font.  Do this for other font names you 

don't recognize to see if the helps speed up the drawing. Change all TTF fonts to SHX to see what 

difference it might make. 

3 Does the drawing contain XREF files?  Close the current drawing, open 

each XREF file and audit and purge each one.  Then go back to your 

drawing.  In 2010 you can use the RECOVERALL command to also include 

XREFs. 

4 Check in layer manager to make sure you don't have 100's of layer filters, if so delete them. 

5 Check the scale list to make sure you don't have 100's of scale lists. 

2009 and higher does this for you automatically, 2008 use scalelistedit, reset. 

Use Scale List Cleanup Utility 

6 Groups can cause problems, see link at bottom of page. 

7 Change ALL text styles to use simplex.shx font as a test, but jot down what font is used with each 

style.  Try QTEXT on as well to test speed.  If one of these helps then you have narrowed down the 

problem to a text font.  Add them back one at a time to find the trouble one. 

8 Don't use true type fonts (TTF) and see if that helps, lots of those 

will slow things down. If using TTF, turn hardware acceleration off. 

9 Set Shademode to 2D, do this in each layout, each viewport, and in Model Space. 

10 Use -purge, Regapps, purge all.  In 2010 and higher also use –purge, z, and –purge, e. 

11 Large file size 

http://usa.autodesk.com/adsk/servlet/ps/item?siteID=123112&id=2886521&linkID=9240617 

Ideas for removing blank text, points in a drawing, anonymous groups 

 HARDDRIVE CLUTTER: 

20 Clean out the temp folder (%temp%)on your computer, this can have a big impact if it is filled with 

hundreds or thousands of files.  Remove all the temp internet files and cookies on your computer.  

I recently helped clean up a computer and it had 5,000 cookies on it. 

21 Finally run the diskfrag program, even the one that comes with Windows works well enough. 

 CPU or RAM OVERLOAD: 

30 What other programs are running?  I have Inventor and Mech 2009.  If I run Inventor and then 

AutoCAD, AutoCAD will be very slow and "jerky".  Rebooting and only running one or the other 

makes a big difference.  So after a reboot only open AutoCAD and see if it runs better.  Add other 

programs one at a time and watch for a difference. 

 AUTOCAD SOFTWARE - VARIOUS SETTINGS: 

40 Install AutoCAD certified video drivers 

41 2011 – HPQUICKPREVIEW set to 0 (Hatch Pattern Quick Preview) 

2011 – HPDLGMODE set to 0 

42 2011 with dual monitors – turn hardware acceleration off, there is an icon toggle to the lower 
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right of the screen, it looks like a computer chip with a lightbulb. 

43 “Stickiness” in 2011, try turning Selection Cycling off.  You do this by toggling the SC button at the 

bottom center of the screen.  If you are using Icons instead of text it should be the one to the left 

of the paper/model toggle button.  This is a great feature, just toggle it on when needed. 

44 Do you have another version of AutoCAD installed?  If so you must go through the File path 

statement in that version as well.  And are you using the same profile?  Start AutoCAD with a new 

profile (copy the shortcut on the desktop, Shortcut tab, in the Target line after the first statement 

in quotes you may have a /p profile_name, over write that if it is there with /p newprofile (pick 

any name that doesn't already exist in your profile folder), and if you don't have a /p profile_name 

then simply add the /p newprofile to that line. Pick ok, then double click on the icon, AutoCAD will 

start with the new clean profile, open a drawing and see if you have the same trouble. If not then 

you have a problem in your regular profile, usually a path statement that is not correct. Go 

through the entire Options, Files, path statements to verify each and every path. 

45 If you don't need draworder then set draworderctl to 0. 

46 Turn DYNamic input off as a test, see DYN toggle at bottom center of screen. 

47 Set SAVEFIDELITY to 0 unless you are saving down to lower version numbers. 

48 3D – use BREP command to remove the history from selected solids.  Read help to understand the 

impact to doing this. 

49 Properties causes slower operating speed and some have recommended setting qpmode to 0 

(off). 

Run with Properties turned off as well as QProperties off as a test. 

50 Go to File>Open>History, are there hundreds or thousands of files listed?  Delete most of those 

short cuts keeping only the last 20 or so. 

51 Make sure all the printers listed in the plot dialog actually exist. 

This goes for printers as well as printer.pc3 files. 

52 Create a file of 0 bytes in size, called acad.dll and place it in the 

same location as acad.exe if one doesn't already exist. 

53 Options> Open and Save > Turn off display digital signature information. 

54 Go through the file paths in Options>Files and make sure every single path listed actually exists, 

be meticulous.  Unplug the network cable and see if the problem goes away.  If so, you may need 

to get a copy of FILEMON from the net and use that to find out what AutoCAD is trying to do.  See 

below for a link with a great explanation on how to use FILEMON.EXE. 

55 Change the cursorsize from 100 to 10 or 7. 

56 http://usa.autodesk.com/adsk/servlet/ps/item?siteID=123112&id=2884947&linkID=9240617 

The support file search path is stored in the Windows registry as a text string, with each path 

separated by a semicolon (;). This registry entry for support paths is also shared by the Windows 

operating system. The problem occurs if the combined support path is very long (over 800 

characters). 

To avoid this problem, restrict the support file search path to paths that are required by the 

software. To check the length of the support file search path for the Autodesk software, enter the 

following AutoLISP® expression on the command line: 

(strlen (getenv "ACAD")) 

To resolve the problem, shorten either path, and then close and reopen the program.  

The above will also be related to commands not being recognized. 

57 Dock the command line in the lower or upper portion of the autocad screen, do not have it 
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floating.  If the command line is not showing it can still have an impact if it was floating prior to 

being made invisible.  Hit Ctrl+9 to bring it back, if it is floating then dock it at the bottom of the 

AutoCAD screen, then hit Ctrl+9 again. 

58 "In AutoCAD 2009 and higher, enable the AutoCAD Classic workspace. 

Dock any desktop element and make sure that none of the palettes are floating. 

Turn off any unused palettes. 

Update the graphics driver." 

59 Turn transparency off on tool palettes.  Hover over a palette and right click, pick transparency,... 

60 Use Cleanscreen (CTRL+0 toggles it off and on) to remove all palettes, 

etc. and see if it makes a difference. 

61 Close the new layer manager in 2009 and higher.  Use LAYERDLGMODE set to 0. 

62 TREEDEPTH at -2520 and SORTENTS at 20, or turn SORTENTS to 0 if a 

large file and using draworder. 

63 Manual Tune video driver - Options, System, Performance Settings, Manual Tune, Driver Name 

pulldown.  Which one is showing?  For vista Direct3D might be better. For XP pick the driver for 

your card, mine is from nVidia so I have nvd3d9.hdi picked.  Pick the Enable hardware acceleration 

to see if that helps.  Further down move the sliders over to the left. 

64 Video Driver updates - check for newer drivers for your card. 

65 Viewres still affects the speed of the computer, contrary to what you may have been told.  

Autodesk has confirmed this to me personally, especially so with MEP.  Set it to 500 instead of the 

maximum setting. Set cursor size to 10 or less. 

66 Set ltscale to the proper value, a large drawing with linetypes will slow down when in MS with 

ltscale set to 1 or a small value. 

67 Too many fonts - remove fonts that you don't actually use, this will 

speed up AutoCAD and the OS. 

68 2011 – Plotting with transparency will slow down the plot process, if you don’t need it to plot with 

transparency then uncheck that In the plot dialog box. 

69 2009 and higher - Have fewer recently used files in the Application Menu (the Big A), Options, 

Open and Save, Application Menu, set to 15 or less, at least as a test. 

 OS SETTINGS: 

80 Use disk cleanup tool.  XP > Start > Accessories > System > disk cleanup.  At a minimum navigate to 

%temp% and delete all the temp files. 

81 Use defrag tool.  XP > Start > Accessories > System > defrag.  Better yet buy a good one, Windows 

defrag is not the best. 

82 Change display settings to “optimize for performance” 

83 Uninstall windows search.  Turn off indexing. 

84 Disable all items not needed, see msconfig 

85 Does your computer have Blue tooth?  A user reported a blue tooth phone placed near the 

computer slowed the computer to a crawl, they moved the phone away and it sped back up. 

86 Set the virtual memory paging file to a larger size with a min and max rather than letting windose 

handle it for you.  XP - Control Panel, System Properties, Advanced, Performance Settings, 

Advanced, Virtual Memory Change, Custom Size, Initial size = 3X ram (3GB ram = 9GB paging file 

size), maximum size = 4X ram. Go larger if you have the hard drive space. 

87 In the same area as immediately listed above, instead of Advanced tab pick Visual Effects tab, pick 

adjust for best performance, then if you must go to custom and pick the few settings you can't do 

without. 

88 Lower hardware acceleration setting, in Control panel, Display, settings, advanced, troubleshoot, 
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move the hardware acceleration slider to the left one click and try it out, keep moving it right and 

watching for a change in performance and also fewer crashes. Find a setting you can live with. 

 ANTIVIRUS SOFTWARE: 

100 Antivirus software - disable and see if there is a difference in performance. 

 If the antivirus software allows you to, set AutoCAD to be ignored. 

 NETWORK: 

110 What network software is being used?, there have been problems reported with some Novell 

server systems, as well as others.  If posting in the new groups be sure to mention the server 

software. 

120 Check the network card speed, is it 10/100 or a 1000?  If your network is 1GB then a 1GB card will 

speed things up. 

 OTHER IDEAS: 

130 Go to autodesk.com web site, pick Services and Support, use the Knowledge Base and search on 

"slow", "delay", etc. 

131 filemon.exe how to use it to find where autocad is freezing http://cadpanacea.com/node/71 

132 Disable digital signatures 

1-On your desktop, right-click on any Autodesk Icon (i.e.: AutoCAD) and pick "Enable/Disable 

Digital Signature Icon".  

2-In the "Signature Validation Options" dialogue box, uncheck "Display digital signatures and 

display special icons".  

3-Restart your computer.  

Full details at this link.  

http://themadcadder.blogs.com/my_weblog/2005/01/diable_the_digi.html 

133 Get rid of blank text 

http://lynn.blogs.com/lynn_allens_blog/2007/09/an-almost-autum.html 

In 2010 use –purge, e 

134 Clean empty groups and unnamed groups out of drawing. 

http://forums.augi.com/showthread.php?t=50895 

135 Various tips from an AutoCAD expert. 

http://blog.jtbworld.com/2008/09/autocad-2009-slow-performance-tips.html 

136 Disable the communication center.  From Tony Tanzillo 

In AutoCAD 2010, you can disable the InfoCenter toolbar by opening the  
registry, and going to the following key: 
HKEY_CURRENT_USER\Software\Autodesk\AutoCAD\R18.0\ACAD-8001:409\InfoCenter 
In that key there's a value with the name "InfoCenterOn". 
Changing that value from 1 to 0 will disable the InfoCenter toolbar. 
(This will have minimal impact to the start-up time of AutoCAD, but every little bit helps.) 

137 Use regedit to open this key: 

HKEY_CURRENT_USER\Software\Autodesk\AutoCAD\R18.0\ACAD-8001:409\Recent FileList 

Make note of how many files in the list are at remote locations that are offline. 

If you find a lot of them, that's probably the issue.  

from Tony Tanzillo, Autodesk.com NG’s 

  

 


