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Installation and Setup

Minimum system requirements
Since Autodesk SketchBook Pro runs on Mac and Windows platforms and with
Tablet PCs, there are different minimum system requirements, installation, and
setup instructions supplied for each.

For this version of Autodesk SketchBook Pro, we added a 15 non-consecutive
day trial version of SketchBook Pro, with a new banner image for each day it is
used.

To ensure Autodesk SketchBook Pro runs to its potential, please ensure that
your hardware meets the following requirements.

Windows system requirements

■ 800 MHz CPU

■ Microsoft Windows® XP or Windows Vista®

■ 256 MB of RAM

■ Graphics card capable of 1024 x768 display

■ We recommend that you use a pressure-sensitive Wacom® tablet and pen
for basic features.

NOTE We do not support other tablet brands, though they might work.
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Macintosh system requirements

■ Mac OS X, Version 10.4, 10.5 G4, G5, or Intel-based CPU*

■ 256 MB of RAM

■ Graphics card capable of 1024 x 768 display

■ SketchBook Pro for OS X is delivered as a Universal Binary supporting both
PPC and Intel-based Mac systems.

NOTE For Mac users, Autodesk SketchBook Pro is Leopard ready.

■ We recommend the use of a pressure sensitive Wacom® tablet and pen for
basic features.

NOTE We do not support other tablet brands, though they might work.

Tablet PC

We designed Autodesk SketchBook Pro for pressure-sensitive Tablet PC devices
running Microsoft® Windows XP™ Tablet PC Edition operating system.

Before installation
If you participated in either the Alpha or Betaprogram and created custom
brushes or textures, you will need to save them, then delete your preferences,
before installing SketchBook Pro 2010. If you don’t, these custom brushes will
be deleted and your marking menus could contain unexpected combinations
of tools.

For Mac users

1 Go to [Macintosh HD]/Users/[user account]/Library/Application

Support/Autodesk/SketchBook Pro/4.0.

2 Copy your BrushTextures and CustomBrushes folders.

3 Save them on your desktop.
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4 Return to [Macintosh HD]/Users/[user account]/Library/Application

Support/Autodesk/SketchBook Pro/4.0 and delete userPreferences.xml
and LagoonMMDefinition.xml.

5 Install SketchBook Pro 2010R1.

6 After the installation, copy the BrushTextures and CustomBrushes folders
and paste them in [Macintosh HD]/Users/[user

account]/Library/Application Support/Autodesk/SketchBook Pro/4.0.
Your custom brushes and textures are now accessible in SketchBook Pro
2010.

For PC users

1 Go to C:\Documents and Settings\[user account]\Application

Data\Autodesk\SketchBook Pro\4.0.

NOTE If Application Data is hidden, follow these instructions to make is
visible. In themenu bar, select Tools > Folder Options to open the Folder
Options window. Click the View tab. In Advanced settings, go to Files and
Folders > Hidden files and folders. Select Show hidden files and folders
. Click OK.

2 Copy your BrushTextures and CustomBrushes folders.

3 Save them on your desktop.

4 Return to C:\Documents and Settings\[user account]\Application

Data\Autodesk\SketchBook Pro\4.0 and delete userPreferences.xml
and LagoonMMDefinition.xml.

5 Install SketchBook Pro 2010.

6 After the installation, copy the BrushTextures and CustomBrushes folders
and paste them in C:\Documents and Settings\[user

acData\Autodesk\SketchBook Pro\4.0. Your custom brushes and textures
are now accessible in SketchBook Pro 2010.

Install Autodesk SketchBook Pro
To ensure Autodesk SketchBook Pro is installed correctly, if you installed the
SketchBook Pro alpha, uninstall it. If you do not have the alpha installed,
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please find the appropriate section and following the installation instructions.
If you are activating the software from a license, see Activate the software from
a serial number on page 10.

Installing on Windows (PC and Tablet PC)

There are two methods for installing SketchBookPro. For people with the
SketchBookPro DVD, inserting it into your disc drive should start the
installation process. However, if this is not the case or you are downloading
the software from our web site, see Manual installation.

DVD installation

1 Place the SketchBookPro DVD into your disc drive. A splash screen
appears.

2 Follow the installation instructions.
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What is seen if you need to uninstall an old version of SketchBook.

What is seen if all is fine.
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Manual installation

1 Download the Autodesk SketchBook Pro executable file,
Autodesk_Sketchbook_Pro_2010_ML_WIN_32_r1.exe.

2 Double-click the Autodesk_Sketchbook_Pro_2010_ML_WIN_32_r1.exe
file.

3 Follow the installation instructions.

If a previous version of the software is installed on your machine, you
will see the screen that follows and will need to uninstall the old version
of the software before continuing. Click Done, uninstall the software,
then reinstall.
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Uninstalling SketchBook Pro

1 Click the Start menu and select Settings > Control Panel > Add or
Remove Programs to open a window.

2 Locate Autodesk SketchBookPro 2010R1 and click the Remove
button.

3 Click Yes when asked if you want to remove the software. The
software will be removed and the window can be closed.

Now, repeat the installation process. See the previous section, Installing
on Windows (PC and Tablet PC), to continue.

Installing on Macintosh

There are two methods for installing SketchBookPro. For people with the
SketchBookPro DVD, inserting it into your disc drive should start the
installation process. However, if this is not the case or you are downloading
the software from our web site, see Manual installation.

DVD installation

1 Place the SketchBookPro DVD into your disc drive, this opens a Finder
window.
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2 Double-click Autodesk_Sketchbook_Pro_2010_ML_MAC_OSX_r1.mpkg
to launch the installer.

3 Follow the instructions. Please note that during the installation process,
if you do not accept the licensing conditions, the installation is
terminated.

Manual installation

1 Download and double-click the disk image (.dmg) file,
Autodesk_Sketchbook_Pro_2010_ML_MAC_OSX_r1.dmg.

2 Double-click the
Autodesk_Sketchbook_Pro_2010_2010_ML_MAC_OSX_r1.mpkg file.

3 Follow the instructions. Please note that during the installation process,
if you do not accept the licensing conditions, the installation is
terminated.

Activate the software from a serial number
The first time you open SketchBook, the product activation window appears.

1 Click Enter Serial Number to enter your serial number and product key.
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2 Click OK.

Entering a serial number

Besides going through the procedure above, there is another place where a
serial number can be entered.

1 Select Help > Enter Serial Number to open the SketchBook Pro Product
Activation window.

2 Enter the serial number and product key from the product packaging or
online purchase confirmation, then click OK.

NOTE If you don’t have a serial number, you can still use SketchBook by
clicking Use Trial to install a 15 non-consecutive day trial version.
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Improving performance
To improve performance, try the following suggestions:

■ For Vista users, in your Control Panel, turn off Pens and Input Devices.
Select Control Panel > Pen and Input Devices > Pen Options > Pen Buttons
> Use the pen button as a right-click equivalent.

■ Right-click on the SketchBook application icon  to select Properties.
In the window that appears, check Disable desktop compositing.

■ Select Edit > Preferences to open the Preferences window. In the General
tab, in the Graphics section, deselect Enable Rotate Canvas. Click OK.
Restart Sketchbook to improve performance.

NOTE When Enable Rotate Canvas is deselected, Rotate Canvas is not available.

Tablet PC setup
We recommend the following additional setup to get the best experience
possible with a Tablet PC.

Tune system performance

For best performance, use the primary landscape orientation.

Some Tablet PC models run slower in portrait mode, due to hardware
implementation. We recommend using landscape mode in this situation.

Fine tuning system performance

1 Go to your system's Start menu.

2 Select Setting > Control Panel.

3 Make sure the Category View is showing.
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4 Select the Printers and Other Hardware category.

5 Select the Tablet and Pen Settings icon.

6 Under the Display tab, select the Primary Landscape screen orientation.

Selecting the best performance setting

1 Go to your system's Start menu.

2 Select Control Panel.

3 Make the category view visible (the window contains the heading "Pick
a category").

4 Select the Performance and Maintenance category.

5 Select the Adjust Visual Effects tab.

6 From the Visual Effects tab, select Adjust for best performance.

Disable the pop-up keyboard

When you wiggle the pen, a keyboard window appears. If you find this window
interferes with your sketching workflow, you can temporarily disable the
window as follows:

Disabling the pop-up keyboard

1 Go to the Start menu.

2 Select Setting > Control Panel.

3 Make sure the Category View is showing.
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4 Select the Printers and Other Hardware category.

5 Select the Tablet and Pen Setting icon.

6 In the window that appears, select the Pen Options tab.

7 Under the Pen Action heading, select the Start Input Panel Gesture entry.
It turns blue when selected.

8 Click the Settings button.

9 De-select the Enable Start Input Panel Gesture checkbox, which removes
the checkmark.

When you enter text again (for example, to type a file name), turn this
checkbox back on. As an alternative, try to increase the size threshold of
the pen wiggle by increasing the value of the Gesture slider to Large.

10 Click OK.

Disable the mouse indicator

If a right mouse button indicator keeps popping up next to the pen, disable
it as follows:

Disabling the mouse indicator

1 Go to the Start menu.

2 Select Setting > Control Panel.

3 Make sure the Category View is showing.
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4 Select the Printers and Other Hardware category.

5 Select the Tablet and Pen Settings icon.

6 In the window that appears, select the Pen Options tab.

7 Under the Pen Action heading, select the Press and Hold entry. It turns
blue when selected.

8 Click the Settings button.

9 In the window that appears, turn off the Enable press and hold for
right-click checkbox.
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Copyright and trademarks

© 2009 Autodesk, Inc. All Rights Reserved. Except as otherwise permitted by Autodesk, Inc.,
this publication, or parts thereof, may not be reproduced in any form, by any method, for
any purpose.

Certain materials included in this publication are reprinted with the permission of the
copyright holder.

Trademarks

The following are registered trademarks or trademarks of Autodesk, Inc., in the USA and other
countries: 3DEC (design/logo), 3December, 3December.com, 3ds Max, ADI, Alias, Alias (swirl
design/logo), AliasStudio, Alias|Wavefront (design/logo), ATC, AUGI, AutoCAD, AutoCAD
Learning Assistance, AutoCAD LT, AutoCAD Simulator, AutoCAD SQL Extension, AutoCAD
SQL Interface, Autodesk, Autodesk Envision, Autodesk Insight, Autodesk Intent, Autodesk
Inventor, Autodesk Map, Autodesk MapGuide, Autodesk Streamline, AutoLISP, AutoSnap,
AutoSketch, AutoTrack, Backdraft, Built with ObjectARX (logo), Burn, Buzzsaw, CAiCE, Can
You Imagine, Character Studio, Cinestream, Civil 3D, Cleaner, Cleaner Central, ClearScale,
Colour Warper, Combustion, Communication Specification, Constructware, Content Explorer,
Create>what's>Next> (design/logo), Dancing Baby (image), DesignCenter, Design Doctor,
Designer's Toolkit, DesignKids, DesignProf, DesignServer, DesignStudio, Design|Studio
(design/logo), Design Web Format, Discreet, DWF, DWG, DWG (logo), DWG Extreme, DWG
TrueConvert, DWG TrueView, DXF, Ecotect, Exposure, Extending the Design Team, Face
Robot, FBX, Filmbox, Fire, Flame, Flint, FMDesktop, Freewheel, Frost, GDX Driver, Gmax,
Green Building Studio, Heads-up Design, Heidi, HumanIK, IDEA Server, i-drop, ImageModeler,
iMOUT, Incinerator, Inferno, Inventor, Inventor LT, Kaydara, Kaydara (design/logo), Kynapse,
Kynogon, LandXplorer, LocationLogic, Lustre, Matchmover, Maya, Mechanical Desktop,
Moonbox, MotionBuilder, Movimento, Mudbox, NavisWorks, ObjectARX, ObjectDBX, Open
Reality, Opticore, Opticore Opus, PolarSnap, PortfolioWall, Powered with Autodesk Technology,
Productstream, ProjectPoint, ProMaterials, RasterDWG, Reactor, RealDWG, Real-time Roto,
REALVIZ, Recognize, Render Queue, Retimer,Reveal, Revit, Showcase, ShowMotion, SketchBook,
Smoke, Softimage, Softimage|XSI (design/logo), SteeringWheels, Stitcher, Stone, StudioTools,
Topobase, Toxik, TrustedDWG, ViewCube, Visual, Visual Construction, Visual Drainage,
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Visual Landscape, Visual Survey, Visual Toolbox, Visual LISP, Voice Reality, Volo, Vtour,
Wire, Wiretap, WiretapCentral, XSI, and XSI (design/logo).

The following are registered trademarks or trademarks of Autodesk Canada Co. in the USA
and/or Canada and other countries: Backburner,Multi-Master Editing, River, and Sparks.

The following are registered trademarks or trademarks of MoldflowCorp. in the USA and/or
other countries: Moldflow, MPA, MPA (design/logo),Moldflow Plastics Advisers, MPI, MPI
(design/logo), Moldflow Plastics Insight,MPX, MPX (design/logo), Moldflow Plastics Xpert.

All other brand names, product names or trademarks belong to their respective holders.

Disclaimer

THIS PUBLICATION AND THE INFORMATION CONTAINED HEREIN IS MADE AVAILABLE
BY AUTODESK, INC. "AS IS." AUTODESK, INC. DISCLAIMS ALL WARRANTIES, EITHER
EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO ANY IMPLIED WARRANTIES
OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE REGARDING THESE
MATERIALS.

Published by:

Autodesk, Inc.

111 Mclnnis Parkway

San Rafael, CA 94903, USA

Please send us your comment about this page.
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