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Autodesk® Revit® Building Family Editor - From the 
Beginning

Intended to compliment Course BD35-2 "Take Your Family to the Next Level", this lab will guide you 
through the process of creating a complete door family.  Along the way you'll gain valuable insight into 
this powerful feature of Autodesk Revit.  By the end of class, not only will you will have a door family 
that you can use right away, you'll know how to do it again.  You'll feel empowered to apply what 
you've learned to make the content you need, when you need it.  Special guest speaker David Conant 
will be on hand to provide his unique insight into the family editor and several well known Revit guru's 
will provide lab assistance.
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01. INTRODUCTION 

A. Open Family template: File > New > Family > Generic Model.rfa 

B. The Revit Family Editor User Interface 

 

C. Things we do Repeatedly during this Lab 

1. Family Types 

a. Click Family Types button on Design Bar 

This is where we gain access to the parameters of each family.  It is also where we 
create formulas for parameters and define types for a family. 

 

2. Element Properties 

a. Pick a Reference Plane > Right Click > Choose Properties or 

b. Click Properties button on options bar 

We can pick the options bar button next to the type selector or Right Click and choose 
the Properties option. 
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3. Apply Labels 

a. Copy Reference Plane (Left/Right) to the left 3’-0” 

b. Add dimension between them 

c. Press ESC twice > Pick dimension > Click “None” next Label on options bar 

The parameters we can apply to dimensions are called Labels.  These are accessed 
from the Options Bar or Right Click > Edit Label, after picking a dimension. 

 

d. Cancel everything 

4. Link Parameters between Host and Nested components 

a. File > Load From Library > Load Family 

b. Browse to Imperial Library > Casework > Domestic Kitchen 

c. Choose: Base Cabinet-2 Bin.rfa > place it randomly 

d. Press ESC twice > Pick cabinet > Right Click > Choose Properties 

e. Click Edit/New > Notice the parameters and the little gray button on the far 
right. 

Parameters in nested families need to be linked to parameters in the host family.  This is 
accomplished by clicking a small subtle gray button in the Type Properties form of a 
nested family. 

 

A parameter that is linked will display “=” in the button and those that are not, won’t. 

5. File > Close > Don’t Save… 

02. GENERAL ADVICE 

A. Use snaps and snap overrides 

B. Make sure you select the object as a reference that you intended 



BD21-1L Autodesk® Revit® Building Family Editor: From The Beginning 

Lab Intro 
4

C. Use temporary hide/isolate to make sure only the objects you want to reference are 
visible 

D. Alter dimension style(s) so it/they work(s) better for laying out your family, remove 
extension line offset, decrease text size etc. 

E. Dimension only to reference planes, align/lock solids/voids to reference planes 

F. If you ignore #4, don’t do both “in the sketch” and “outside the sketch” 

G. Don't move the "origin", check the location of the origin by importing a dwg with 
linework representing 0,0, and use “Origin to Origin” if you think you did.  A little 
background, if you move the reference planes defining the origin you will think the 
placement origin is moved.  In fact the reference planes don't really define the origin 
anymore because Revit maintains the original origin is actual the internal 0,0 for 
placement.  This is a bug. 

H. Don't use "-" in parameter names because it turns into a minus if you use the 
parameter in a formula 

I. Change the scale of the view to make it easier to constrain, select geometry...be 
sure to test the family at various scales. Lineweights, graphic performance, 
particularly if nested annotation are included. 

J. Add additional types to the host in hosted families.  This makes it faster to test for 
different host thicknesses. 

K. Don't define materials in families, use sub-categories as much as possible 

L. Don't include parameters in families that don't change geometry, instead put them 
in project templates and apply them to the categories they affect. 

M. Don't dimension objects inside a sketch and then constrain the object outside the 
sketch, either all in or out.  The exception to this is the depth of an extrusion which 
you can constrain outside of a sketch because you can’t constrain it with 
dimensions elsewhere.  It is safer to align/lock to reference planes. 

N. Angles and arcs are hardest to constrain.  Save them for last and use Hide/Isolate 
to remove unnecessary objects from view so it is easier to ensure you constrain the 
right parts. 

O. Window and Door cuts per family cut plane 

P. Make a system type parameter into an instance parameter, select label in view, 
check instance parameter in option bar. 

Q. Shared families can only pass instance based parameters 

R. Voids don't allow visibility on/off or level of detail 

S. Mirror does not copy locks 

03. CREATE THE HOST FAMILY (SETTING THE STAGE) 

A. Use Door Family template 

1. FILE > NEW > FAMILY > Door.rft 

2. FILE > SAVE > BROWSE to: MY DOCUMENTS > Name: AU 2005 Door 
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When you choose SAVE, Revit knows the file is a template and asks you for a new 
name.  Revit will add the extension “RFA” automatically. 

3. Open View: Ref. Level > Maximize view window 

 

TIP!  You know you can double click the blue bar?  It’s a “Windows” thing… 

4. Change View Scale: 1”=1’-0” 

Increasing the scale will make the geometry larger and the relative size of dimensions 
smaller, and easier to see everything. 

 

5. Delete the trim: Select the trim objects 

 

6. RIGHT CLICK > Choose: Delete 

Why are we deleting these?  Don’t need them…it is a masonry door family! 

7. CLICK: Family Types (design bar) 

 

a. Remove parameter: Frame Project Ext. > Trim Projection Exterior 

b. Click: YES 

 

c. Repeat > Remove Parameter: Frame Projection Int. > Trim Projection Interior 

d. Repeat > Remove Parameter: Frame Width > Trim Width Interior 



BD21-1L Autodesk® Revit® Building Family Editor: From The Beginning 

Exercise 1 
6

e. Click: OK 

B. Move the EQ dimension down below the wall to get it out of our way 

 

C. Delete dimension in Exterior Elevation 

We need to do the width a little differently to allow for a jamb and to calculate our rough 
opening.  Leaving this here would generate an error later and be confusing. 

1. Open View: Elevations (Elevation 1): Exterior 

2. Pick Dimension with Label: Width > Delete 

 

3. Close View 

D. Adding additional wall types to host wall 

This will make testing/flexing our family easier, faster 

1. Create the additional wall types 

a. Select the wall object 

b. Click: Properties 

 

c. Click: Edit/New 

d. Click: Duplicate 

e. Accept new wall name offered: Wall 2 > Click: OK 

f. Click: Duplicate (yes, a second time) 

g. Accept new name offered: Wall 3 > Click: OK 
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E. Change the width for each wall type 

BTW, We should still be viewing the type parameters for Wall 3, if not let’s get back on 
the same “wall”. 

1. Click: Structure’s EDIT button 

 

Yes it really is a button even though it is long and doesn’t really look like buttons you are 
used to looking at.  A seasoned Revit user has gotten over this by now, but new users 
are sometimes confused when you ask them to click the “edit button”. 

2. Change the thickness for type: Wall 3: 1’-6” Width 

 

Yes, you click inside the field just like Excel to edit the value.  You can enter 0 18, 0-18, 
1-6, 1’-6”, 1’-6, 18”…Revit assumes feet and wants a foot value, a space and an inch 
value when you don’t supply the ‘ mark or “ mark…so no need to enter them if you don’t 
want to. 

3. Repeat for type: Wall 2: 1’-0” Width 

4. Repeat for type: Wall 1: 0’-6” Width (already set to this) 

F. Adjustable Door Inset 

We need a Reference Plane so we can move the door assembly in or out within the 
opening. 

1. Change Wall Type: Type 3 

2. Draw Reference Plane between the host wall’s exterior face and the reference 
plane Center (Front/Back) 

 

3. Name Reference Plane: Door Inset > IsReference: Weak Reference 

a. Select the Reference Plane, Right Click, choose Properties 
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4. Add dimension between Reference Plane and Exterior Face of Wall 

5. Select Reference Plane > Change Dimension value: 0’-2” 

 

6. Add Parameter to dimension 

a. Select the dimension > Click Label:None > Choose <Add parameter> 

 

b. Assign the values to match this image 

 

A reasonable argument could be made for this to be an instance parameter.  For the 
sake of this lab we’ll just use Type. 

G. Wall Offset Alignment Feature 

1. Add Reference Planes on either side of the opening 

a. Position: 6” from the Right And Left Reference Planes 

b. Name: Wall Offset Right and Left accordingly 

c. IsReference: Strong Reference 

2. Add dimension between each and Left and Right Reference planes 

3. Add Label for Reference Plane Wall Offset Left 

a. Name: Wall Offset Left > Group: Constraints 

4. Add Label for Reference Plane Wall Offset Right 

a. Name: Wall Offset Right > Group: Constraints 
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H. Rough Opening & Jamb Width 

1. Copy Reference Plane: Right 

a. To the left: 0’-2” > Name: Jamb Right > IsReference: Weak 

2. Copy Reference Plane: Left 

a. To the right: 0’-2” > Name: Jamb Left > IsReference: Weak 

3. Add Dimension between each new reference plane and Reference Plane Right 
and Left 

4. Add Label to each Dimension  

a. Name: Jamb Width > Group: Dimensions 

 

5. Add a formula to parameter Rough Width 

a. Design Bar > Family Types 

b. Parameter: Rough Width > Formula: Width + (Jamb Width * 2) 

 

6. Increase the width of the opening 

a. Pick the dimension string between Reference Plane Right and Left 

The dimension string with the EQ toggle on 
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b. Toggle the EQ off 

This will let us adjust the opening without shifting the layout undesireably.  If we didn’t 
delete the width dimension earlier we would have seen unexpected behaviour while 
adjusting the width. 

c. Pick Reference Plane: Right > Change dimension value: 1’-8” 

d. Pick Reference Plane: Left > Change dimension value: 1’-8” 

e. Press ESC twice > Select the dimension string again > Toggle EQ on 

7. Add dimension between Reference planes: Right & Left 

a. Add Label to dimension string > Select Rough Width from list 

 

There is no need to apply the Width parameter since the combination of Jamb Width and 
Rough Width are defining it for us.  Besides the Width parameter drives the whole thing, 
since it is part of the formula we placed in Rough Width. 

I. Add Jamb Head Reference Plane to Elevation View 

1. Open View > Elevations (Elevation 1): Exterior 

2. Copy Reference Plane: Top > down 0’-4” 

3. Pick copy > Right Click > Properties > Name: Head Bottom 

4. Add dimension between Reference Plane: Top & Head Bottom 

5. Add Label to dimension 

a. Name: Head Width > Group: Dimensions > Type  > OK / OK 

J. Add formula to parameter: Rough Height 

1. Click Family Types > Click in Formula column next to Rough Height 

2. Type Formula: Height + Head Width 

 

3. In View Elevations (Elevation 1): Exterior select dimension with Height label 

4. Switch labels from Height to Rough Height (choose from list) 
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K. Testing/Flexing/Save 

1. Experiment with parameter values 

2. Open View 3D Views: View 1 

a. View > Orient > Northwest > Press F8 > Click Save Icon 

 

3. File / Save or Click SAVE icon on Toolbar 

 

L. File > Close 

04. CREATE THE SHARED PARAMETER 

A. File | Shared Parameters 

 

1. Click: Create 

 

2. Name the file (put it in My Documents) 

 

3. Create the group 

 

4. Name: AU Lab 
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5. Create the shared parameter 

 

6. Name: Undercut 

a. Type: Length 

 

7. Click: OK | OK 

05. APPLY THE SHARE PARAMETER 

A. Create a parameter using the shared parameter Undercut 

B. (Design Bar) Click: Family Types 

 

C. In the Parameters Frame, click: Add 

 

D. Click Radio button for Shared Parameter, the Click Select Button 

 

Because we just defined the shared parameter file we don’t need to browse to find it.  
Revit will remember the last shared parameter file we created until we point to another or 
it can’t find that last one. 
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E. Choose the Undercut parameter from the list, click OK 

 

F. Group: Dimensions 

 

You could easily argue that this should be an instance parameter but for this exercise we 
will let it be Type. 

G. Click OK 

06. BUILDING THE DOOR PANEL 

A. Use Generic Model Template 

Why? Starting out with this template means we can build it without a host object. 

1. New > Family > Generic Model.rft 

2. SaveAs > AU 2005 Door Panel.rfa (My Documents) 

3. Maximize view: Ref. Level 

4. Change View Scale: 1-1/2”=1’-0” 

B. Convert to Door Category 

Why? Now that we don’t have a host object, it allows us to use predefined sub-
categories for doors when we want to assign solids to a category. 

1. Settings > Family Category and Parameters 

2. Check: Doors 

3. Check: Work Plane-Based 

4. Un-Check: Always Vertical 

 

We need Work Plane-Based to permit us to later use the work plane of a reference line 
to control the rotation of the panel in the host family. 

C. Layout Reference Planes in Plan View 
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1. RIGHT - Copy Reference Plane: Center (Left/Right) 

a. To the right: 1’-6” 

b. Name: Right > IsReference: Right 

c. Origin: Yes 

d. Pin Reference Plane position 

Why? We need this panel to flex from one side, not center outward.  If we don’t do this, it 
will move around undesirably in the host family. 

2. LEFT - Mirror Reference Plane: Right 

a. Pick Reference Plane: Center (Left/Right) as axis of reflection 

b. Name: Left > IsReference: Left 

3. FRONT - Copy Reference Plane: Center (Front/Back) 

a. Up: 0-7/8” 

b. Name: Front > IsReference: Front 

c. Origin: Yes 

d. Pin Reference Plane Position 

4. BACK - Mirror Reference Plane Front 

a. Pick Reference Plane: Center (Front/Back) as axis of reflection 

b. Name: Back > IsReference: Back 

5. MULLION FRONT - Copy Reference Plane: Center (Front/Back) 

a. Up 3/8” 

b. Name: Mullion Front > IsReference: Not a Reference 

6. MULLION BACK - Mirror Reference Plane: Mullion Front 

a. Pick Reference Plane Center (Front/Back) as axis of reflection 

b. Name: Mullion Back > IsReference: Not a Reference 

7. GLAZING FRONT - Copy Reference Plane: Center (Front/Back) 
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a. Up 3/16” 

b. Name: Glazing Front > IsReference: Not a Reference 

8. GLAZING BACK – Mirror Reference Plane Glazing Front 

a. Pick Reference Plane: Glazing Front as axis of reflection 

b. Name: Glazing Back > IsReference: Not a Reference 

9. STILE INSIDE RIGHT – Copy Reference Plane Right 

a. To the left, inside of Reference Plane Right: 0’-5” 

b. Name: Stile Inside Right > IsReference: Not a Reference 

10. STILE INSIDE LEFT – Copy Reference Plane Left 

a. To the right, inside of Reference Plane Left: 0’-5” 

b. Name: Stile Inside Left > IsReference: Not a Reference 

D. Dimension the Reference Planes 

 

Remember to toggle the “EQ” option on the dimensions as shown above 

E. Label the Dimensions 

 

1. Width (stock parameter) 

2. Thickness (stock parameter) 

3. Thickness Glazing > Group: Other 

4. Thickness Mullion > Group: Other 

5. Stile Right > Group: Other 

6. Stile Left > Group: Other 

F. Add Control (Flip Arrow) 
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1. Choose Double Horizontal & Double Vertical 

 

2. Place as shown here 

 

3. Cancel command > press ESC twice or click Modify 

 

G. Layout Reference Planes in Elevation View 

 

1. Open View > Elevation: Front 

a. Set View Scale: 1”=1’-0” 

2. Sketch a horizontal reference plane 7’-0” above Ref. Level 

a. Name: Top > IsReference: Top 

3. Pick the Reference Plane we just sketched > Copy > Down: 0’-5” 

a. Name: Top Rail Inside > IsReference: Not a Reference 

4. Sketch a horizontal reference plane 0’-2” above Ref. Level 
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a. Name: Panel Undercut > IsReference: Weak Reference 

5. Sketch a horizontal reference plane 0’-10” above Ref. Level 

a. Name: Bottom Rail Inside > IsReference: Not a Reference 

H. Dimension the Reference Planes 

 

I. Label the Dimensions 

1. Label > Height (from stock list)  

2. Label (Add Parameter) > Rail Top > Type: Length > Group: Other 

3. Label (Add Parameter)  > Rail Bottom > Type: Length > Group: Other 

J. Add Shared Parameter (Refer to Exercise 3) 

1. Pick dimension > Label (Add Parameter) > Shared Parameter > Select > 
Undercut (from earlier file) > Group: Other 

 

K. Add Parameters 

1. Click: Family Types > Add parameter 

a. Mullion Width  > Type: Length  > Group: Other > Value: 0’-3/4” 

b. Lite Width  > Type: Length  > Group: Other > (calculated value) 

c. Lite Height  > Type: Length  > Group: Other > (calculated value) 
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2. Create Parameters to change the number of lites 

a. Lites Horizontal > Type: Integer > Group: Constraints 

b. Lites Vertical > Type: Integer > Group: Constraints 

c. Note to User > Type: Text > Group: Constraints 

Using groups here to just segregate the parameters.  Trying to make it a little easier to 
discern things. 

3. Assign maximum number of lites and provide “note to user” 

 

L. Add Calculations to parameters 

Remember parameters in formulas are Case Sensitive! 

a. Enter Partial formula: ((Width - (Stile Right + Stile Left)) - ((Lites Horizontal - 1) 
* Mullion Width)) 

Adding the formula in two stages will prevent an error that I haven’t discovered the 
cause.  Any ideas? 

b.  Click Apply 

c. Add at end of formula: / Lites Horizontal 

d. Click Apply 

2. Parameter Lite Height 

a. ((Height - (Rail Top + Rail Bottom)) - ((Lites Vertical - 1) * Mullion Width))  

This formula typically works when everything is entered at once but will repeat the 
process for consistency. 

b. Click Apply 

c. Add at end of formula: /Lites Vertical 

d. Click Apply 

 

This is the closest thing we’ve got to LISP (“Lost in Silly Parenthesis”) 

M. Make a new Dimension Style  

To make it easier to do the next step, first a new arrowhead, then dimension style 

1. Menu: Settings 
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a. Duplicate existing Type: Diagonal 1/8” > Name: Diagonal 1/32” 

b. Tick Size: 1/32” > Click: OK 

2. Menu: Settings 

 

3. Duplicate | Name: Void 

 

N. Create Lites with Void 

1. Void Form > Void Extrusion 

2. Sketch small rectangle off to the side of the panel reference planes 

 

3. Add dimensions to sketch (Type: Void) 

4. Add Labels to Dimensions (use list) 

a. Lite Width 

b. Lite Height 
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5. Copy the rectangle and dimensions > To the Right, past the right side of the 
original 

6. Add Dimension between the adjacent edges of the rectangles 

7. Add Label to Dimension > Select Mullion Width from the list of choices 

8. Copy both rectangles > To the right past the right side of the second rectangle 

9. Add Dimension Between the two inside rectangles adjacent edges (2x) 

10. Add label to Dimension > Select Mullion Width from the list of choices 

At this stage we should see this what we see in this image 

 

11. Copy all four rectangles > Up past the top of the existing rectangles 

12. Add Dimensions between each adjacent sketch line (4x) 

13. Add Label to Dimension > Select Mullion Width from the list of choices (4x) 

14. Copy all eight rectangles > Up past the top of the previous 

15. Add Dimensions between each adjacent sketch line (4x) 

16. Add Label to Dimension > Select Mullion Width from the list of choices (4x) 

17. Copy all 16 rectangles > Up past the previous 

18. Add Dimensions between each adjacent sketch line (4x) 

19. Add Label to Dimension > Select Mullion Width from the list of choices (4x) 



BD21-1L Autodesk® Revit® Building Family Editor: From The Beginning 

Exercise 4 
21

After this series we should see the following 

 

20. Align the bottom row with Reference Plane: Bottom Rail Inside 

a. Align > Check: Multiple 

 

b. Pick Reference Plane: Bottom Rail Inside 

c. Pick bottom sketch line of each rectangle 

d. Click Padlock as each appears (4x) 

 

21. Align left side of Rectangle cluster to Reference Plane: Stile Inside Left 

a. Align > (Multiple still checked) 

b. Pick Reference Plane: Stile Inside Left 

c. Pick each outside sketch line from the left column of rectangles 

d. Click the padlock as each appears (8x) 

22. Adjust the dimensions that stay behind 

a. Select the dimensions > Nudge them into position 
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b. Finish Sketch of Void (should look like this) 

 

The void isn’t cutting anything yet so it is easy to see Align/Lock the depth of the void 

23. Open View: Floor Plans: Ref. Level 

24. Select Void > Drag upper edge beyond Reference Planes 

25. Align > (uncheck Multiple) Pick Reference Plane: Front > Pick front of void > 
Click Padlock 

26. Align > Pick Reference Plane: Back > Pick back of void > Click Padlock 

 

O. Add a Solid Mullion (Sketching loosely, Align/Lock) 

1. Open View > Elevations: Front 

2. Sketch the solid 

a. Solid Form > Solid Extrusion > Sketch Lines > Rectangle 

Sketch the rectangle larger than the panel reference planes taking care not to draw 
directly on top of any reference planes. 

b. Align/Lock sketch lines to Reference Planes: Top Rail Inside, Bottom Rail 
Inside, Stile Inside Right and Stile Inside Left (per following image) 
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Beware where you pick to choose the reference planes for alignment.  If the object you 
want doesn’t highlight check the status bar (and/or tool tip) to see what Revit is offering 
for selection.  As a rule try to pick somewhere that isn’t covered by other geometry.  Tab 
if necessary to pick the correct object.  Don’t forget Temporary Hide/Isolate will help too! 

3. Assign sub-category 

a. Menu: Settings > Object Styles > Click New > Name: Mullion > OK 

b. Click Extrusion Properties > Choose Subcategory > Mullion 

c. Finish Sketch 

4. Set depth of Solid Mullion 

a. Open View > Floor plans: Ref. Level 

b. Select solid > drag upper grip past reference planes 

c. Align/Lock Mullion Front to Reference Plane: Mullion Front 

d. Align/Lock Mullion Back to Reference Plane: Mullion Back 

5. Cut Geometry 

a. Open View: 3D Views: [3D] 

b. Click Cut Geometry > Pick Void > Pick Solid 
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P. Add Solid Glazing (Sketch Loosely, Drag/Lock) 

1. Open View > Elevations: Front 

2. Solid Form > Solid Extrusion > Sketch Lines > Rectangle 

Sketch the rectangle larger than the panel reference planes taking care not to draw 
directly on top of any reference planes. 

a. Pick/Drag/Lock sketch lines over Reference Planes: (4x) Top Rail Inside, 
Bottom Rail Inside, Stile Inside Right and Stile Inside Left 

Pay close attention to the status bar to confirm that Revit finds the reference planes and 
locking will relate to the correct element. 

b. Assign Subcategory > Click Extrusion Properties > Subcategory: Glass 

If we look at the door in a 3D view we won’t see materials set because the Object Style 
for glass doesn’t have a material assigned. 

c. Finish Sketch 

d. Menu: Settings > Objects Styles > Glass > Assign Material: Glass 

As long as objects in the family are not assigned a specific material, just By Category, 
the Subcategory value will take precedence and the project material assignments will 
govern when it is loaded into a project. 

3. Set Depth of Solid Glazing 

a. Open View > Floor Plans: Ref. Level 

b. Pick Solid Glazing > Drag upper grip above reference planes 

c. Align/Lock Front of Solid to reference plane: Glazing Front 

d. Align/Lock Back of Solid to reference plane: Glazing Back 

Q. Add Solid Frame (Pick/Lock) 

a. Open View > Elevations: Front 

b. Solid Form > Solid Extrusion > Lines > Pick Tool (Check Lock Option) 

 



BD21-1L Autodesk® Revit® Building Family Editor: From The Beginning 

Exercise 4 
25

c. Pick Reference Planes: Top, Right, Left and Undercut 

d. Trim corners of sketch > Trim/Extend to Corner option 

e. Sketch > Lines > Pick Tool (Check Lock Option) 

f. Pick Reference Planes: Top Rail Inside, Bottom Rail Inside, Stile Right Inside & 
Stile Left Inside 

g. Trim corners of sketch > Trim/Extend to Corner option 

Pick on a part of the reference plane that isn’t covered by or covering anything else, to 
make it easier. 

h. Assign Subcategory > Extrusion Properties > Subcategory: Panel 

i. Finish Sketch 

2. Set depth of Solid Frame 

a. Open View > Floor Plans: Ref. Level 

b. Pick solid > Drag upper grip past reference planes 

c. Align/Lock Panel Front to Reference Plane: Front 

d. Align/Lock panel back to Reference Plane: Back 

R. FLEX / SAVE 

1. Open View > Default 3D View (Click the “3D House” toolbar button) 

2. Change parameters 

3. Open View > 3D Views: View 1 > Press F8 

4. Expand Dynamic Modify View dialog to see orientation options 

 

a. Click Save icon to save view configuration 

S. Change Object Style settings for the family (optional) 

1. Settings > Object Styles > Change objects assigned to colors to use black 

T. File > Save 

U. File > Close 

07. BUILDING THE 2D DOOR SWING DETAIL 

A. Justification 

1. Doing so reduces the effort of reproducing this graphic representation in other 
similar families.  We just have to load the family, position it and assign a few 
parameters to govern how it displays. 
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B. Setup 

1. File > New > Family > Generic Model.rft 

2. File > SaveAs > AU 2005 Door Swing.rfa (My Documents) 

3. Menu: Settings > Family Category and Parameters 

a. Check: Doors 

b. Uncheck: Always Vertical 

Or should we?  Hey Autodesk Guys, whadya think?  Can you explain this feature? 

4. Maximize View 

5. Increase the Scale of the view 

a. 1" = 1'-0" 

C. Add Object Style 

1. Menu: Settings > Object Styles > New > Name: Plan Swing 

This is to match up with the object style found in stock Revit door families. 

2. Lineweight: Projection = 1 > Cut = 1 

D. Reference Planes 

1. Reduce the extents so that the drawing area is smaller and closer to the size of 
the symbology we are creating 

2. Copy Right 3'-0" to the left, Name: Left > IsReference: Left  

3. Rename Center (Left/Right) > Name: Right > IsReference: Right > Check: Origin 

Entering values in the IsReference you can just click in the field and enter the first letter 
of the name you want.  You can also copy/paste the text into the Name field 

4. Rename Center (Front/Back) > Name: Front > IsReference: Front > Check: Origin 

5. Adjust the ref planes so they look like this 
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E. Sketching 

1. Sketch 1st line of panel 

a. Symbolic Line > Type: Panel (Cut) 

b. From intersection of Ref Planes Right and Front at 45 degrees and 3 feet long 

 

2. Sketch 2nd line 

a. Symbolic Line > Type: Panel (Cut) 

b. From second point of first line perpendicular to the line toward the left and 2" 
long 

 

3. Sketch 3rd Line 

a. Symbolic Line > Type: Panel (Cut) 

b. From end of second line parallel to first line till the second end of the line is 
parallel to the first point of the first lineSketch 4th Line 

 

4. Sketch 4th line 

a. Symbolic Line > Type: Panel (Cut) 

b. Close the rectangle of the panel 
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5. Sketch 5th Line 

a. Model Line > Type: Invisible 

b. From the intersection of Ref plane Right and Front (make sure it is the 
intersection of them) 

 

c. Sketch away from start point, left and below Reference Plane: Front, a couple 
degrees below 

 

6. Sketch 6th Line 

a. Pick invisible line and four (4) panel sketch lines > Temporary Hide/Isolate > 
Hide Object 

b. Symbolic Line > Type: Plan Swing (projection) > Option: Arc From Center End 
Points 

c. Place center for Arc at intersection of ref planes Right and Front.  First endpoint 
of arc from intersection of ref planes Left and Front.  Sketch last point up and 
toward the panel sketch lines that are hidden, pick a point nearby. 

 

d. Reset Temporary Hide/Isolate 

e. Pick the Arc segment > Drag bottom grip to the invisible line > Drag upper grip 
to outside upper corner of panel sketch 
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F. Dimensioning 

 

1. Add Angular Dimension: Swing Angle 

a. Between outer edge of panel and Reference Plane: Front 

2. Add Linear Dimension: Thickness 

a. Between long sides of panel 

3. Add Linear Dimension: Width (for system parameter) 

a. Add width dimension between short sides of rectangle panel 

4. Add Angular Dimension 

a. Between invisible line and outside edge of panel.  Adjust to exactly .5 degrees, 
Click padlock to lock 

5. Add Linear Dimension: Width (for system parameter) 

a. Between Right and Left ref planes 

G. Labels 

 

1. Add Label for swing 

a. Name: 2D Swing > Group: Graphics 
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2. Add Width for panel 

a. Select Width from list in pull down 

3. Add Width for Panel size, across Reference Planes 

a. Select Width from list in pull down, again 

4. Add label for thickness to door panel sketch lines 

a. Select Thickness from list in pull down 

H. Add Control (Flip Control) 

 

Add flip control to allow mirroring panel in double door families. 

I. FLEX 

1. Change swing angle (finish with 90 degree setting) 

2. Change panel width 

3. Change panel thickness 

J. File / Save 

Student Notes: 

08. ASSEMBLE THE HOST AND NESTED COMPONENTS 

A. Open Door Family File: AU 2005 Door.rfa 

B. Open View > Floor Plans: Ref. Level 

C. Loading nested components 

1. File > Load From Library > Load Family > Choose 

 

a. AU 2005 Door Panel 

b. AU 2005 Door Swing 

c. AU 2005 Frame HM (Already built, courseware part of handout) 

09. POSITION PANEL 

A. Sketch Reference Line 

NOT Reference PLANE, we want a Reference LINE! 

1. First point at intersection of Reference Planes Jamb Right and Door Inset 

2. Use Keyboard Shortcut snap override “SI” for snap interesection 
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3. Second point at 45 degrees and 3’-4” (see image) 

 

B. Add Angular Dimension 

1. Pick Reference Line and Reference Plane: Door Inset 

C. Add Label 

1. Label: Add Parameter > Name: 3D Swing > Group: Graphics > Instance 

 

2. Flex/Test (finish with 45 degree angle) 

D. Set Work Plane > Pick Plane > Reference Lines horizontal plane 

 

 

 

E. Place panel > Click Component 

 

1. Choose AU 2005 Door Panel 
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2. Hover cursor and panel over the reference line, use SpaceBar to rotate the panel 
(should have to press 4x) 

 

3. Move outside bottom corner to endpoint of Reference line 

 

4. Click Modify or Press ESC twice 

F. Link Component Parameters to Host parameters 

1. Select Nested Component: AU 2005 Door Panel 

2. Right Click / Properties 

3. Click: Edit/New 

4. Select parameter: Width 

a. Click Link Button > Choose Width (From List) > Click OK 

 

5. Select parameter: Height 

a. Click Link Button > Choose Height > Click OK 

6. Select parameter: Thickness > Click Link Button 

Oops…we can’t assign this one because Thickness in the host has no value yet, empty 
that it is.  We need to give it a value first. 

a. Click OK / OK / OK 

G. Add Parameter to Host 

a. Click Family Types 

b. Pick Thickness > Type: 0-2 > Click OK 

H. Return To Nested Component 

1. Choose Panel > Right Click > Choose Properties > Click: Edit/New 
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a. Select parameter: Thickness 

b. Click Link Button > Choose Thickness > Click OK 

The following steps will be repeated many times to create and link parameters in the 
host family to those in the nested family. 

2. Select parameter: Stile Right 

a. Click Link Button > Pick Add Parameter 

Adding parameters to the host family while editing the properties of the nested 
component allows revit to chose the correct data type automatically and eliminates the 
chance that we will create the parameter with the wrong type selected. 

 

b. Name: Stile Width > Group: Other > Type > Click: OK / OK 

3. Select parameter: Stile Left 

a. Click Link Button > Choose Stile Width > Click: OK 

4. Select parameter: Rail Top 

a. Click Link Button > Pick Add Parameter 

b. Name: Rail Top > Group: Other > Type > Click: OK / OK 

5. Select parameter: Rail Bottom 

a. Click Link Button > Pick Add Parameter 

b. Name: Rail Bottom > Group: Other > Type > Click: OK / OK 

6. Select Parameter: Thickness Mullion 

a. Click Link Button > Pick Add Parameter 

b. Name: Thickness Mullion > Group: Other > Type > Click: OK / OK 

7. Select Parameter: Thickness Glazing 

a. Click Link Button > Pick Add Parameter 

b. Name: Thickness Glazing > Group: Other > Type > Click: OK / OK 

8. Select Parameter: Mullion Width 

a. Click Link Button > Pick Add Parameter 

b. Name: Mullion Width > Group: Other > Type > Click: OK / OK 

9. Select Parameter: Note to User 

a. Click Link Button > Pick Add Parameter 

b. Name: Note to User > Group: Constraints > Type > Click: OK  / OK 

10. Select Parameter: Lites Vertical 

a. Click Link Button > Pick Add Parameter 
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b. Name: Lites Vertical > Group: Constraints > Type > Click: OK / OK 

11. Select Parameter: Lites Horizontal 

a. Click Link Button > Pick Add Parameter 

b. Name: Lites Horizontal > Group: Constraints > Type > Click: OK / OK / OK 

I. Panel Visibility 

1. Pick Nested Panel > Options Bar > Click: Visibility 

 

2. Un-Check: Plan/RCP 

 

3. Click OK 

4. Family Types > Supply Value to Parameter: 3D Swing > 0 degrees 

10. POSITION 2D SWING NESTED COMPONENT 

A. Restore the work plane > Workplane > Pick Name > Level: Ref. Level 

 

B. Component > Choose AU 2005 Door Swing > place near opening 

1. Align nested component with Reference Plane: Jamb Right > Lock 

2. Align nested component with Reference Plane: Door Inset > Lock 

C. Link parameters 

1. Pick nested component > AU 2005 Door Swing > Right Click: Choose Properties 
> Click: Edit/New 

a. Select parameter: Width > Pick Width from list 

b. Select parameter: Thickness > Pick Thickness from list 

c. Select parameter: 2D Swing > Click Add Parameter 

d. Name: 2D Swing > Group: Graphics  > Instance > Click OK / OK / OK / OK 

11. POSITION FRAME 

A. Place Component > Choose: AU 2005 Frame HM 

B. Place it loosely above opening 



BD21-1L Autodesk® Revit® Building Family Editor: From The Beginning 

Exercise 6 
35

 

C. Align/Lock Frame (Horizontal positioning) 

1. First Pick Reference Plane: Center (Left/Right) 

2. Second Pick Frame Reference Plane: Center (Left/Right) 

 

D. Align Lock Frame (Vertical Positioning - Part 1 of 2) 

1. First Pick Reference: Interior Wall Face (Tab to select) 

2. Second Pick Reference Plane: Back 

3. Click: Padlock 

 

4. First Pick Reference: Exterior Face of Wall (Tab to select) 

5. Second Pick Reference Plane: Front (Hinge Point) 

6. Click: Padlock 

 

E. Finished appearance after alignment 
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F. Select component: AU 2005 Frame HM > Click: Properties > Click: Edit/New 

1. Select Parameter: Width 

a. Click: Link Button > Choose: Width > Click: OK 

2. Select Parameter: Height 

a. Click: Link Button > Choose: Height > Click: OK 

3. Select Parameter: Jamb Width 

a. Click: Link Button > Choose: Jamb Width > Click: OK 

4. Select Parameter: Head Width 

a. Click: Link Button > Choose: Head Width > Click: OK / OK 

G. Click: Family Types 

1. Click: Add Parameter > Name: Door Inset Comment 

a. Type: Text > Group: Dimensions 

b. Value: Beware of thin walls (right above Door Inset) 

2. Click: Add parameter > Name: Frame Inset > Type: Length > Group: Constraints 

a. Assign Value to existing parameter > Name: Door Inset > Type: 0’-0” 

 

To allow a door assembly to be set further in a wall opening we invite an error where the 
frame’s stop geometry will need to be zero or less.  This will cause an error in both the 
host family and project environment.  So we need to warn our users that thin walls are 
likely to cause trouble.  There isn’t a straightforward way to do this, so this is a 
“workaround”. 

b. Add Formula to Parameter: Frame Inset > Type: Door Inset + Thickness 

c. Click OK > Select component: AU 2005 Frame HM 

d. Click: Properties > Click: Edit/New 

3. Select Parameter: Thickness 

a. Click: Link Button > Click: Add Parameter 

b. Link Parameter: Thickness > Frame Inset 

4. Select Parameter: Jamb Inset Inside 

a. Click: Link Button > Click: Add Parameter 

b. Name: Jamb Inset Inside > Group: Other > Click: Ok / OK 

5. Select Parameter: Stop Thickness 
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a. Click: Link Button > Click: Add Parameter 

b. Name: Stop Thickness > Group: Other > Click OK / OK / OK / OK 

H. Fix Elevation Swing Indication Linework 

The default template has these lines indicating a hinge point on Reference Plane: Left.  
All the stock Revit doors are set up with panel and hinge points on the Right. 

1. Open View > Elevations (Elevation 1): Exterior 

2. Select Symbolic Lines for Elevation Swing > Delete 

3. Select components Panel and Frame > Temporary Hide/Isolate > Hide Object 

Hiding objects again to make it easier to constrain the symbolic lines we need. 

4. Sketch > Symbolic Lines > Choose: Elevation Swing (Projection) 

5. Sketch from intersection of Reference Plane: Jamb Left and Head Bottom  to 
along Reference Plane: Right (roughly the middle) 

 

6. Sketch from the endpoint of the previous segment to a point above Ref. Level on 
Reference Plane: Left 

 

7. Add Dimension from Ref. Level to Endpoint of second segment 

 

a. Label > Undercut > Select from list 
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8. Add Dimension from Reference Plane: Head Bottom to Endpoint of diagonal 
segments and the end point of the second segment 

 

This will keep the diagonals at the midpoint between whatever the undercut value is and 
the top of the door panel. 

I. Flexing/Testing 

J. Saving the thumbnail view 

1. Open View > 3D Views: View 1 > Press F8 

2. Click (Orient to a Direction) > Choose: Northwest Isometric 

3. Click Save icon 

K. File / Save 

L. Design Bar > Load into Project 

1. Click New Project icon on Toolbar 

 

2. Click Window > Choose AU 2005 Door.rfa – 3D View: View 1 

 

3. In Family again > Choose: Load into Projects from Design Bar 

 

4. Switch back to project > sketch wall 

5. Place door > flex parameters > Finish at leisure Q/A time. 

12. BUILDING THE NESTED FRAME ASSEMBLY (BONUS) 

A. Use Generic Model Template 

Why? Starting out with this template means we can build it without a host object. 



BD21-1L Autodesk® Revit® Building Family Editor: From The Beginning 

Exercise 7 (Bonus) 
39

1. New > Family > Generic Model.rft 

2. SaveAs > AU 2005 Frame HM.rfa (My Documents) 

3. Maximize view: Ref. Level 

4. Change View Scale: 1-1/2”=1’-0” 

B. Convert to Door Category 

Why? Now that we don’t have a host object, it allows us to use predefined sub-
categories for doors when we want to assign solids to a category. 

1. Settings > Family Category and Parameters 

2. Check: Doors 

3. Check: Work Plane-Based 

4. Un-Check: Always Vertical 

 

We need Work Plane-Based to permit us to later use the work plane of a reference line 
to control the rotation of the panel in the host family. 

C. Layout Reference Planes in Plan View 

 

1. Copy Reference Plane: Center (Left/Right) 

a. To the right: 1’-8” 

b. Name: Rough Opening Right > IsReference: Weak 

2. Mirror Reference Plane: Rough Opening Right 

a. Pick Reference Plane: Center (Left/Right) as axis of reflection 

b. Name: Rough Opening Left > IsReference: Weak 
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3. Copy Reference Plane: Center (Front/Back) 

a. Up: 0-3” 

b. Name: Stop Front > IsReference: Weak 

4. Mirror Reference Plane: Stop Front 

a. Pick Reference Plane: Center (Front/Back) as axis of reflection 

b. Name: Back > IsReference: Weak 

5. Copy Reference Plane: Center (Front/Back) 

a. Up 0’-5” 

b. Name: Hinge Point > IsReference: Front 

6. Mirror Reference Plane: Hinge Point 

a. Pick Reference Plane Center (Front/Back) as axis of reflection 

b. Name: Back > IsReference: Back 

7. Copy Reference Plane: Rough Opening Right 

a. To the left, inside of Reference Plane: Rough Opening Right: 0’-2” 

b. Name: Right > IsReference: Right 

8. Mirror Reference Plane: Right 

a. Pick Reference Plane: Center (Left/Right) as axis of reflection 

b. Name: Left > IsReference: Left 

9. Copy Reference Plane: Right 

a. To the left: 0’-1” 

b. Name: Stop Side Right > IsReference: Weak 

10. Mirror Reference Plane: Stop Side Right 

a. Pick Reference Plane: Center (Left/Right) as axis of reflection 

b. Name: Stop Side Left > IsReference: Weak 

D. Dimensions 
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E. Labels 

 

1. Label > Thickness > Select from list 

2. Label (Add Parameter) > Jamb Width > Group: Other 

a. Select both dimensions before adding parameter label (saves time) 

3. Label (Add Parameter) > Stop Thickness > Group: Other 

a. Select both dimensions before adding parameter Label (saves time) 

4. Label (Add Parameter)  > Jamb Inset Inside > Group: Other 

5. Label (Add Parameter)  > Jamb Depth > Group: Other > Instance 

We need this to be an Instance parameter because doing so will allow the frame to flex 
to match the wall thickness of the host wall, assuming that is desireable.  If not, then the 
frame will have to have fixed sizes according to types. 

6. Add Value to parameter > Width: 3’-0” 
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If we don’t add this value to the parameter first then the formula will complain about not 
finding a value for Width. 

7. Add Formula > Parameter: Rough Width > Formula: Width + (Jamb Width*2) 

 

8. Label > Rough Width > select from list 

F. Reference Lines – View: Front Elevation 

 

1. Open View > Elevations (Elevation 1): Front 

a. Set View Scale: 1”=1’-0” 

2. Sketch Reference Plane > above Ref. Level > 7’-4” 

a. Name: Top > IsReference: Top 

3. Copy Reference Plane: Top > Down: 0’-4” 

a. Name: Head Bottom > IsReference: Weak 

4. Copy Reference Plane: Head Bottom > Down: 0’-1” 

a. Name: Head Stop > IsReference: Weak 

G. Dimension Reference Planes – View: Front Elevation 

 

H. Label Dimensions – View: Front Elevation 
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1. Label (Add Parameter)  > Head Width > Group: Other 

2. Add Value to parameter > Height: 7’-0” 

 

3. Add Formula > Parameter: Rough Height > Formula: Height + Head Jamb 

 

4. Add Label > Rough Height > Select from list 

5. Add Label > Stop Thickness > Select from list 

I. Symbolic Lines 

1. Open View > Floor Plans: Ref. Level 

2. Sketch Left Jamb linework 

a. Sketch > Symbolic Lines > Type: Frame/Mullion (cut) 

 

b. Check: Chain 

 

c. Sketch lines from intersection of Reference Planes to describe the following 
shape 
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No need to lock these sketch lines to the reference planes.  Revit assumes that because 
we sketched them on the reference lines they should maintain their relationship with 
them. 

d. Repeat the process for the Jamb on the right 

 

J. Extrusion - Right and Left Jamb (Plan) 

1. Select all the left jamb symbolic lines > Click Temporary Hide/Isolate shortcut > 
Hide Object 

 

Hide Object, not category, we need to be able to see the sketch lines of the solid when 
we sketch them.  This removes the symbolic lines from view so we can sketch the solid 
extrusions we need without inadvertently reference the symbolic lines instead of the 
reference planes. 

2. Solid Form > Solid Extrusion > Lines > Sketch the same profile as with the 
symbolic lines 

 

3. Click: Extrusion Properties > Subcategory > Frame/Mullion 

 

4. Reset Temporary Hide/Isolate 

5. Click: Finish Sketch 
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6. Open View > Elevations (Elevation 1): Front 

7. Select Solid Extrusion > Drag top Grip up just past Reference Plane: Top 

 

8. Click: Align > Choose Reference Plane: Top > Choose the top edge of Solid 
extrusion > Click Padlock 

 

K. Extrusion - Head 

1. Open View > Elevations (Elevation 1) Right > Zoom Region > Around Head 

2. Set View Scale: 1”=1’-0” 

3. Solid Form > Solid Extrusion > Sketch Lines > Check: Chain 

 Check work plane to see that Revit defaulted to Center (Left/Right) if you like 

4. Select previous jamb Extrusion > Temporary Hide/Isolate > Hide Object 

Again we don’t want to snap to any objects we shouldn’t, hiding them makes it easier. 

5. Sketch lines similar to the previous solid extrusion 

 

Revit remembers the last subcategory assignment we used for the jamb solid so we 
don’t have to specify it again, unless we were working with a different subcategory. 

6. Reset Temporary Hide/Isolate 

7. Click: Finish Sketch 

8. Open View > Elevations (Elevation 1): Front > Zoom Region > Around Head area 

9. Select the jamb solid > Temporary Hide/Isolate > Hide Object 
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10. Select the new head solid > Pick/drag the side grips over Reference Planes: 
Rough Opening Right and Rough Opening Left 

 

11. Temporary Hide/Isolate > Reset 

 

12. Join Geometry 

 

13. Select each: Head Solid & Jamb Solid 

 

14. Set Visibilty of solids 

a. Select either solid 

b. Click Visibility > Un-Check: Plan/RCP & When cut… 

 

We really only want symbolic lines visible in plan views.  This makes it so.  Because the 
geometry has been joined, setting one sets both. 

L. Set up Thumbnail View 

1. Open View: 3D Views: View 1 > View > Orient > Northwest 

2. Press F8 > Click Save Icon 

M. File > Save 
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13. QUESTIONS FOR DAVID AND STEVEN (THE BOYS FROM AUTODESK REVIT): 

A. What is the reasoning behind the different colors setup in the family templates?  
Don’t we just want them all black? 

B. Why do reference planes in families have a scope box parameter? 

C. If I assign a parameter to a group does it have any impact on how Revit uses the 
parameter?  In other words, does Revit give one parameter a higher priority than 
another depending on the group it is assigned to? 

D. When we switch from generic model to door category why does a Default Elevation 
parameter get added?  It isn’t part of a door template. 

E. Does the order we create objects affect how constraints are applied? 

F. Does the order we add dimensions affect how constraints are honored? 

G. Does the direction we sketch a line affect how it behaves? 

14. APPENDIX 

A. Parameters – What are they and why do I care? (PDF in content folder) 

B. Planning – Refer to handouts for AU 2005 Class BD 35-2 

C. Guidelines to building content (Autodesk’s guidelines) (PDF content folder) 

15. TIPS 

A. When you are trying to limit what a void is cutting you can create it as a solid first, 
then change it to void.  Now you can choose what you want the void to cut instead 
of it automatically cutting everything it touches. 

B. You can push/pull voids with formulas and yes/no parameters to make them cut/not 
cut solids to create variations within one family.  (see Phil Read’s Pumpkin 
example) 

C. If you need annotation to move with some geometry, you can group them (with 
some success). 

D. Avoid over use of voids 

E. Avoid too many formulas 

F. Avoid arrays and formulas 

G. Always test in project environment 

H. Use symbolic lines instead of geometry in plans 

 


